How to jailbreak Itouch ver 1.1.2

Discussion in 'iPod touch' started by efedor, Dec 14, 2007.

  1. efedor macrumors regular

    Joined:
    Nov 18, 2007
    #1
    So thanks to you guys I discovered the happiness of having my itouch jailbroken, being a motivated itouch owner i decided to upgrade to 1.1.2 and now I cant jailbreak it!! any suggestions into getting this issue resolved? If I cant jailbreak it I will gladly go back to ver 1.1.1 if you guys help me find the site that i can download it. thanks in advance
     
  2. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #2
    here ya go partner

    download the 1.1.1 official firmware, save it to a place you will remember. (if you have safari please turn off the auto open when downloaded option)

    if your touch isn't already in recovery mode as already instructed plug touch into pc/mac load itunes up and then hold down the lock/wake button and home key keep them held down eventually your touch will shut off, keep the buttons held down and when you see the apple logo let go of the lock/wake key ONLY leaving the home key pressed down and eventually you should get the itunes logo with pic of the usb wire.

    iTunes should now say its detected an ipod in recovery mode click ok, now depending what system your using for windows hold the shift key down or for mac options key then press restore and point iTunes to the ipsw file and click open, iTunes should start restoring your touch to 1.1.1. When its done point the touch's safari to jailbreame.com, scroll down to the bottom of the page and click on install AppSnapp and soon after safari will "crash" if you wait yout touch will start to auto jailbreak, if memory serves me once the install has complete reboot your touch and your jailbroken.

    to upgrade to 1.1.2 first step, go to installer then scroll down to 1.1.1 tweaks and install oktoprep. Once installed plug ipod in to pc/mac and update to official 1.1.2. When updated grab the 1.1.2 jailbreak program and extract to a folder. If you are running windows then run windows.bat if mac then the osx file, tick install ssh and click the jailbreak button. When this has finised doing its thing power off your touch then turn it back on, your touch will reboot when loaded up (this is normal) when its rebooted you will then have a jailbroken 1.1.2

    make sure you add http://repo.us.to to installer sources and you will have a nice and easy install of iphone apps

    to add a source in installer

    1. open installer
    2. click sources
    3. click edit
    4. click add
    5. enter url
    6. click ok
    7. wait for sources to refresh
    8. go back to install
    9. scroll down to iphone apps for 1.1.1/iphone apps for 1.1.2

    for mail and maps make sure you install the prep items aswell
     
  3. j3nsen macrumors member

    Joined:
    Oct 2, 2007
    #3
  4. efedor thread starter macrumors regular

    Joined:
    Nov 18, 2007
    #4
    thanks for the advice, I cant seem to be able to restore it back to ver 1.1.1 i downlod the firmware and do the hold down options and hit restore then I choose the firmware 1.1.1 then it ask me wich file to use..I choose one by one but none seem to wor. Is there anyother way to restore ver 1.1.1 besides returning the itouch back to the store and getting a new one? thanks
     
  5. seaniguess34 macrumors newbie

    Joined:
    Dec 27, 2007
    #5
    I have a similar problem, after I downgraded to 1.1.1, installed installer, and upgraded back to 1.1.2, all with the help of touchdev.net, I got to step 5-3 "download and extract the 1.1.2 jailbreak..." and it was just a link to rapidshare.com (needless to say, I was confused). So I come here and see that I need to download the jailbreak from conceited software and I did, but now I'm lost again.
    It would be great if someone could tell me what I'm doing wrong, because at this point I'd be fine back with installer at 1.1.1
     
  6. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #6
    how are you lost?

    is it that the 1.1.2 jailbreak program isn't working? are you not sure what to do with the program??
     
  7. seaniguess34 macrumors newbie

    Joined:
    Dec 27, 2007
    #7
    basically, when I downloaded, I didnt know what to do with it
     
  8. seaniguess34 macrumors newbie

    Joined:
    Dec 27, 2007
    #8
    I guess its more that I don't know what "windows.bat" is.
     
  9. albinoAZN macrumors regular

    Joined:
    Nov 19, 2007
    #9
    ok guys, it's really simple.
    1. Download this 1.1.1 file. Make sure that when you download it, it stays as either a .zip or .ipsw, if not, download it with a different browser. If it's a .zip, just rename it to .ipsw. Put this somewhere you can remember (like your desktop).
    2. Connect your iPod and put it in restore mode (hold home+sleep, let go of sleep after 10 seconds, keep home held down), open iTunes if it doesn't by itself, and select your iPod in the left pane.
    3. Option+click restore (shift+click on windows).
    4. Select the .ipsw file and hit ok.
    5. Once it's finished restoring, go to http://jailbreakme.com on your ipod and click "install appsnapp" at the bottom.
    6. Once that's finished, open installer, and click on All Packages, then select OkToPrep. Install this.
    7. Now connect your iPod, open iTunes, and select it in the left pane.
    8. Click on Upgrade (NOT RESTORE).
    9. Let it Upgrade.
    10. Download this Jailbreak package and extract it your desktop.
    11. Make sure your iPod is still connected, and open the folder you just downloaded. If you're on windows, double click Windows.bat, if you're on mac, double click Jailbreak.jar.
    12. Follow the on-screen instructions to jailbreak it.
    13. You're done.
     
  10. efedor thread starter macrumors regular

    Joined:
    Nov 18, 2007
    #10
    I still cant

    Hey albino you make it look so easy but after i download the 1.1.1 and i try to access it it had like 6 different files and none are ipsw files. I wish someone from el paso tx could help me out on this simple project! i guess ill have to wait till feb and pay apple for a software program that does it :( happy new year to all.
     
  11. wildcardd macrumors 6502a

    Joined:
    Mar 26, 2007
    Location:
    Denver, CO
    #11
    Read Albino's step 1 again. I think you missed something in your eagerness:
    If it's a .zip, just rename it to .ipsw.
     
  12. albinoAZN macrumors regular

    Joined:
    Nov 19, 2007
    #12
    That means that you downloaded it, and it automatically extracted it. In safari, go to Preferences (cmd+,), and uncheck the box that says "Open 'safe' files after downloading". Now re-download the file, and it should be an .ipsw file.
     
  13. MK25toLife macrumors regular

    Joined:
    Aug 7, 2007
    #14
    Ok I got a really stupid question, when I am downloading all this stuff am I doing it on my Touch via WiFi or am I doing it on my computer then transferring over to my Touch via USB? I plan on buying my Touch today and want to hit the ground running once I open it. Excuse me for such a silly question.
     
  14. 619 macrumors member

    619

    Joined:
    Dec 30, 2007
    #15
    This seems really complicated. Is there any way of bricking the iTouch though?
     
  15. efedor thread starter macrumors regular

    Joined:
    Nov 18, 2007
    #16
    Albino your a genius

    OK I changed the preference and it worked exellently, thank you and happy new year.
     
  16. mizzoufan macrumors newbie

    Joined:
    Jan 5, 2008
    #17
    issues with upgrade

    I have a new iTouch running 1.1.2. I went through the great directions on this thread, and everything works as described, but when the ipod reboots after running the 1.1.2 jailbreak, it gets stuck with the picture of the usb cable, and the itunes logo. I'm sure I missed something, but I've tried this 4 times, starting from scratch each time. I found in the readme in the 1.1.2 jailbreak that you're supposed to shutdown itunes before double clicking the jailbreak.jar. That didn't help. I've rebooted the mac, and the ipod. I currently have it jaibroke and running 1.1.1 until I can get this resolved.

    Any ideas?
     
  17. cjjnovi macrumors newbie

    Joined:
    Jan 21, 2008
    #18
    omg

    I Must have downloaded those 1.1.1 Software things 1 bizzilion times

    And My itouch Will Not Downgrade and its keeps saying theres an Error yet i keep doing it over and over deleting it and redownloading and the same error occurs this is getting me aggrivated

    Someone tell me Whats Going on.
     
  18. dlx000 macrumors newbie

    Joined:
    Apr 24, 2008
    #19
    can't can't jailbreak with 1.1.1 ipsw! - HELP!!!!

    I am trying to jailbreak 1.1.1 in order to install 1.1.2 but
    keeps getting an Error. Won't let me install 1.1.1!!!!!

    i use Mac with iTunes 7.6.2
    is there any issues with iTunes or hidden preferences?????

    PLEASE HELP!!!!
     

Share This Page