How to Jailbreak using iOS4 on ipod touch 2g

Discussion in 'iPod touch Hacks' started by lokster, Jun 22, 2010.

  1. lokster macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #1
    Ok guys this is way way way too easy


    1. Download and update itunes to 9.2
    2. Download ipod touch 2g iOS4
    Link http://www.redmondpie.com/download-ios-4.0-for-iphone-4-9170229/

    3. Download Redsn0w .0.9.5b-5 for windows
    http://rapidshare.com/files/401513205/redsn0w_win_0.9.5b5-3.zip
    for mac
    http://rapidshare.com/files/401512748/redsn0w_mac_0.9.5b5-3.zip


    whatever firmware you have you CANNOT jailbreak from one firmware to another, so you have to restore the ipod touch 2g to an OFW 4.0

    (Hold shift while clicking restore then point to the downloaded ipod touch 2g)


    once that is done


    use redsnow, point to the downloaded ipod touch 2g firmware, FOLLOW INSTRUCTIONS and read carefully!

    make sure multitasking and wallpapers are checked.

    and tahdah! fully working multitasking, jailbroken ipod touch! works like a charm, multitasking isnt sluggish at all!
     
  2. stainlessliquid macrumors 68000

    Joined:
    Sep 22, 2006
    #2
    I jailbroke and there arent any icons for the "songs, albums, artist, etc" buttons at the bottom when in music, just the text with an empty space above it. Is that normal?
     
  3. scoldinho macrumors newbie

    Joined:
    Jun 22, 2010
    #3
    Please Help

    I keep on getting an error message telling me the ispw file is not recognized it keeps on doing this everytime I select the file in Redsn0w. If someone can help it would be much appreciated. The file I am selecting is the official software update which is iphone1,2_4.0_80923_restore.ispw
    Thanks in advance.
    I am on Windows Vista.
    And its a Iphone 3G.
     
  4. Dale Sorel macrumors 6502a

    Dale Sorel

    Joined:
    Jan 12, 2003
    #4
    I just did this jailbreak on my 8GB MB 2G iPod touch and it"s great!

    But just a word to those out there interested in doing this to your touch, it's got to be the MB model or else it won't work. In fact, once you download the 0.9.5b5-3.zip, then decompress and run it it asks you if you have the MC model. If you click yes it tells you it won't work and quits.

    I don't know how the legit version of the multitasking works, but the setup in this jailbreak is sweet! When you double click the home button the bottom of the screen raises up so you can select or quit whatever you have running. Very cool! Sure sometimes things slow down a little, but I think it's totally worth it.
     
  5. stainlessliquid macrumors 68000

    Joined:
    Sep 22, 2006
    #5
    I restored then rejailbroke and the icons seem to be fine, although I didnt enable multitasking this time since it disabled the doubletap home button to go to ipod (I would rather have that than multitasking), multitasking may have screwed up the icons.
     
  6. lokster thread starter macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #6
    im not too sure about the 3g, but the ipod touch 2g works, you should head over to the other side of the forum lol.

    should be recognized unless the software update you downloaded is incomplete.
     
  7. lilcosco08 macrumors 65816

    lilcosco08

    Joined:
    May 27, 2010
    Location:
    Dayton
    #7
    To those with the unable to recognize IPSW error:

    Download the GM release and have redsn0w use it (while the official iOS4 is installed) It should recognize it and the rest of the jailbreak process will work
     
  8. doh23 macrumors newbie

    Joined:
    Jun 21, 2010
    #8
    Is it possible to jailbreak a MC 2G Ipod Touch yet? I tried yesterdat with redsn0w and it said that it wasn't supported
     
  9. Resplendent macrumors member

    Joined:
    Sep 13, 2008
    #10
    Jailbroke my 2G last night for the first time and it's running splendidly. Multitasking, Battery %, Orientation Lock, Wallpaper all working fine, if a tad slow. Honestly I can't think of any ways it could be improved now. Thank Xenu for redsn0w!
     
  10. wywern209 macrumors 65832

    wywern209

    Joined:
    Sep 7, 2008
    Location:
    do you rly want to know?
    #11
    you need to get a copy of the GM ipsw and point redsn0w to that. i did that and it worked for me.

    EDIT: lilcosco08 beat me to it.
     
  11. Yhapster macrumors newbie

    Joined:
    Dec 6, 2008
    Location:
    Guyana
    #12
    Just finished jaibreaking my ipod 2g mb model to ios4..using the redsnow beta..i enabled multitasking and background wallpaper and so far works fine..

    note:i was on the official ios4 firmware before jailbreaking
     
  12. AlphaTeam macrumors regular

    AlphaTeam

    Joined:
    Sep 26, 2005
    #13
    So for some reason I can't get it to work.
    I've downloaded the new OS and Redsn0w. I get in to Redsn0w and get to the part where is has you hold the buttons down. On part 3 it gets to about 20 seconds in the countdown, skips to the next step and the ipod stays at a white screen. Redsn0w just says "waiting for reboot". If I hold down both buttons it comes out of it, but never finishes.

    EDIT: Sorry I have a 2G MB version.
     
  13. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #14
    Are you sure you are pointing redsn0w to the correct firmware file for your device?
     
  14. AlphaTeam macrumors regular

    AlphaTeam

    Joined:
    Sep 26, 2005
    #15
    I dunno what the problem was. I tried it at work and was successful.
     
  15. jjimenez92 macrumors newbie

    Joined:
    May 1, 2009
    #16
  16. cathyy macrumors 6502a

    Joined:
    Apr 12, 2008
    #17
    Just a quick question...is it possible to jailbreak using this hack if I haven't jailbroken my iPod Touch 2G yet? I've got a iPod Touch 2G MB running 3.1.3
     
  17. Achu macrumors newbie

    Joined:
    Jun 15, 2010
    #18

Share This Page