iPod touch How to jailbreak with a broken home button?

Discussion in 'Jailbreaks and iOS Hacks' started by fenderbendr, Jan 28, 2013.

  1. fenderbendr macrumors member

    Joined:
    Jan 28, 2013
    #1
    Ok, so the home button on my iPod touch 4g has been broken for a while. I've been using the home button in Assistive touch an alternative and its been working well. I'm now getting tired of it as it takes up a chunk of my screen and is getting annoying.

    I know there's a way to enter dfu mode without using the home button via the dfu ipsw mode on an older version of redsnow. I've tried that method before with no success. It said the version wasn't compatible or something and when I tried to enter dfu mode via an iTunes restore, it didn't work. I'd like to jailbreak my device when the new 6.1 jailbreak comes out.

    So I have a few questions:

    What is the best and latest method of jailbreaking without a home button?

    If I do get a working jailbreak, I know you can set a different button as a home button. When the device is in sleep mode, will the button I mapped as the home button register?

    Any advice would be great.
     
  2. nepalisherpa macrumors 68020

    nepalisherpa

    Joined:
    Aug 15, 2011
    Location:
    USA
    #2
    If the new jailbreak requires you to be in the DFU mode first then there are programs to help you with that. For now, just calm down and be patient.
     
  3. fenderbendr thread starter macrumors member

    Joined:
    Jan 28, 2013
    #3
    Thanks, I'm not mad or anything, not sure why you think I am.

    I'll wait until the jailbreak is released then before worrying about this.
     
  4. maccompatible macrumors 6502

    Joined:
    Mar 26, 2012
    #4
    Not being calm does not equate to being angry, not sure why you think he said that.

    On topic, I don't think absinthe required a home button or DFU mode. We'll see if the 6.1 jailbreak is as easy.
     
  5. fenderbendr thread starter macrumors member

    Joined:
    Jan 28, 2013
    #5
    I'm new here so I'm sorry if you misinterpreted what I said. I'm very eager and not at all angry.

    That's good news if it doesn't require dfu mode.
     
  6. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #6
    The tool may not require DFU mode, this is true. But having access to DFU is integral in the jailbreak process in case maintenance is required, IMO.

    Redsn0w has the ability to put your phone into "soft DFU" mode without hardware required, but personally I don't like that method. It sounds like you tried it and agree.

    Your best bet, is to maybe try the genius bar? How long out of warranty is it? Sometimes you get lucky.
     
  7. fenderbendr thread starter macrumors member

    Joined:
    Jan 28, 2013
    #7
    The iPod is literally on its last limb. Its two years old, has a small blob of stuck pixels that I can't get rid of on the screen, and it's far out of warranty. It probably wouldn't be worth it to fix the home button at this point. I'm planning on upgrading when/if the new IPad mini comes out. :D

    So I'll just wait and see what this jailbreak brings.
     
  8. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #8
    Darn that stinks.

    Well eBay is your friend and I'm sure you could find an iPod Touch 4 for less than $100.
     
  9. fenderbendr thread starter macrumors member

    Joined:
    Jan 28, 2013
    #9
    Meh, I think I'll just hold out until I upgrade. I'll try really hard to get it jailbroken when it's released.
     
  10. devinu macrumors newbie

    Joined:
    Feb 2, 2013
    #10
    Go to settings/ general/ accessibility / turn on assisted touch
     
  11. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #11
    Great, thats what he was using already…

    @OP
    You mentioned th DFU IPSW on older redsn0w, that is still an option under Extras/Even more/DFU IPSW

    Might give it another shot on latest redsn0w.

    What you might have to do is download both the 6.0 and the 6.1 IPSW.

    First in redsn0w goto Extras/Select IPSW and select the 6.0 IPSW
    Thand go to Extras/even more/DFU IPSW and select the 6.1 IPSW

    redsn0w is still not optimized for anything newer than 6.0 and this is the workaround.
     
  12. fenderbendr thread starter macrumors member

    Joined:
    Jan 28, 2013
    #12
    Yeah, I have already created a 6.1 dfu with the latest redsnow to be ready in case the new jailbreak tool requires dfu mode.

    I'm pretty sure that's the problem I had last time. It said that redsnow only supports the x.0 versions. I'll try you're method though.
     
  13. devinu macrumors newbie

    Joined:
    Feb 2, 2013
    #13
    First sentence and I completely missed it.
     
  14. tomzvvip macrumors newbie

    Joined:
    May 1, 2013
    #14
    you can do it. my blog has a tutorial that can jailbreak iOS 6 with broken button. but u can't just boot. so u must rejailbreak.
    http://fanboy31.blogspot.com/2013/04/hi-today-i-want-to-post-about-how-to.html
     

Share This Page