How to keep MBP from shutting down

Discussion in 'MacBook Pro' started by atr, Aug 30, 2010.

  1. atr macrumors regular

    Joined:
    Dec 16, 2009
    #1
    I use Daylite and Daylite Server on my MBP connected to the net and sync my iPad running Daylite Touch through my 3G connection. It works great while I have my MBP running. I want to set up my MBP so that it will run without shutting down (screen blanked out). I just want to do this for a few days to see how it works out. If I like it I will get a Mac Mini to run as the server instead of the MBP.

    The problem I am having is that no matter how I adjust the settings on the MBP, after awhile it shuts down Daylite and Daylite Server. Daylite Server shuts down and puts out an error message and everything just hangs there. I figure I must be doing something wrong in the settings but don't know what. Any suggestions would be appreciated. I tried searching the forums, google, apple support, etc. but haven't found anything - of course I am probably searching all those wrong too....

    I set the Energy Saver settings to never go to sleep but that doesn't seem to help.
     
  2. atr thread starter macrumors regular

    Joined:
    Dec 16, 2009
    #3
    That would be for me, and even that has an expiration...

    Thank you GGJstudios, I wonder why that didn't show up in all the google searches I did.

    I am trying it out now.

    Thanks!
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    What are you talking about? Caffeine doesn't have an expiration.
     
  4. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #5
    Energy saver settings should be set sleep time to never. Be sure you set this for the adapter and not battery if you want it to never sleep while plugged in.
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Caffeine overrides energy saver settings. There's no need to modify them.
     
  6. atr thread starter macrumors regular

    Joined:
    Dec 16, 2009
    #7
    I was referring to myself, I can drink caffeine to stay awake, but even then - only for so long.

    BTW - I started the Caffeine widget this morning before I keft for work and now I can't connect to my MBP from my office. I assume that it must have shut down but will know when I get home. I still have something wrong.
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Make sure you have set the default duration the way you want it:
    ScreenCap 2.PNG
     
  8. atr thread starter macrumors regular

    Joined:
    Dec 16, 2009
    #9
    I had it set up properly, and when I got home my MBP was still running correctly (I kept the screen dimmed all the way down).

    The problem had nothing to do with the MBP. My wife decided to work from home this afternoon so when she got there she disconnected the wifi network so she could hook up her laptop directly to the internet cable modem.

    Caffeine was working perfectly, as advertised. Just had no where to go....

    Once again, thanks for your help.
     

Share This Page