How to keep your opti-bay hard drive in sleep until accessed.

Discussion in 'macOS' started by DramaLLama, May 8, 2011.

  1. DramaLLama, May 8, 2011
    Last edited: May 8, 2011

    DramaLLama macrumors 6502

    Joined:
    Feb 6, 2011
    #1
    First off I'm using the MCE Technologies opti-bay kit so I don't know if that will have a difference or not but I've read that sometimes the cheaper kits will not put the hard drive to sleep properly.

    Use Cocktail and set your settings:

    I have my hard drives to spin down after 1 min of inactivity (default is 10 min).
    [​IMG]

    Your primary hard drive that your OS is installed on will not go into sleep mode after just 1 min (correct me if you've found otherwise please).

    My opti-bay hard drive is labeled 'movies' as the only thing I keep on it is.. movies.. so I don't want it spinning all the time even when I'm not using it.
    [​IMG]

    You must disable spotlight indexing as shown in the screenshot above to keep spotlight from accessing it every 5 min or so to index the files. If you don't do this then your opti-bay hard drive will continue to spin-up for spotlight to index.

    You can still search the files it will just be slower.. not noticeable at all IMO since all I have is movie files so it's just looking for one name and not through a bunch of system files.



    If you disable indexing from your spotlight settings in 'system preferences' (privacy tab) then the indexing AND Finder will be disabled.. so you won't be able to search at all. If you disable indexing in this Cocktail app then it will still let you search files on the drive it just won't let spotlight access it and spin the drive up to index them.


    Please let me know if this was helpful, I've been trying to fix this problem for a day or so and anything I googled was all the same not-really working kind of stuff..
     
  2. Biff... macrumors 6502a

    Biff...

    Joined:
    Jun 16, 2010
    Location:
    Sherman Oaks, CA.
    #2
    Thank you for this post, I will let you know if it works.
     
  3. ArmanUV macrumors member

    Joined:
    Jul 15, 2010
  4. Biff... macrumors 6502a

    Biff...

    Joined:
    Jun 16, 2010
    Location:
    Sherman Oaks, CA.
    #4
    I tried it, didn't work.
     
  5. tekkietekkie macrumors member

    Joined:
    Aug 26, 2010
    #5
    same here, anyone have anyway to get it to work?
     
  6. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #6
    In my experience you also cannot have iStat running, as it just always seems to send out a command which wakes up the drive for just a few seconds about every 5 min. It is not a huge power draw beside the startup but it is really annoying.
    Disabling smart checking and every hdd monitoring doesn't help. All I wanted to monitor was the current discharge rate of the battery and CPU temps but iStat cannot let my hdd sleep.

    PS: It would be really nice if spotlight was smart enough as not to wake up unmounted drives, because my hdd doesn't just sleep I unmount it and you still have to do all this things. Spotlight too just wakes it up, notices that it is unmounted and lets it sleep again.
     
  7. ArmanUV macrumors member

    Joined:
    Jul 15, 2010
    #7
    Thanks for the tip. Did you file a bug report with the dev?
     
  8. ArmanUV macrumors member

    Joined:
    Jul 15, 2010
    #8
    So I finally received my 15" MBP today. The OWC data doubler installation went perfectly and not I got OS X Lion and Win7 on the SSD (original bay) and the stock 7500rpm Hitachi in the optibay.
    I did everthing that was recommended by OP with no luck. BUT adding the HD partitions to spotlight's privacy list did the trick! :D
    I won't be able to search those partitions but at least now I have a perfectly silent MBP with increased battery life.

    So those of you who didn't get it to work try adding ALL the partitions on your hard drive to Spotlight privacy list after running Cocktail.
     
  9. Satnam1989 macrumors 65816

    Joined:
    Nov 16, 2011
    Location:
    Illinois
    #9
    hey guys I'm also trying this out....so far my HDD in the optical bay does not spin down with CockTail, I hav the following settings:

    - Alias for my Videos folder from my HDD on my Desktop (don't access it all the time)
    - My Torrent program downloads files to my HDD(application isn't launched 99% of the time as i barely use it)
    - Indexing is off as i hav added my bootcamp and my storage HD as I added them to the privacy tab in the spotlight option under system preferences(both partitions are on my HDD in optical bay slot)
    - Did not buy license for Cocktail(do i need it just to put the HDD to sleep?)


    Also does Cocktail need to stay in my dock running in order for these settings to work?(its been running for a while now but I'm asking for future) any suggestions would help, my laptop specs and config can be found in my signature.
     
  10. Satnam1989 macrumors 65816

    Joined:
    Nov 16, 2011
    Location:
    Illinois
    #10
    So far tested Cocktail is a fail to set the second HDD to sleep....on Lion 10.7.2 Running SSD+HDD setup only way drive ever goes to sleep is when i eject the partitions from my desktop and to wake it up I have to use disk utility to remount them.
     
  11. andy71600 macrumors newbie

    Joined:
    Jun 22, 2010
  12. tribalvibes macrumors newbie

    Joined:
    Feb 3, 2012
    #12
    Disable TimeMachine local

    At least for my setup, SSD+HDD internal in an OWC DataDoubler/Optibay setup, it was Time Machine local/mobile backups that were causing the spun-down HDD to spin up again every few minutes.

    Turning Time Machine off, or disabling the 'mobile' backups with
    tmutil disablelocal
    (and rebooting)
    seems to keep the HDD spun down.

    Verify this by looking at, e.g.,
    fs_usage -w -f filesystem | grep "your HDD root path"

    and toggling Time Machine.

    There may be other things spinning up the HDD too but TM was the main annoyance.

    Anyone know a way to disable these selectively for only the HDD while keeping them on for the SSD ?
     

Share This Page