How to kill mouse acceleration in OS X

Discussion in 'macOS' started by *LTD*, Nov 1, 2009.

  1. *LTD* macrumors G4

    *LTD*

    Joined:
    Feb 5, 2009
    Location:
    Canada
    #1
    This works best with "How to speed up mouse tracking in OS X", found elsewhere in this forum.

    Note that mouse acceleration in OS X cannot be terminated completely, unless you are using something like USB OVerdrive. Assuming you are not using or do not want to use USB overdrive or similarly complete solution, read on.

    Download the source here:

    http://forums3.armagetronad.net/download/file.php?id=9698

    You'll get a Unix executable file. Open a Terminal window and drop the file onto it.

    After "killmouseaccel", type "mouse" (without quotation marks), and make sure a space remains between the two words. Then hit enter.

    Effect is immediate. Logging out or restarting will kill the effect, so you'll have to run it each time. You might be able to set it to an automatic script upon logging in. Something I haven't figured out yet.

    Ideally, it's best to increase the mouse tracking speed first (using instructions I posted elsewhere in this forum), which should be permanent until you reset the speed in the actual mouse pref pane, and then run the executable to kill mouse acceleration.
     
  2. appleguy123 macrumors 603

    appleguy123

    Joined:
    Apr 1, 2009
    Location:
    15 minutes in the future
    #2
    If you don't mind me asking, what is mouse acceleration?
     
  3. lewis82 macrumors 68000

    lewis82

    Joined:
    Aug 26, 2009
    Location:
    Totalitarian Republic of Northlandia
    #3
    I guess it's what makes the cursor go faster if you move the mouse faster...

    Because without it, the cursor would only move accordingly to the distance the mouse moved.
     
  4. gupperman macrumors newbie

    Joined:
    Nov 25, 2009
    #4
    Great stuff, really! Thanks for posting it.
    I've just switched to MAC after a life on windows and the mouse acceleration thing almost made me go back to windows. :) My hand hurts after 3 days with this cursor which moves like you're dragging it in mud on the screen.

    Acceleration sucks when you move your cursor very slow, it gets slower and slower...so if you are in the inbox for example, and you click on an email and then want to move the cursor on another email 3-4 rows below, it takes ages to get there...and it's driving you nuts!!!

    The little app LTD provided saved my live and I start to enjoy the mac finally. I now need to find a way to run the script at booting because the effect goes away after each restart, which sucks. If you find how to do that, please post it! Please. I found some resources but since I'm new to the mac world, they sound like chinese to me.

    However, the script rocks... it's much cleaner and simple than all the shareware crap. Thanks LTD.
     
  5. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #5
    I still don't see any reason to turn off mouse acceleration. It's there for a reason, it just happens to have a really crappy curve in OSX. USB Overdrive with the right settings or MS Intellipoint drivers (if using MS mouse) fix it nicely.
     
  6. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #6
    Its a matter of habit. I used mouse accel all my life and only a couple of months ago turned it off due to problems of making it work consistently with my Razer Copperhead.

    I'm glad I did, though there are a few times when I miss it.
     
  7. kreidel macrumors member

    Joined:
    Nov 16, 2009
    #7
    Is there a way to make it work when I load a game? I tried to use it in World of Warcraft and it does not work in game, only on the desktop.
     
  8. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #8
    I have acceleration disabled via USB Overdrive, but I think this method works with terminal fix as well.

    When in WOW open preferences and look for the Mouse tab. Once there set the mouse speed slider all the way to the left.

    This made mouse behavior in WOW the same as in OS X. I am yet to encounter another game that doesn't obey the system mouse rules. Hope this helps :)
     
  9. Infrared macrumors 68000

    Infrared

    Joined:
    Mar 28, 2007
    #9
    That's not the source. It's an executable. This source is here:

    http://forums3.armagetronad.net/viewtopic.php?t=3364

    It can be compiled as follows:

    Code:
    gcc killmouseaccel.c -o killmouseaccel -framework IOKit -framework Carbon
     
  10. kreidel macrumors member

    Joined:
    Nov 16, 2009
    #10
    Can you explain this more please? Do you mean when I am playing WoW I change it in there? So I set the slider all the way left which is the slowest setting?
     
  11. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #11
    Yes. Enter world, press esc, go to Interface, Mouse and set Mouse Sensitivity to the lowest. This forces WOW to use the system's setting.
     
  12. kreidel macrumors member

    Joined:
    Nov 16, 2009
    #12
    Did not work but thank you.

    Anyone know another way?
     
  13. termhn macrumors newbie

    Joined:
    Nov 30, 2014
    #13
    The first post works a charm, thanks

    Also, here's how to get it to run on startup:

    1. Download and unroll the tarball in the first post
    2. You should now have a file in downloads called killmouseaccel with no extension. I decided to rename it to killma (no extension still) for convenience and you should to to make the rest of the guide work.
    3. Right click and copy the newly renamed killma file
    4. In the top menu in finder click go and then go to folder and type in "/usr/local/bin"
    5. Paste (Command-V) killma into this folder
    6. You should now be able to open terminal (click spotlight or Command-Spacebar then type terminal) and then run:

    killma mouse

    to eliminate your acceleration.
    7. To make this automatically apply on startup, inside terminal do the following. It will ask for your password, when you type it it won't actually type any letters but you are actually typing. Just type in your password and hit enter:

    sudo mkdir /System/Library/StartupItems/killma && cd $_
    sudo nano killma.sh

    7a. You're now in a little text editor. Type the following:

    #! /bin/bash
    killma mouse

    7b. Press Control-X and then Y when asked if you want to save the buffer

    7c. Now run:

    sudo chmod +x killma.sh

    8. Done! It should kill your mouse accel at startup now.
     

Share This Page