How to link your Apple TV to one remote only

Discussion in 'Apple TV and Home Theater' started by FrenchPB, Mar 15, 2011.

  1. FrenchPB macrumors 6502

    Joined:
    Sep 15, 2005
    #1
    Hey all,


    I have recently bought an Apple TV 2, and I really enjoy the product. However, when I use the little remote, it impacts all the Macs in the room. For instance, when I press menu on the Apple TV remote, it starts cover flow (the same interface as on the apple tv, not sure it's named cover flow) on my MacBook Pro.

    Is there a way to "link" the apple tv remote to the apple tv ONLY, so that it doesn't wake up the other Macs in the room.

    This is very annoying as it is right now.
     
  2. JJP9398 macrumors member

    Joined:
    Jan 31, 2009
    #2
    Same problem

    I had the same problem even after I paired the remote with ATV2. You can pair the remote under settings on the ATV2. I went a step further and turned off the IR port on my iMac. You can turn off the IR sensor on the computers by going system preferences...Security...General Tab...it should be the very bottom one.
     
  3. FrenchPB thread starter macrumors 6502

    Joined:
    Sep 15, 2005
    #3
    Thank you, I'll do that :)
     
  4. newagemac macrumors 68020

    Joined:
    Mar 31, 2010
    #4
    Pairing a remote to a computer or Apple TV means that the computer or Apple TV can only be controlled by that particular remote. But that remote can and still will control other computers and ATVs. So the solution is to pair the other devices with their own remotes or just turn off the IR on them if you have no remote for them. You can do that under the security settings on your Mac.
     
  5. bcburrows macrumors 6502

    bcburrows

    Joined:
    Mar 25, 2009
    Location:
    Bristol
    #5
    I have two apple remotes

    1) is the old style white one, came with an old MBP
    2) is the new style one, came with the ATV2

    I have paired the white remote to my new MBP and I have paired the
    new remote to the ATV2

    BUT STILL

    they continue to work on both devices and not each device exclusively as I assumed they would by being 'paired'

    Any suggestions
     
  6. tombee macrumors member

    Joined:
    Sep 12, 2008
    #6
    similar situation which hopefully will lead to a solution to help both of us.

    I have atv 1 and atv 2 both in the entertainment center.
    would be fine with having separate remotes to control the boxes, but "pairing" the old atv remote with the atv1 doesn't stop atv2 from accepting the remote commands.

    at this point, i've reverted to putting tape over the atv1 ir window and using the remote app to control it.
     
  7. eTip, May 2, 2011
    Last edited: May 2, 2011

    eTip macrumors 6502

    Joined:
    Mar 12, 2009
    #7
    @bcburrows: I suppose it's possible that you have two Apple remotes with the same ID. Try changing the ID on one of them. To do so, hold Menu and Select (center) for 10 seconds (other guides say 5 seconds but I have found that not to be long enough). That should increase the ID by one. If you didn't unpair before doing this, this remote should now NOT work with the device you had it paired with. (If it still controls both devices, either the ID change didn't work or something else is wrong).

    If it did work, you need to unpair:

    "You can use ANY Apple Remote to unpair Apple TV from a remote. Press and hold the Menu and Previous/Rewind buttons on a white Apple Remote for 6 seconds, or the Menu and Left buttons on an aluminum Apple Remote for 6 seconds." (from apple support page linked below).

    Then pair it again. It's best to do the pairing / unpairing with the device you dont want paired OFF or at least with the remote not pointed at that device.


    Apple support article:

    http://support.apple.com/kb/HT1555
     
  8. eTip macrumors 6502

    Joined:
    Mar 12, 2009
    #8
    How are you saying anything different than what is in post #4?
     
  9. bcburrows macrumors 6502

    bcburrows

    Joined:
    Mar 25, 2009
    Location:
    Bristol
    #9
    Well I am guessing there is some issue as I turned off IR on my mbp, after I had paired one to it, but alas both remotes are still controlling it.....
     
  10. eTip macrumors 6502

    Joined:
    Mar 12, 2009
    #10
    Well, obviously - if IR is truly off, it shouldn’t respond to either remote so something isn't right. Still, I would change the ID of one of the remotes & see what happens. What do you have to lose? There is software that will show you the ID of your remote so you can be sure that they have different ID's. Both Remote Buddy and iRed (not sure if that one's still around) will do this & I think they both have trial versions.
     

Share This Page