Resolved How to make QT not the default program for videos?

Discussion in 'macOS' started by Mackist, Feb 18, 2015.

  1. Mackist, Feb 18, 2015
    Last edited: Feb 19, 2015

    Mackist macrumors member

    Joined:
    Dec 30, 2013
    #1
    Got Yosemite.
    In the past you could right-click on a file, click open with, select a program, click on the check-mark, and the format would always be opened with it in the future, automatically.
    Not no more. Apple just won't be happy being the second richest corporation in the world, so now no matter how many times you do this, it still opens videos with their stupid QuickTime, only to tell you a minute later that it can't open the video. And guess what, can't even delete the program!
    Not like 1984 at all.
    Many thanks!
    MC
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    After you select the app you want, did you click "Change All", just below that?
     
  3. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #3
    I think you maybe mistaken there. You had to right click on the file, select the "Get Info" option which opens the Info Panel. Then select the program that you want to run the file, and then click on the "Change All" button. Certainly in OS X versions upto 10.9 anyway.
     
  4. Mackist thread starter macrumors member

    Joined:
    Dec 30, 2013
    #4
    > "Get Info" option which opens the Info Panel. Then select the program that you want to run the file, and then click on the "Change All" button.

    Genius, that worked, thank you!!!
     

Share This Page