How to make Time Machine see my Airport disk?

Discussion in 'Mac Accessories' started by boston04and07, Nov 9, 2010.

  1. boston04and07 macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #1
    What I'm trying to do is use my Airport Extreme's attached hard drive (a Western Digital MyBook) as a wireless Time Machine disk. I know it's not officially supported by Apple anymore, but I did this for several months in my old apartment and it worked fine. I moved a few months ago, and just got around to setting up my TM disk now (I know, I know, I should have done it sooner :rolleyes: ) Since it had been so long I decided to just erase the disk and start fresh. I erased it, connected it to my Airport Extreme, and it shows up fine in the Finder as a folder on the Airport. However, when I click Select Backup Disk in Time Machine preferences, nothing is found. I'm not doing anything any different this time around, I don't think...

    I searched the forums and found two suggestions - the first being to save a text file called "com.apple.timemachine.supported" on the disk, and the other being to enter "TMShowUnsupportedNetworkVolumes 1" into the Terminal. The text file trick didn't work and the Terminal command wasn't recognized. Any ideas on how I can get Time Machine to see this hard drive?
     
  2. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Cal
    #2
    I normally see mine on the sidebar on finder, click on the airport express, then double click on the disk folder and it pops up on my desktop as an airdisk.
     
  3. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #3
    The TMShowUnsupportedNetworkVolumes 1 is supposed to be part of a "defaults write" command executed in Terminal. I did a quick google and found references to:

    Code:
    defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1
    I have no idea whether it is a good or bad idea for you to try it.

    Brian33
     
  4. rockytopmoose macrumors newbie

    Joined:
    Jun 22, 2010
    #4
  5. boston04and07 thread starter macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #5
    Rgarjr, yeah, it is showing up in the Finder as well as a volume on the desktop. Rockytopmoose, it's also showing up as a shared disk in Airport Utility. I have all sharing options enabled. I have no problem accessing the drive or putting other content on it - it's just that the Time Machine preference pane doesn't see it as an available disk. Hmm. Brian33, I could have sworn I added the defaults write com.apple.systempreferences prefix but then again I was really tired when I tried this last night so I very well could have left it off. :rolleyes: I'll try the Terminal command again when I get home though.

    I'm a little confused about something though - this was supported at one time by Apple, right? When I had this setup before I could have sworn I read many posts on this forum about how it's virtually the same thing as owning a Time Capsule, how great it works, etc. In fact I thought it was the widely held belief that it was a better option due to the problems the TC has had over the years. After searching I can't seem to find any of that, only references to how it's unsupported and can be a little shaky. I never experienced any of that - am I missing something? Strange...
     
  6. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #6
    Forgive me for asking such a basic question, but how did you format the drive? FAT32 or HFS+?
     
  7. boston04and07 thread starter macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #7
    It was definitely HFS+. First thing I thought of, too! :)
     
  8. hellfire88 macrumors 6502

    Joined:
    Apr 28, 2008
    #8
    Yea, it's pretty crappy that Apple used to support this (I believe it was an advertised feature on their website at the Airport Extreme product page) but no "took it away" Apple-style.

    I used to have a Time Capsule that was a bit flakey and heated up a lot (the thing got HOT) so I was about to go pick up a latest-gen Airport Extreme and hook up a 1.5TB HDD to it in an external enclosure with a fan (to cool the HDD). Now I'm not so sure how smoothly it'll work as a time machine backup disk via Airdisk :(
     
  9. boston04and07 thread starter macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #9
    Well after fiddling around with it some more, it appears to be working now! *fingers crossed* I restarted the drive, unplugged it and reattached it, and tried the Terminal command again. The first backup is running at a snail's pace so I might plug in via ethernet and see what happens there. Thanks, everyone for your help!! Very much appreciated.

    I wonder why this is unsupported by Apple...hope it's nothing more than their attempt to boost Time Capsule sales!
     
  10. boston04and07 thread starter macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #10
    Just thought of one more question. I'm thinking about getting a new Macbook Air in a few months, and would want to set it up by restoring files from my Time Machine backup. Would it be worth getting the $29 USB to ethernet adapter instead of doing it wirelessly? I'm just not sure if restoring wirelessly would take forever, (backing up 115GB on my MacBook has taken about 16 hours or so), or if the backup wouldn't show up at first like it did on my MacBook. Thoughts?
     
  11. DJY macrumors 6502a

    DJY

    Joined:
    Dec 20, 2003
    Location:
    Canberra AUST
    #11
    Not sure it will work.
    I tried using two adaptors and an ethernet cable to attempt to do a Migration Assistant from my old Rev B MBA to my new one... and it didn't recognise it. I think the Mac needs to have a built in FireWire port for this to work.

    I ended up having to do a wireless Migration Assistant - which literally took all night.
     

Share This Page