How to mount a damaged SD card?

Discussion in 'Mac Basics and Help' started by PmattF, May 16, 2010.

  1. PmattF macrumors member

    Joined:
    Dec 28, 2006
    #1
    I have an A-Data brand 16 gig SDHC card which became corrupted/damaged in my Canon S90 (it looks like a lot of people are having problems with this card). When I put the card into the card reader attached to my Mac Pro, the volume does not show up on the desktop, or appear at all under Disk Utility. No error message of any kind pops up.

    If I look in Console, I see the following messages:
    Code:
    USBF:	28693.905	AppleUSBUHCI[0x11f5b000]::Found a transaction which hasn't moved in 5 seconds on bus 0x1d, timing out! (Addr: 0, EP: 0)
    USBF:	28696.637	[0x12238100] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 1 of Hub at 0x1d000000)
    USBF:	28696.637	[0x12238100] The IOUSBFamily was not able to enumerate a device. USBMSC Identifier (non-unique): 000000009451 0x5e3 0x723 0x9451
    USBF:	28719.906	AppleUSBEHCI[0x1208e800]::Found a transaction past the completion deadline on bus 0xfd, timing out! (Addr: 5, EP: 1)
    USBF:	28725.906	AppleUSBEHCI[0x1208e800]::Found a transaction which hasn't moved in 5 seconds on bus 0xfd, timing out! (Addr: 5, EP: 0)
    
    The last two continue to repeat.

    I have tried a variety of card recovery programs on my Mac, and on the Windows side booted under VMWare. But since the card is not mounting at all, none of these programs can see the card to try to recover anything.

    Does anybody have any suggestions? I really would like to recover these photos.
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    There are some data recovery apps out there that work wonderfully on hard drives, and I see no reason why they won't work on other media as well.

    Two I can think of are
    - DataRescue (by Prosoft Engineering) - highly recommended
    - Stellar Phoenix Data Recovery - has also received good reviews.

    Both of these are "pay-for" programs (not freeware).

    With DataRescue, you can use the app in "demo mode" to scan your volume and recover _one_ file as a "test". Assuming that the test works, you then choose to pay the registration fee, and get access to whatever else is available to be recovered.

    DR (and Stellar Phoenix) will work when NOTHING else will. This is because they don't try to "repair" a volume -- instead, they are designed to scavenge damaged volumes and recover whatever they can find.

    You also have the obstacle to overcome, that the volume "won't mount" for you.

    With an "unseen, unmountable" volume, even DR may not be able to "get at" the damaged volume, simply because it won't mount -- and thus, can't be "seen" by the software.

    I had a similar problem with a damaged partition on a hard drive. Try as I might, I could not get that partition to mount.

    My solution was to re-initialize the entire drive (yes, you read that right -- I RE-INITIALIZED the drive). Doing this "wiped clean" the directories, installing a clean, good directory in place of the corrupted ones.

    But remember - reinitializing in and of itself DOES NOT disturb the actual _data_ on the drive sectors. All it does it replace the old directory with a new one. The data from the old directory is "left in place", at least until NEW data is written over the old.

    Because I could now re-mount the bad drive, even with the former partition erased, Data Rescue could now "see" the entire drive, and thus scavenge and recover the data that was on the unmountable partition. It worked!

    Again, I suggest you give DataRescue a try. You can find it here:
    http://www.prosofteng.com/products/
     
  3. cube macrumors G5

    Joined:
    May 10, 2004
    #3
    If those applications can't work with unmounted volumes, they are not disk repair programs, they are undeletion software.
     
  4. PmattF thread starter macrumors member

    Joined:
    Dec 28, 2006
    #4
    I just downloaded the DataRescue demo -- it does not see the SD card as a drive either, since it is not mounted.

    Looking at their faq about drives not being visible does not give me much hope, as it says "If the drive fails to show up in Disk Utility, this means that the computer does not detect the presence of the drive, and no software will be able to access it either."

    Formatting the drive would probably be worth a try, but since MacOS does not acknowledge that there is a drive attached when this card is in the card reader, I can not format it there. And if I was going to format it, it probably would make more sense to do it in the camera, but the camera is giving me a "Memory Card Error" message, and the format option is grayed out in the menu.

    Any other ideas?

    I have seen suggestions that an SD card can be disassembled, and the actual memory chip separated from the controller, and the data on the memory chip accessed directly. But I suspect that kind of thing would be extremely expensive to have done.
     
  5. cube macrumors G5

    Joined:
    May 10, 2004
  6. PmattF thread starter macrumors member

    Joined:
    Dec 28, 2006
    #6
    It is definitely SDHC -- I bought it yesterday, and checked for that (since I had previously been downloading photos directly from the camera without a reader).

    But definitely a good point.

     
  7. cube macrumors G5

    Joined:
    May 10, 2004
    #7
    Did you try if the reader works properly with a good card?
     
  8. PmattF thread starter macrumors member

    Joined:
    Dec 28, 2006
    #8
    Yes, reader is working with a good card.

     
  9. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #9
    Semi-last resort, try a different reader, and also on a different computer, I had one card that became very precious about what would read it.
     

Share This Page