How to Move Files Without Copying Them?

Discussion in 'Mac Pro' started by schwine5, Jan 8, 2016.

  1. schwine5 macrumors newbie

    Joined:
    Apr 13, 2015
    #1
    I have Mac Pro (Early 2009) with Yosemite 10.10.5.

    When I move a file or folder with the computer mouse from the computer desktop, for example, the file or folder is copied to the new location while the original file or folder stays in place.

    Thanks for any tips on how to move a file or folder with the computer mouse "without" also copying the file or folder at the same time.
     
  2. itguy06 macrumors 6502a

    Joined:
    Mar 8, 2006
  3. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #3
    That's not right. Option-drag forces a copy. Command-drag will force a move.
     
  4. schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #4
    Is there a way to configure the OS X so that the computer mouse can move a file by itself without using the Command-drag option?
     
  5. killr_b macrumors 6502a

    killr_b

    Joined:
    Oct 21, 2005
    Location:
    Suckerfornia
    #5
    Unless you're moving from one disk to another, it shouldn't copy, it should just move. Like Darth.Titan said though, you can cut out this copy and delete when moving the files to another disk by holding Command when dragging.
     
  6. MacScott macrumors regular

    MacScott

    Joined:
    Jan 27, 2012
    Location:
    Indiana
    #6
    Or of course you can use mv in the terminal
     
  7. schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #7
    I have four separate, active hard disks in bays 1-4 of the Mac Pro.
    I noticed that in the "Get Info" window of each hard drive, the Shared Folder was check-marked.

    At first, I thought this was the cause of the file copy issue.
    But after I un-checked all of these Shared Folder options, the problem continues.

    Like killr_b said, "Unless you're moving from one disk to another, it shouldn't copy, it should just move."
    I agree that the files "should just move" and that's my goal in this situation.

    I shouldn't have to use keyboard commands to move everyday files back and forth on the same drive.
    The key point, I think, is that the files are created and moved within the same drive and not between drives.

    My sense is that I need to separate my main working hard drive from the other backup drives.
    In my case, I have an SSD installed which is my main drive, and the four bay drives are backup drives.
     
  8. Hirakata macrumors 6502

    Hirakata

    Joined:
    Mar 17, 2011
    Location:
    Burbank, CA
    #8
    Odd behavior. You say you are moving "everyday files back and forth on the same drive." Please give an example of where a file being moved from and where it is being moved to.
     
  9. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #9
    Permission problem may cause this problem. e.g. Move from one user's folder to another user's folder, the system may copy the files rather than move them.
     
  10. schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #10
    In terms of permissions here's what I can say.
    I'm logged in as the Administrator and thus I have full read and write permissions.

    The Get Info window for any file always says that I have full read and write privileges as the Administrator.
    I've even changed the "staff" and "everyone" options in the Get Info window to receive read and write privileges.

    No one else uses my computer and only I create and work with all the files and folders.
    I've used the repair and verify disk permissions option in Disk Utility several times recently but it doesn't seem to help.

    For example, if I try to move any .jpg, .mp3 or .docx (Microsoft Word for Mac) file, the original file stays in the original location and a copy is relocated to wherever I place it. For instance, the original file is on the computer desktop, and the file copy is placed in a folder.

    In a related issue, whenever I try to delete any of these files, I am not able to do so.
    Instead, I receive this error message: "The operation cannot be completed because one or more required items cannot be found (Error code -43)." This error message doesn't make sense to me because I can create a file on the main SSD drive, make a duplicate of this file on the computer desktop, and then try to move or delete this file. If I move the file, only a copy gets moved and the original file stays in place. If I try to delete the file, the Error code -43 appears.

    Yesterday I didn't have this problem but today I do.
    The only thing I can think of that may have caused this problem is that I backed up files on the SSD to the hard disk in bay one of the Mac Pro with Super Duper since these issues started.

    I'm hesitatat to use Super Duper again, but maybe the answer is to try a different copy option in Super Duper between the SSD and the Bay 1 hard disk. That's assuming I'm even on the right track with this line of thinking.

    I wanted to upload some related screenshots from my computer but the options don't seem to allow that from what I can tell.
     
  11. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #11
    It will only copy, if you are moving from a read only spaces like /Applications or if you move between volumes (disks.)
    --- Post Merged, Jan 8, 2016 ---
    This looks like a corrupted disk.
     
  12. schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #12
    A corrupted disk may be the cause of these problems.

    This SSD in question is brand new, but it's the second one I received from an online retailer.
    The first SSD began to smoke during installation, so I sent it back and received this newer one.

    If this SSD is corrupted, I'm not sure how to verify that.
    Disk Utility's repair permissions option doesn't seem to highlight any obvious problems with this drive.
     
  13. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #13
    I have had this problem. I found a restart fixed it. If it recurs, you might want to try deleting the .ds files using a utility like Onyx and also the com.appl.finder cache folder before rebooting.
     
  14. armut macrumors member

    Joined:
    Jul 9, 2014
    Location:
    Germany
    #14
    Just copy the files, navigate to the folder you want to move them and click "alt"+"cmd"+"v"
     
  15. schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #15
    I have now tested two SSD drives with Disk Warrior and no drive problems are reported by it.
    Both drives still have the file moving problem as compared to hard drives which do not have this issue.

    So if the SSD drives are not failing I still don't know how to fix this issue.
    --- Post Merged, Mar 16, 2016 ---
    I want to drag files with the computer mouse without using keyboard commands.
     
  16. kohlson macrumors 6502a

    Joined:
    Apr 23, 2010
    #16
    In the back of my mind this was a behavior on some waaay earlier version of Mac OS X. It was configurable. That said, I am around many Macs each day, including two of my own (work and personal). The default is copy across volumes, move within a volume. My guess is that it's something in your set up (multiple disks or partitions defining an workspace. such as a boot SSD and data HDD, or data stored on different partitions/disks).
     
  17. schwine5, Mar 16, 2016
    Last edited: Mar 16, 2016

    schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #17
    On the Mac Pro I have four HDD drives and one SSD drive.
    Since the default operation is copy across volumes, maybe this command is in operation when I am working within the SSD drive. If so, perhaps I need to find a way to change this Finder command within Terminal.

    The other SSD with this issue is a stand alone Mac Mini computer.
    The Mac Mini only has one defalt SSD drive and it's not connected to the Mac Pro.

    Yet the Mac Mini also has the file copy problem with the combination of SSD and El Capitain OS X.
     
  18. armut macrumors member

    Joined:
    Jul 9, 2014
    Location:
    Germany
    #18
    I don't know if it's possible to move the files with using the mouse. Never tried.
     
  19. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #19
    Repair Disk Permissions only works in limited circumstances - it does't repair permissions across the board Mostly, it repairs system files. User data is not touched. If there are permissions issues with the contents of a particular folder (read-only when they should be read/write, let's say), do this:

    Get Info for the folder. Confirm/correct that folder's permissions. In the Get Info window, unlock the padlock, click the Action drop down (gear icon) at the bottom of the window, and select "Apply to enclosed items..."

    Back to Repair Disk Permissions.... Per Apple HT201560
    Since you are using Repair Disk Permissions, you aren't using El Capitan, as that function was removed. Changes to the OS made it unnecessary (those people who complain that Apple removed it don't understand why it was removed - maybe Apple should add a do-nothing button as a placebo). https://support.apple.com/HT201560
     
  20. McScooby macrumors 6502

    Joined:
    Oct 15, 2005
    Location:
    The Paps of Glenn Close, Scotland.
    #20
    I know you said you'd done get info on the files in question, have you done it on the disks? I have this issue when moving files from a standard user (on my computer) to the admin folder (on same computer) , so are all the disks linked to the main user a/c?
     
  21. schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #21
    Yes, but it should be possible to move files without using keyboard commands!
     
  22. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #22
    Yes, I agree. This Should be possible. However, I want to know what the result is when doing such action.
    Assume your have a folder with path "/Macintosh/Users/admin/Documents/", and you have a file called "MOMENT RING.m4a". You want to move this m4a to this folder "/Macintosh/Users/admin/Music".
    Note how paths are written and hope your HDD arrays doesnt have some tricky RAID settings if possible.
    Try to do it, and see what it happens.
     
  23. schwine5, Mar 17, 2016
    Last edited: Mar 17, 2016

    schwine5 thread starter macrumors newbie

    Joined:
    Apr 13, 2015
    #23
    Some progress. I noticed that when I move a file from one folder to another folder, the file actually moves and does not also make a copy of itself in the process. However, when I move a file from the computer desktop to a folder, a copy of the file is also created. As a result, the file is moved to the folder as directed, but a copy of it also remains on the desktop. So I can limit the file copying issue to when it originates on the computer desktop. Perhaps there is a Finder, RAID or Permissions issue related to the computer desktop on this SSD drive.

    I also checked the Get Info option on the SSD drive itself, and I see that the Shared folder option is "unchecked."
     
  24. DoofenshmirtzEI macrumors 6502a

    DoofenshmirtzEI

    Joined:
    Mar 1, 2011
    #24
    Just to clarify, the SSD in question holds your home directory (either it is your system disk and you haven't moved your home directory, or it isn't and you moved your home directory there), yes? And isn't partitioned in any way?
     
  25. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #25
    Then what is the result if you move your file from /Volumes/Macintosh HD/Users/admin/Desktop to /Volumes/Macintosh HD/Users/admin/Documents? Assume both folders are on your SSD, not on your RAID disk or somewhere else.
    I have a Mac with single SSD, and I can always move the file from one folder to another, or from Desktop to another folder. I don't need to delete the duplicate file as they are not created by system anyway.
     

Share This Page