How to play blu-ray files m2ts on mac?

Discussion in 'iMac' started by cathy88, Apr 30, 2010.

  1. cathy88 macrumors member

    Joined:
    Aug 11, 2009
    #1
    Hi

    I have recently downloaded a blu ray video file. After I unzip it there are 2 folders BDMV and CERTIFICATE and if I go into BDMV I will see many sub folders where one is called STREAM and inside have heaps m2ts files and one which is the largest and I assume thats the one I wanna watch.

    My question is does anyone know how to play m2ts files on mac or just be able to play blu ray files (not blu ray disc). I think this must be an exact rip of the video from its original blu-ray disc.

    I have tried VLC but it didnt work....

    Thanks in advance
     
  2. i7QuadCoreMania macrumors 6502

    Joined:
    Nov 10, 2009
    #2
    vlc will play it if you ripped it on a PC using some software to decrypt it like AnyDVD.

    I have a few Bluray rips in ISO on my external drive and VLC plays it fine.

    I also have a Bluray superdrive in my i7, although it sees the BD disc and can open the directories, it plays for jack, again I think the problem is the video stream is encrypted and OSX currently has not support for it.:mad:
     
  3. cathy88 thread starter macrumors member

    Joined:
    Aug 11, 2009
    #3
    The thing is I dont have the original BD disc. I just downloaded this off the net and then unzip it i got all these folders.
     
  4. i7QuadCoreMania macrumors 6502

    Joined:
    Nov 10, 2009
    #4
    I have played bluray m2ts files from those directories.

    open the BDMV then stream and the largest m2ts file. it should play, if not the dude just copied the directories off the bluray disc, so my thinking it is still encrypted.

    however if you have bootcamp installed or parallels, or vmware fusion boot windows and run the WinDVD 9 which has Bluray support should be able to play those encrypted files.

    I don't know of another osx app with bluray support at the moment.
     
  5. cathy88 thread starter macrumors member

    Joined:
    Aug 11, 2009
    #5
    Sadly I dont have any windows computer at home, nor do I have parallel. I tried playing it on my Zinwell player and it didnt work either says invalid file even though I am so sure that it supports m2ts. It seems that I can convert it with handbrake but whats the best setting to do so, or is there any program that I can convert this m2ts to mkv without lossing any quaility?

    Thanks
     
  6. Cave Man macrumors 604

    Cave Man

    #6
    Plex and XBMC are the best at m2ts playback. You can probably open the file in Handbrake and transcode it to an mkv or m4v.
     
  7. cathy88 thread starter macrumors member

    Joined:
    Aug 11, 2009
    #7
    I tried installed XBMC but it wont play it dont know why.... any ideas?
     
  8. Cave Man macrumors 604

    Cave Man

    #8
    Plex and XBMC use ffmpeg2 so they should be able to open m2ts files just fine. I suspect your file is corrupted in some way. I open m2ts files all the time with Plex and they play just fine. But I don't download any of mine, they're ripped from the discs.
     
  9. cathy88 thread starter macrumors member

    Joined:
    Aug 11, 2009
    #9

    But it doesnt say corrupt file it just wont run. And I was able to put it in handbrake and do live preview for converting and it came out fine when i choose to preview first min.

    Is there anyway to tell if its corrupted or protected.

    This is what I downloaded and the user posted this up with the information

    DISC INFO:

    Disc Title: RED_BIRD_2D_F3
    Disc Size: 48,835,177,299 bytes
    Protection: AACS
    BD-Java: Yes
    BDInfo: 0.5.2

    PLAYLIST REPORT:

    Name: 00802.MPLS
    Size: 47,541,110,784 bytes
    Length: 2:41:41 (h:m:s)
    Total Bitrate: 39.20 Mbps
    Description:

    VIDEO:

    Codec Bitrate Description
    ----- ------- -----------
    MPEG-4 AVC Video 28817 kbps 1080p / 23.976 fps / 16:9 / High Profile 4.1

    AUDIO:

    Codec Language Bitrate Description
    ----- -------- ------- -----------
    DTS-HD Master Audio English 4146 kbps 5.1 / 48 kHz / 4146 kbps / 24-bit (DTS Core: 5.1 / 48 kHz / 1509 kbps / 24-bit)
    DTS Audio French 768 kbps 5.1 / 48 kHz / 768 kbps / 24-bit
    DTS Audio German 1509 kbps 5.1 / 48 kHz / 1509 kbps / 24-bit
    Dolby Digital Audio Czech 448 kbps 5.1 / 48 kHz / 448 kbps
    Dolby Digital Audio Hungarian 448 kbps 5.1 / 48 kHz / 448 kbps
    Dolby Digital Audio Slovak 448 kbps 5.1 / 48 kHz / 448 kbps

    SUBTITLES:

    Codec Language Bitrate Description
    ----- -------- ------- -----------
    Presentation Graphics English 24.863 kbps
    Presentation Graphics Bulgarian 20.745 kbps
    Presentation Graphics Croatian 19.764 kbps
    Presentation Graphics Czech 20.673 kbps
    Presentation Graphics Danish 22.906 kbps
    Presentation Graphics Dutch 21.379 kbps
    Presentation Graphics Finnish 21.679 kbps
    Presentation Graphics French 20.180 kbps
    Presentation Graphics French 1.535 kbps
    Presentation Graphics German 27.247 kbps
    Presentation Graphics Greek 23.021 kbps
    Presentation Graphics Hungarian 24.754 kbps
    Presentation Graphics Norwegian 20.641 kbps
    Presentation Graphics Portuguese 25.017 kbps
    Presentation Graphics Slovak 23.114 kbps
    Presentation Graphics Slovenian 19.364 kbps
    Presentation Graphics Swedish 21.978 kbps
     
  10. cathy88 thread starter macrumors member

    Joined:
    Aug 11, 2009
    #10
    I just tried Plex when I open it new pop up window goes buffering then that window dissappears and nothing happens
     
  11. Cave Man macrumors 604

    Cave Man

    #11
    I see you're trying to open Avatar. That disc has been problematic. You'll need to run the largest m2ts file in BMDV/STREAM folder (not mpls file) through tsmuxer to remux the 1080p video and the DTS core into a new m2ts file. It's important that you extract the DTS core from the DTS-HD audio track. You'll also have the problem of the subtitles because they're not easily extracted from the Blu-ray rip. The bad news is that I don't think tsmuxer works under Snow Leopard yet. It also looks like it still has encryption (AACS).
     
  12. cathy88 thread starter macrumors member

    Joined:
    Aug 11, 2009
    #12
    Turns out the latest version of tsMuxeR doesnt work with Snow Leopard had problem with GUI. So I downloaded 1.8.30b and it can run but when I try to add the m2ts file a new pop up window came out which was all blank and I click Ok it said Cant detect stream type. File name:/xxx/xxx/xxx/xxx/00002.m2ts does this mean its protected?

    Is there no luck for me to watch this lol. Took me a week to download quite sad though ^^
     
  13. Badger^2 macrumors 68000

    Badger^2

    Joined:
    Oct 29, 2009
    Location:
    Sacramento
    #13
  14. fa8362 macrumors 65816

    Joined:
    Jul 7, 2008
    #14
    If the MPAA wanted to go after you, you've made it easy.
     
  15. qtx43 macrumors 6502a

    Joined:
    Aug 4, 2007
    #15
    And this is the reason we have to put up with DRM on everything, the relatively few who want everything for free.
     

Share This Page