How to Prevent auto period after two-letter state abbreviation

Discussion in 'Mac Apps and Mac App Store' started by gogreen1, May 19, 2018.

  1. gogreen1 macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #1
    When I type a two-letter all-cap state abbreviation, I then type two spaces after which I type the ZIP code. That's when Pages enters a period after the state abbreviation. How do I prevent Pages from adding a period after a two-letter all-cap state abbreviation? In Preferences, I've unchecked all the editing items I can find. Thanks.
    --- Post Merged, May 19, 2018 ---
    Never mind. Solved! Uncheck "Add period with double space" in System Preferences > Keyboard > Text.
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    Hmmm. That's curious, since "they" recommend only a single space after a period between sentences. But, yeah, auto-correct and the like can be a pain in the neck. My biggest complaint is the way it messes with capital letters where I don't want 'em.
     
  3. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    Doesn't that setting change the double space to a period-space?

    Turned it off myself quite a while back. Useful in iOS only, as far as I'm concerned.
     
  4. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #4
    Then uncheck "Capitalize word automatically," too.

    Not for me. It just prevents MacOS from inserting a period after I enter two spaces. Funny thing is, I originally wanted it to stop doing that in MS Word for Mac 2016! Works there, too, I guess, because it's an OS keyboard setting.
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    That is already not checked, ditto for "add period with double-space". The unwanted capitalization seems to occur mostly in Mail.
     
  6. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #6
    Can't help there. Sorry. I use Thunderbird.
     

Share This Page