How to prevent fan noise in BootCamp

Discussion in 'MacBook Pro' started by improwise, Dec 5, 2015.

  1. improwise, Dec 5, 2015
    Last edited: Dec 5, 2015

    improwise macrumors member

    Joined:
    Jun 19, 2015
    #1
    Not sure how much common knowledge this is but if you have a powerful MacBook Pro running Windows via BootCamp, you most likely have noticed that there is a problem with fans running way to much and too loud. Especially if you have a dedicated GPU in it.

    If you can't find another way to solve the problem, I would recommend trying to lower the "Maximum Processor State" in Power Options under "Processor Power Management". Default values are usually 100% which will make the CPUs "turbo mode" kick in quite often which usually makes the fans go crazy.

    Just by lowering this value to 99% instead this problem has gone from very irritating to almost not noticeable on my 2015 MacBook Pro 15". Now the fans only kick in when they really should. And this is with 4980HQ CPU with AMD dedicated grapics and a the MBP connected to a 4K display.

    Of course, there will be a loss of performance by doing this but not really something you would notice in day-to-day use, and you can always just switch to another Power Plan and get all performance back. Depending on your success with this you might want to consider changing some options for the dedicated GPU also but in my case the real kicker is the Maximum Processor State.

    Results of course vary with the specific model you have and it's configuration, but overall I guess that this should work on all modern MacBook Pros (and other Macs as well). You can use a tool like HWMonitor to monitor fan and CPU behaviour, especially notice how the max values of the CPU clocks change when you go from 100% to 99% (you need to restart the program after changing to get updated "max" values or select "Clear max/min values").

    Let us know if this works for you :)
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I don't recall having any issues with the fan with my 2012 rMBP. While I understand the rMBP will run hotter in windows, the fan was never a problem.
     
  3. improwise thread starter macrumors member

    Joined:
    Jun 19, 2015
    #3
    Well, naturally it is a combination of processing power, processor load and cooling capacity that that makes up the end result. In my case the "problem" is that the CPU in it's highest mode is more powerful than the rMBP can handle without letting the fans run wild, and that it kicks into burst mode rather instant.
     
  4. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #5
    You can also install Intel XTU and edit(up/down/off etc..) your turboboost multiplier in Windows... https://downloadcenter.intel.com/download/24075/Intel-Extreme-Tuning-Utility-Intel-XTU-

    This way you can find a sweet spot in turboboost(if you are wanting to use this feature in Windows)

    Also in advanced power settings you can change the Windows Cooling Policy(Typically between "Active" and "Passive").

    I don't have this particular problem either
     
  5. improwise, Dec 6, 2015
    Last edited: Dec 6, 2015

    improwise thread starter macrumors member

    Joined:
    Jun 19, 2015
    #6
    Well, that might be useful in certain scenarios but considering how the CPU temps rise when the CPU goes into turbo mode, I wouldn't want the fans NOT running as they do, ie the problem at least with my rMPB isn't that the fans run as they do, it's that they have to because of to much heat generated.
     
  6. improwise thread starter macrumors member

    Joined:
    Jun 19, 2015
    #7
    The Intel XTU could definitely help out a bit also, not sure how user friendly it would be for an average user though.

    I've experimented a bit using Windows Cooling Policy before trying out Processor Power Management but couldn't see any noticeable difference. Even with passive there was way to much fan noise for my liking compared to now when it is not a problem at all with minimal performance loss (again, in day to day usage). Adjusting power settings for GPU could also help out a bit.
     

Share This Page