How to prevent OSX from frying my MBP during sleep?

Discussion in 'MacBook Pro' started by MacYost, Mar 5, 2010.

  1. MacYost macrumors member

    Joined:
    Jun 14, 2009
    Location:
    The Netherlands
    #1
    I own a 13" MacBook Pro since last July. I always put it to sleep by closing the lid. But it will not always stay asleep: sometimes I return to my MBP after a good night's sleep to discover that the sleep led stopped blinking and the notebook is red hot, with its fans blowing at top speed. Opening the lid will not awake the MBP, though. I get a black screen and the only thing that helps is a hard reset.

    Does any one know why MBP seems to awake from sleep with the lid closed and starts overheating itself?

    (I also posted a related problem: not being able to awake from sleep, but without first overheating)
     
  2. m85476585 macrumors 65816

    Joined:
    Feb 26, 2008
    #2
    Try turning off any settings that might wake the computer, such as Bluetooth (uncheck "allow bluetooth devices to wake computer from sleep").
     
  3. patrickdunn macrumors 6502a

    patrickdunn

    Joined:
    Apr 16, 2009
    Location:
    St. Louis, MO
    #3
    It shouldn't overheat, it will get warm thought. They were designed to work in "clamshell mode". Do you have anything plugged in the USB ports that wake it when closed?

    More on Clamshell Mode:
    http://support.apple.com/kb/HT3131
     
  4. MacYost thread starter macrumors member

    Joined:
    Jun 14, 2009
    Location:
    The Netherlands
    #4
    Thanks for the suggestions.

    I have nothing plugged into the usb ports, am not using any bluetooth device and "wake on bluetooth" = off. I found a setting about waking from sleep by the network, and put that to off also. I cannot easily check if this solves the problem, because the problem does not happen very often.
     
  5. Punker macrumors member

    Joined:
    Jun 25, 2009
    #5
    This happened to me once, just after i had disabled the sudden motion sensor. (beach ball hell, i tried this as a solution as suggested by many)

    After i renabled it, it never happened again.
     
  6. MacYost thread starter macrumors member

    Joined:
    Jun 14, 2009
    Location:
    The Netherlands
  7. avediswolf macrumors regular

    avediswolf

    Joined:
    Jul 23, 2008
    Location:
    Ohio
    #7
    Running VMWare?
    If you forget to properly shut down Windoze, it seems to do some funky things like you are mentioning.
     
  8. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #8
    Select "sleep" from the Apple menu before closing it, that might do somethin.
     
  9. MacYost thread starter macrumors member

    Joined:
    Jun 14, 2009
    Location:
    The Netherlands
    #9
    No VMWare or Parallels here.
     

Share This Page