How to prevent sleep for long render

Discussion in 'iMac' started by 12dylan34, Dec 16, 2012.

  1. 12dylan34 macrumors 6502a

    Joined:
    Sep 3, 2009
    #1
    My computer is going to sleep and stopping long overnight renders. Before you say, "change the energy saver preferences to 'never,'" I might tell you that this was never a problem on my recently upgraded-from 2008 MBP, which was running the same version of Cinema 4D, and had the same energy saver preferences as my new iMac.

    Is it like a firmware thing between the two machines that's causing this?

    I found this

    but I was wondering if you guys knew a trick to prevent this from happening without changing my energy saver preferences, since it never did on my old MBP.

    Thanks for any help that you can provide
     
  2. kathyricks macrumors 6502

    Joined:
    Nov 26, 2012
    #2
    I've done 9 hour renders without a problem on my SnowLeopard iMac. I set Computer Sleep to: "Never." Display Sleep to about 5 minutes. I check the boxes for "Put hard disk to sleep when possible" and "wake for network access."

    Have you done all that on your Mountain Lion machine or does Mountain Lion have different choices?
     
  3. Wong Jowo macrumors newbie

    Joined:
    Oct 29, 2012
    Location:
    Worcester, MA & Yogyakarta, Indonesia
    #3
    I use Caffeine.
     
  4. 12dylan34, Dec 16, 2012
    Last edited: Dec 16, 2012

    12dylan34 thread starter macrumors 6502a

    Joined:
    Sep 3, 2009
    #4
    I just want my computer to sleep when I'm not rendering, but not have to constantly change my sleep settings.

    On my old MBP, both computer and display were set to 15 minutes, but the computer never went to sleep on overnight renders anyway. The people on the forum I linked to cited it going to sleep with full processor use as a bug.
     
  5. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  6. boy-better-know macrumors 65816

    boy-better-know

    Joined:
    Jun 30, 2010
    Location:
    England
    #6
    Would also like to reccomend Caffeine. Brilliantly easy and free. Everyone should have it on their Mac.
     
  7. DagazaGZ, Dec 16, 2012
    Last edited by a moderator: Dec 17, 2012

    DagazaGZ macrumors regular

    DagazaGZ

    Joined:
    Dec 13, 2010
    #7
    Well if your using a laptop, you probably want to be able to shut the lid while it renders.
     
  8. 12dylan34 thread starter macrumors 6502a

    Joined:
    Sep 3, 2009
    #8
    These are all really great and useful things, but I don't think that people are understanding my problem:

    On my old computer, it stayed awake when rendering by default. The computer sleep setting was set to 15 minutes. When the rendering was done, it went to sleep. No change to "never" in the sleep settings or third party software was needed. It was all automatic. The lid had to be open, but that wasn't an issue.


    I want to know how to get the same behavior on my new iMac without changing the energy saver settings and without third party software. At least in past machines, this was possible, and the default behavior.
     
  9. DagazaGZ, Dec 16, 2012
    Last edited by a moderator: Dec 17, 2012

    DagazaGZ macrumors regular

    DagazaGZ

    Joined:
    Dec 13, 2010
    #9
    Without 3rd party software I doubt you'll get it working. Caffeine is free and very light weight, why not use it?

    When I'm converting a video to my iTunes, I have my Mac set up to keep my Mac running while it's converting the video. And when it's done my Mac sleeps. I have my power settings set to turn off the screen after 1 min and the hard drives at 1 min as well. I start the conversion then turn off the Caffeine app. When I turn off the caffeine app my screen turns off after 1 min but my mac continues to encode the video sometimes for 8 hours at a time. After it's done, my Mac goes to sleep.
     
  10. oaks42 macrumors newbie

    Joined:
    Nov 30, 2012
    #10
    I think I can understand your problem as I have with mine (its my old iMac running Snow Leopard). While watching Apple TV from my iTunes on my iMac, it will go to sleep halfway when I'm streaming the video (my family outing videos) and I have to return to my mac upstairs and wake it. Second time round it did it again and now I have to set to 'Never' sleep in order to finish the video.

    I realise its only very recently that I have this problem. Is there something changed recently on this power down? How can an application streaming halfway go to sleep, never heard of?! I thought its because my machine is getting old but reading yours I think its more then meets the eye and not just the age or software. Apple must have did something to it? :confused:
     

Share This Page