How to put HDD on permanent sleep with only SSD running

Discussion in 'Mac OS X Lion (10.7)' started by Denisoftus, Jul 22, 2011.

  1. Denisoftus macrumors member

    Joined:
    Jun 2, 2011
    #1
    I have a problem with HDD spin up and down during the day with no reason. There is no data on the drive but still SL always using it. I hoped with Lion the situation is changed, but apparently I see the same behaviour as with SL.

    Is there a script/app/tweak anything which can bring this damn drive down for up until I need it?

    For the moment I end up ejecting drive every time and remounting and ejecting it again after coming of the sleep. This is really annoying for "the best OS"

    Also auto - sleep is not working any more, I also hoped Lion will fix it, but it did no good. Any ideas?

    Thanks.
     
  2. cpfcmatt macrumors newbie

    Joined:
    Jul 7, 2011
  3. Denisoftus thread starter macrumors member

    Joined:
    Jun 2, 2011
    #3
    yes, I'm doing it with no joy.
     
  4. Denisoftus thread starter macrumors member

    Joined:
    Jun 2, 2011
    #4
    Anyone?

    I find it hard to believe that everyone else is happy with the case.
     
  5. WiBu macrumors member

    Joined:
    Aug 10, 2010
    #5
    The only thing I can think of is to suggest disabling Spotlight indexing the drive. The downside is that this might not solve the problem and you won't be able to search the drive with Spotlight. You can easily enable it again though.
     
  6. Denisoftus thread starter macrumors member

    Joined:
    Jun 2, 2011
    #6
    Will try, thanks!
     
  7. WiBu macrumors member

    Joined:
    Aug 10, 2010
    #7
    I'm just wondering if that fixed it for you?

    It sort-of-did for me, but Spotlight still likes to fire up the drive and check /.Spotlight-V100/ to see if it can or should index the files. I'm not really sure how to get around that.
     
  8. Denisoftus thread starter macrumors member

    Joined:
    Jun 2, 2011
    #8
    Not much luck with that, I'm affraid. It even spin it up when unmounted, surely spotlight are not aware of unmounted disk.

    Any other ideas?

    P.S. Just noticed, unmounting makes no effect on the drive, it still spinning, but ejecting does.
     
  9. WiBu macrumors member

    Joined:
    Aug 10, 2010
    #9
    OK, I seemed to fix the issue for myself, hopefully something here will help:

    Disable Spotlight indexing the drive under the Privacy options in System Prefs for Spotlight. You've done this already, but I found that Spotlight still liked to spin-up the drive to check if it could index it or not. In an effort to try and fix it I removed the Spotlight folder on the root of my Optibay HDD using Terminal using 'rm -rf /Volumes/[THEVOLUMENAME]/.Spotlight-V100/'. Make sure you have filled out the full file path before issuing the command; a mistake could nuke your files on the drive. You might find Spotlight hits the drive one more time to replace the files you deleted, but it shouldn't need to check again.

    Disable Mobile Backups that Time Machine likes to do when the usual back-up drive isn't connected. I can't find the command to achieve this at the moment, but it should be easy enough to find after a little bit of searching around. I believe the same effect can be achieved by turning automatic backups off.

    Lastly, check that your disk is actually set to spin down. In Terminal type 'pmset -g disk' and check what disksleep is set to, it may have reset. To set it to another value do 'sudo pmset -a disksleep 5', 5 being the value in minutes after inactivity that the drive will sleep, I personally have it set to 2. If it is set to 0 it will never spin down.

    If you have done all of this and it is still spinning up randomly, I'm not sure what the problem may be. Perhaps certain apps are checking it; I have noticed that it sometimes likes to spin up when I open the App Store or check recently opened files in some apps.
     

Share This Page