How to recover lost disk space?

Discussion in 'OS X El Capitan (10.11)' started by Shirasaki, Jul 26, 2015.

  1. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #1
    I try to install Windows using a boot camp disk, but fail in progress due to serious partition issue. So I give up, and delete partitions created through boot camp.

    And now, I can no longer recover or create those partitions under mac, and I cannot fox partition table even using Yosemite installation disk.

    I use diskutil to delete partition, not using disk utility since El Capitan does not support unsupported partition modification.

    I try to use diskutil but there is no luck. Using Yosemite disk utility brings me this warning message: MediaKit reports partition map too small.

    How to solve this issue? El Capitan works normally, but boot camp stops working.
     
  2. Evren Carven macrumors regular

    Evren Carven

    Joined:
    Dec 16, 2014
    #2
    What information did you get when you use diskutil to delete this partition?

    I have tried to search the answer with this warning message by Yosemite disk utility without result. You should contact Apple support to get more information if there is no more clue about this problem. Please share your experience for us if you solve it.
     
  3. Shirasaki thread starter macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #3
    Delete partition? What I want to do is to expand my current mac partition and remove any partition after that. That simple.

    I then try to use GPT command to modify partition table under installation disk. But since the method I find in YouTube doesn't contain backup steps, GPT partition table simply ceases working properly. I mean, after changing that table, Mac OS X ceases working immediately. I do need to dig into that command before throwing something heavier on my mac.

    Now, I end up using time machine backup to restore.
     
  4. Polardude macrumors newbie

    Joined:
    Jul 4, 2004
    #4
    I had the same issue over the weekend and did not find a fix. Installed Windows 8.1 using Boot Camp Assistant in El Capitan and ran into an driver issue requiring a reinstall (black screen after boot). Going through set up again, Windows couldn't install on the freshly erased partition.

    In OS X, I was unable to remove nor erase the partitions used by Windows. I tried repairing via Disk Utility in normal and recovery modes without success. I also tried removing the partitions one by one in both environments. Again, no such luck. I was mulling using diskutil in terminal but decided against it in case I messed up the partition table like OP did.

    Was anyone able to merge / erase their partitions to a single one in HFS+ with OS X 10.11?
     
  5. Shirasaki thread starter macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    I tried using El Capitan Boot Camp assistant to install Windows 10. But that version was too old and thus really buggy and crappy. So I wanted to remove it through Boot Camp assistant.

    Then, things went wrong.

    Now, Windows partition is gone, but I cannot resize original Mac OS X partition, or use Boot Camp assistant to retry. I want to modify GPT partition table but it is simply risky, and I find Apple is moving Recovery HD right behind Mac OS X partition, rendering manual GPT partition modification impossible.

    Maybe I will try to destroy GPT table and manually add all entries to see if there is any chance.

    El Capitan Boot Camp assistant is far from ready to use.
     

Share This Page