How to remove Cydia Errors

Discussion in 'Jailbreaks and iOS Hacks' started by mr lee, Aug 16, 2010.

  1. mr lee macrumors member

    mr lee

    Joined:
    Jul 5, 2010
    #1
    Tired of seeing this:

    [​IMG]

    It's most likely happening due to a repo that is either damaged or no longer working. Here is a very easy fix to get rid of those pop ups.

    What you will need:

    1. An SSH program - [Cyberduck or Transmit for Mac] [PuTTY or WinSCP for Windows.] If you use a different program then use that.

    2. Wi-Fi connection

    3. The iPhone or iPod/iPad with the Cydia error.

    4.
    Open SSH app installed via Cydia on the iPhone or iPod/iPad.

    What to do?
    Open the SSH program and make sure you can see server:, User Name:, Password: and Port:.

    [​IMG]
    For server enter the IP address your device is connected to. You can do this by opening the Settings app and going to the Wi-Fi section and then looking for the Wi-Fi you are connected to. Then click the arrow which shows the Wi-Fi info. Search for the IP Address e.g. 192.165.2.2.

    The default user name for your iPhone is root

    The default password is alpine

    Make sure the port is 22

    Finally make sure you are using SSH or SFTP rather then FTP.

    If you can not connect restart your device, make sure you have Open SSH installed via Cydia, connected to WiFi and make sure you have entered the information correctly.

    1.Once connected go to the main directory and then navigate in the SSH program to /etc/apt/sources.list.d/ Look for Cydia.list and open it with a text editing program on your computer.

    2.Look for the sources that are giving you problems (ex: deb http:d.mobilecinema.com/ ) on the device and simply delete them from the list.

    3.Now save that list and copy it back into your device via SSH.

    4.Over write the previous Cydia.list file.

    5.Now re-open cydia and refresh your sources and the Error repo's should be gone.



    I hope this worked for you. If you need any help reply. :D
     
  2. onefish2 macrumors member

    onefish2

    Joined:
    Oct 10, 2006
    Location:
    Nanuet, NY
    #2
    Awesome. Thanks for posting this. I never thought of doing this. I was stuck at one point and puzzled why there was no vi or txt editor on the iPhone. So I copied the file and edited locally and then uploaded it back to the iPhone.
     
  3. macattack87 macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #3
    worked for me :D

    one tip tho to mac users with cyberduck

    you cant edit the file without first downloading it to your desktop

    so download it first, open it up in textedit make the changes and re upload it
     
  4. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #4
    Theres no picture after "tired of seeing this?".
     
  5. pellets007 macrumors 6502a

    pellets007

    Joined:
    Jan 28, 2009
    Location:
    New York
    #5
    I have errors with a few sources that I tried adding. However, these sources do not show up on the list. Any ideas?
     
  6. thizzinG macrumors member

    Joined:
    Aug 4, 2010
    Location:
    West Coast, Cali
    #6
    Use Mobile Terminal (from Cydia) and install Cyfix (non GUI version) from Cydia..
    It is no doubt the BEST way to get rid of expired non existent repos.

    (Assuming you already have Cyfix from Cydia installed)

    1. Open Mobile Terminal
    2. Type in "su" hit enter
    3. Type in your password or "alpine" if you haven't changed it yet.
    4. Type in "cyfix"
    5. Then type in your problematic URL.


    Respring and viola.

    It EXTERMINATES it COMPLETELY. It will NEVER return (unlike the iFile trick)


    Please feel free to PM me if you need further assistance.
     
  7. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #7
    The OP’s method is all over this forum. Thanks for giving out more info on Cyfix. I had wanted to install this, but wasn’t sure if the GUI or the non-GUI needed to be added. We’ll see if this keeps a problematic repo from appearing again (gafoogle). I delete it and it comes back after awhile for who knows what reason.
     
  8. aussietanker macrumors member

    Joined:
    Oct 19, 2010
    Location:
    Sydney, Australia
    #8
    Hi All ... sorry to bring this up again .... but i am trying to sort out the cydia errors on my iphone ....

    i have followed the advice here, and THINK that i have done parts of it correctly - but seem to be messing up a few critical steps ...

    basically i followed the method as shown here (thanks for writing it out so clearly) ...


    My first query relates to points 3 & 4 ....

    when i found the list, i just double clicked on it on my PC - it opened up on a page, and the ONLY sources on the list were the ones giving trouble ... ie the "Big Boss' lists etc were NOT listed .... so i just deleted them all ....

    in the widow that i was using, there was no option to save as... so i just closed the window on the page (little x in RH corner) - i think this "overwrote" the list, as when i reopened the list to check it - it was now empty with no writing at all on it ....

    i then reopened cydia (without respringing) and i still get the error messages :( however ... when i go into sources on "Manage' on cydia, none of those sources are listed at all ... when i go into packages.... it seems as if the software from those sources that i deleted from that list is still there ...

    obviously i have not followed the instructions as accurately as i thought :(



    also, in another post on the matter in the same thread ... it says ...




    i treied to do this method ... but for some reason "mobile terminal" doesnt load on my iphone ... i installed another application called "pTerm' which i think does a similiart thing ... i can get my connection to the phone ok .... but i don't understand how to do this bit >>> (Assuming you already have Cyfix from Cydia installed) ... i am on a PC using XP Pro ... when i download cyfix onto my comp it doesnt seem to recognize what it is ... i can open it with a text editor ... but do not know how to get it ionto my iphone ... any help here is appreciated (pls use shh for dummies style "talk" )

    .... any help on how to correct whatever mistake i have made is greatly appreciated ... i would really like to get rid of all these error messages, as well as understand what i am doing a little better

    any advice and help is greatly appreciated

    thank you

    regards
    at

    regards
    at
     
  9. thizzinG macrumors member

    Joined:
    Aug 4, 2010
    Location:
    West Coast, Cali
    #9
    Cyfix doesn't get loaded onto your PC.
    You install it on your iPhone thru Cydia.

    Without MobileTerminal I can't help you on this method.
     
  10. green94 macrumors regular

    Joined:
    Mar 17, 2009
    #10
    Or go into iFile, navigate to /etc/apt/sources.list.d -> cydia.list and delete any sources that are returning errors. Save and you are done.

    Much easier IMO.
     
  11. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #11
    This only works with the sources you've added manually, correct?

    The sources I've had a problem (GPG error) with since I used limera1n to jb are;

    ispaziorepo.com
    iphone-storage.de
    smxy.org
     
  12. bludragon06 macrumors regular

    bludragon06

    Joined:
    Jun 27, 2010
    Location:
    Pittsburg California
    #12
    Thank you soooo much.....

    Every time I opened up Cydia and it was refreshing it would always come up with an error cause because I tried adding a repo called beyouriphone. Ugh dont do it people. So I used iFile and went into where you said and deleted two repos (the same source) and now woo hoo no errors!
    -Dave
     

Share This Page