How to remove "Other" user in Login Pane

Discussion in 'macOS' started by hon, Jun 7, 2011.

  1. hon macrumors newbie

    Joined:
    Jun 7, 2011
    #1
    I have a brand new iMac set up a few days ago. Originally, I have only two users set up, both admin and every time the iMac turned on, I could only see two users in the Log-in pane.

    Last night I was fiddling around with parental control function and then back to square one, i.e. both users were still admin.

    However, now I notice that I have a third user in the Log-in pane called "Other". I have tried going into the System Preference/Account and trying to delete it but to no avail. Can anyone tell me how to remove this "Other" user from the Log-in pane. Thank you.
     
  2. unclenice macrumors newbie

    unclenice

    Joined:
    Jun 1, 2011
    #2
    How to remove users on login window.

    Go to System Preferences----Accounts-----login options----Display login window as----select name and password.

    Disable guest Account if is enabled
    I hope that helps.
     
  3. hon thread starter macrumors newbie

    Joined:
    Jun 7, 2011
    #3
    Thank you for your help...but this is not i want. I want to keep the icon so that I can log in just by clicking the icon. So i guess i need to keep to the option "List of users".

    Thanks anyway.
     
  4. hon thread starter macrumors newbie

    Joined:
    Jun 7, 2011
  5. larkost macrumors 6502a

    Joined:
    Oct 13, 2007
    #5
    Sorry to be a bit snarky... but this one is too obvious:

    http://***********/?q=macos+x+hide+user+from+loginwindow

    For me the first 4 or 5 hits were all answers to this question for various version of the OS. I already knew that that was what was going to pop up, but it seems to me that you have not done the obvious homework before asking the question.

    Edit: grrr... that should be a "let me google it for you" link... so you are just going to have to google it for yourself.
     
  6. hon thread starter macrumors newbie

    Joined:
    Jun 7, 2011
    #6
    No. that wasn't the answer to the solution I am looking for. I just want to remove the "Other" on the list, not any of the users.

    Thank you for the sarcasm.
     
  7. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #8
    You probably enabled the root account at some point in the process. Open Directory Utility (found in /System/Library/CoreServices/), unlock it using the padlock in the corner, then from the Edit menu at the top of the screen, select "Disable Root User". If that says Enable Root User instead, then that's not the problem, but I expect it is.

    jW
     
  8. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #9
    Bingo. Sad to see it took 7 posts to get the answer.
     
  9. willgreene99 macrumors regular

    willgreene99

    Joined:
    Dec 16, 2010
    Location:
    DFW
    #10
    I went through the steps and noticed that I have the Enable' option so I enabled and disabled the option but the Other account option is still available. But I have installed a remote server monitor app, Lithium Core Admin. So I am thinking this is part of the install.
     
  10. Rhetro macrumors newbie

    Joined:
    Aug 12, 2006
    #11
    trying to Log in as admin, without the other user login options

    Hello.

    This is exactly what I did; I enable the Root User in Linux. I was playing around with something else, and it turns out I don't really need to have the Root User enabled.

    However, I haven't been able to find the Disable Root User anywhere. I'm looking in the Viewing window, right?

    Thanks for your help.
     
  11. Rhetro macrumors newbie

    Joined:
    Aug 12, 2006
    #12
    Disregard...

    found it!

    That did the trick!

    Thanks!
     
  12. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #13
    Disable Root User is in the Edit menu of Directory Utility, found in /System/Library/CoreServices/.

    jW
     
  13. alksion macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #14
    I had the same problem, however, my root user was already disabled. I had to go to the "Search Policy" tab and delete the entry with the IP in it. Do not remove the local one.

    This is what worked for me.
     
  14. zaidshaari macrumors newbie

    zaidshaari

    Joined:
    Feb 2, 2016
    #15

    sorry, i cant find where the file to find out
     
  15. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #16
    I'm using El Capitan and the Directory Utility app is located;

    Macintosh HD (the name of your Drive)/System/Library/CoreServices/Applications
     
  16. zaidshaari macrumors newbie

    zaidshaari

    Joined:
    Feb 2, 2016
    #17
    sorry, i like to know what this means ... node

    Screen Shot 2016-02-23 at 11.09.59 PM.png
     
  17. glenguyen macrumors newbie

    glenguyen

    Joined:
    May 23, 2016
    #18
    First you go to settings, user and groups, click lock to make changes, type password, click login options, click join, click Open Directory Utility, go to Directory Editor but first click the lock to make changes find AuthenticationAuthority and delete it by pressing the minus button at the bottom of the page. then go to apples website to download Mac OS. All you have to do is restart your mac and when you hear the sound press command + r. and it will take you through a series of steps to download Mac OS (about 1 hour) then it will say it cant download. click shutdown then turn your mac on again. Do not press restart. After that give the Mac your information to create a new user, this user will then delete the 'Other..." user and all you have to do is user the new user for a few seconds, log off, sign in to your old user, go to settings, user and groups, press the lock to make changes and then remove the new user you created, close the lock. Log off and you will see only 1 user! Hope this helps, it worked for me!
     

Share This Page