Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

hagar

macrumors 6502a
Original poster
Jan 19, 2008
969
2,019
hi, I cannot find the option anymore to rename iCloud email account. Mine shows up as iCloud but I want to rename it. It used to be in Mail, Contacts, Calendars settings. And it’s still there for other mail accounts (Exchange, Gmail,…) but not for iCloud. Anyone?
 
  • Like
Reactions: Sowelu

Menel

macrumors 603
Aug 4, 2011
6,214
1,164
You cant rename it iirc.

You can create aliases on icloud.com mail,section.
 
Comment

hagar

macrumors 6502a
Original poster
Jan 19, 2008
969
2,019
I'm sure you could do this in iOS 7. I renamed my iCloud account to Home and that's how it was listed in Mail and calendar. Now, that options seems to be gone.

I wonder how they call a second iCloud account. Icloud2 ?
 
Comment

parkds

macrumors 6502
Jan 23, 2003
278
61
Was wondering the same thing. In iOS 7 you could rename it ("Description") but I cannot find the same option in iOS 8.
 
Comment

Sowelu

macrumors 6502
Aug 15, 2008
306
156
New York City
Same here - I tried to rename my iCloud email to 'Home' but I cannot find the 'description' field to do so. You can rename any other email accounts in iOS8, but not your iCloud email (this was not the case in iOS7). I am not sure why they'd do this? :confused:
 
Comment

adam-stark

macrumors newbie
Oct 17, 2014
20
4
Ok by experimenting, I have got around this, but Apple still need to fix it for sure...



I noticed that only the primary iCloud account has lost the ability to change the description field. (I have another iCloud account with my wife to share notes and I can still change the description if I add it as a mailbox) so this led me to try the following, which worked !



What I did was the following:



1) Create a new temp bogus iCloud account (adam_test123) for example.

2) Under General/iCloud I logged out of my primary iCloud account (e.g. adam_stark@icloud.com)

3) Under General/iCloud I logged in under my new temp account (adam_test123) and set it to sync nothing, it is a temp measure after all. This is now my temporary primary iCloud account.



Then

4) Under Mail,Contacts,Calendars, added a new iCloud account and logged in with my appleid which was the original primary account (adam_stark@icloud.com). As this is not my primary account on the iPhone now (the adam_test123 is) and can only sync mail/calendars/reminders etc... It still lets me modify the description field. so I changed it from iCloud to the label i wanted.... (now in mail it shows up with the label I want and not iCloud)



5) Under General/iCloud I logged out of the temp/bogus account....



6) Under General/iCloud I re-logged in as my original account (adam_stark@icloud.com) and the OS obviously knew that the account already existed as a secondary account (as in step 4 above) and must of changed/upgraded it automatically to my primary account again when I logged in, as it gave me the options of iCloud Drive and Find my phone etc...... But the beauty is, it left the description as what I set it to in step 4... so voila, under mail, is now the label I want....



A very long winded way around it, and may not work for all.... but it worked for me at least ;-)



Hope it helps someone .....



Adam
 
  • Like
Reactions: jimthing
Comment

Dreanmachine

macrumors newbie
Dec 19, 2011
2
0
Ok by experimenting, I have got around this, but Apple still need to fix it for sure...



I noticed that only the primary iCloud account has lost the ability to change the description field. (I have another iCloud account with my wife to share notes and I can still change the description if I add it as a mailbox) so this led me to try the following, which worked !



What I did was the following:



1) Create a new temp bogus iCloud account (adam_test123) for example.

2) Under General/iCloud I logged out of my primary iCloud account (e.g. adam_stark@icloud.com)

3) Under General/iCloud I logged in under my new temp account (adam_test123) and set it to sync nothing, it is a temp measure after all. This is now my temporary primary iCloud account.



Then

4) Under Mail,Contacts,Calendars, added a new iCloud account and logged in with my appleid which was the original primary account (adam_stark@icloud.com). As this is not my primary account on the iPhone now (the adam_test123 is) and can only sync mail/calendars/reminders etc... It still lets me modify the description field. so I changed it from iCloud to the label i wanted.... (now in mail it shows up with the label I want and not iCloud)



5) Under General/iCloud I logged out of the temp/bogus account....



6) Under General/iCloud I re-logged in as my original account (adam_stark@icloud.com) and the OS obviously knew that the account already existed as a secondary account (as in step 4 above) and must of changed/upgraded it automatically to my primary account again when I logged in, as it gave me the options of iCloud Drive and Find my phone etc...... But the beauty is, it left the description as what I set it to in step 4... so voila, under mail, is now the label I want....



A very long winded way around it, and may not work for all.... but it worked for me at least ;-)



Hope it helps someone .....



Adam

Adam, I tried this several times, but to no avail. Always returns to generic iCloud. Am I missing some subtle angle? Help?
 
Comment

adam-stark

macrumors newbie
Oct 17, 2014
20
4
Err no not really...

Just make sure that in Step 4 you have some temp account logged in as the primary iCloud account (under settings/iCloud) so that you have a iClould label under the mailboxes, then create a new mail iCloud account with your original AppleID (just mail for now) and then change the label... so that under mailboxes you see your mail under the label you want.

At step6 is should keep the label, it has worked for me on 2 phones now...

A.
 
Comment

mattfoo

macrumors newbie
Sep 27, 2014
18
2
This works a treat, nice one.
Finally got rid of iCloud generic email description.
Thanks again
Matt
 
Comment

Mike MA

macrumors 68020
Sep 21, 2012
2,064
1,735
Germany
Stumbled across the same behaviour. Surely this is not a bug, rather Apple wants to push the iCloud Label into our minds. The workaround works though, but at this point I just have to resign...at least my whife has her real named featured on the iPad :(
 
Comment

allpurposeguru

macrumors newbie
Apr 1, 2009
9
6
Stumbled across the same behaviour. Surely this is not a bug, rather Apple wants to push the iCloud Label into our minds. The workaround works though, but at this point I just have to resign...at least my whife has her real named featured on the iPad :(

This workaround worked in iOS 8, but no longer works in iOS 9. That means that there was a concerted effort to force users to have the primary account named "iCloud". Someone had to write code to do this.

Problem is, if you have some other email address established as your iCloud login, that means that you have to remember that iCloud does NOT mean iCloud, it means whatever email address you signed up to iCloud WITH. (remember, this description ONLY shows up in Mail.)

Hey, Apple? Quit screwing around with forcing people to have all the nitpicky details the way YOU want them and fix iCloud Drive so I can HAVE THE FILES I WANT ON MY COMPUTER. I think you have better things to do than force the look and feel AWAY from what I want.
 
Comment

Theareubs1

macrumors newbie
May 20, 2020
2
0
Great stuff, thanks for your reply...... sound like a long winded way around it but might still give it a go, the main thing is that its not something silly I am doing to miss the option to change..... I will now sleep peacefully at night!!!!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.