Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.
Status
Not open for further replies.

eriX

macrumors member
Original poster
May 11, 2007
32
0
Hi guys!

I´ve download a torrent file of 6.5 Gb :eek: and finally after several weeks i got a message from Stuffit Xpander wich told me that my rar file is damaged.

Can someone help me with this frustrating situation? :confused:
 

Sherman Homan

macrumors 6502
Oct 27, 2006
463
0
If the download completed, then the was some sort of response that indicated it was all there. That probably means that the original was no good!
 
Comment

brkirch

macrumors regular
Oct 18, 2001
191
1
If the file is actually corrupt and not just unsupported by Stuffit and is not an incomplete download you might be able to repair it. At http://www.rarlabs.com there is a Mac OS X port of their rar program. Download and decompress it. Open the terminal and drag the file named rar from the decompressed folder to the terminal window, then click the terminal window and type "r ", drag the rar file you want to repair onto the terminal window, click the terminal window and hit return. If the file has a rar recovery record then a repair will be attempted.
 
Comment

eriX

macrumors member
Original poster
May 11, 2007
32
0
Thank you very much guys I tried UnrarX and I can extract my legal file partially The other part is damaged, more users can confirm it.
 
Comment

steelfist

macrumors 6502a
Aug 10, 2005
577
0
download the file again to another location, and if possible, have the program recheck the download.
 
Comment

woofbow

macrumors newbie
Sep 16, 2010
18
0
Repairing a Corrupt (CRC error) RAR archive on OS X

If the file is actually corrupt and not just unsupported by Stuffit and is not an incomplete download you might be able to repair it. At http://www.rarlabs.com there is a Mac OS X port of their rar program. Download and decompress it. Open the terminal and drag the file named rar from the decompressed folder to the terminal window, then click the terminal window and type "r ", drag the rar file you want to repair onto the terminal window, click the terminal window and hit return. If the file has a rar recovery record then a repair will be attempted.

Well, Mr. Brkirch -
It's been over 3 years since you posted the above reply, and I luckily found your post.

I d/l a 2-gig post in 13 rar segments. One of the segments was corrupt, even after multiple d/ls. I use UnRarX to decompress and join. It's very simple and effective, I use it all the time, but it is pretty basic and has no repair function.

I looked all over for software to help me fix the error, but there isn't any for Mac OS X, it appeared. Some folks told me I needed a PAR file, but I tried fooling with MacParDeluxe, which I've had for some time as well, but when it encountered the bad RAR archive it couldn't do anything.

Fortunately I found your post. I'm not a big command-line guy, but I d/l the WINRAR command-line tool for Mac OS X. It's currently at version 3.9.3 but I found an older one, 3.8.0 to be sure it would work OK with my version of OS X (10.4.11).

Anyway, I tried the steps you outlined, but it didn't work at first. The only thing missing in your directions is to identify the destination path where you want the fixed file placed. Once I did that, the program scanned the file, found the recovery record, and fixed it.

The archive combined and unstuffed perfectly after that.

Thank you, sir, for your expertise and post. I appreciate it!
 
Comment

gskiser

macrumors member
Jun 23, 2003
53
0
Well, Mr. Brkirch -
It's been over 3 years since you posted the above reply, and I luckily found your post.

I d/l a 2-gig post in 13 rar segments. One of the segments was corrupt, even after multiple d/ls. I use UnRarX to decompress and join. It's very simple and effective, I use it all the time, but it is pretty basic and has no repair function.

I looked all over for software to help me fix the error, but there isn't any for Mac OS X, it appeared. Some folks told me I needed a PAR file, but I tried fooling with MacParDeluxe, which I've had for some time as well, but when it encountered the bad RAR archive it couldn't do anything.

Fortunately I found your post. I'm not a big command-line guy, but I d/l the WINRAR command-line tool for Mac OS X. It's currently at version 3.9.3 but I found an older one, 3.8.0 to be sure it would work OK with my version of OS X (10.4.11).

Anyway, I tried the steps you outlined, but it didn't work at first. The only thing missing in your directions is to identify the destination path where you want the fixed file placed. Once I did that, the program scanned the file, found the recovery record, and fixed it.

The archive combined and unstuffed perfectly after that.

Thank you, sir, for your expertise and post. I appreciate it!

I'm trying to do the same thing. Could you expand on how to identify the destination path within the terminal window? It may be obvious, but I'm not very familiar with using the terminal.
 
Comment

woofbow

macrumors newbie
Sep 16, 2010
18
0
I'm trying to do the same thing. Could you expand on how to identify the destination path within the terminal window? It may be obvious, but I'm not very familiar with using the terminal.

Hi. Sure thing.

First, to reiterate, drop the "rar" program file from the "rarosx" folder onto the terminal window. Then make sure there's a space, then type "r" (without the quotes). Then make sure there's another space. Then drop the file you want repaired onto the terminal window (it'll give the path and name of the file). Then make sure there's another space, and type "Users/yourname/Desktop" or wherever you want the fixed file placed. It may be easier to just drop the folder where you want it placed onto the terminal window again so there's no chance at typos.

Then hit "return" and the repair scan will start. if the file has a recovery record, it will say that it was found almost immediately. Then it goes about repairing the file. Depending on the size of the file, it may take a couple minutes.

Note that the file will have the prefix "fixed" appended to the beginning of the filename. You'll need to delete that once the repair process has completed before you attempt to join the files again.

That should do the trick!
 
Comment

gskiser

macrumors member
Jun 23, 2003
53
0
Thank you!!!

Hi. Sure thing.

First, to reiterate, drop the "rar" program file from the "rarosx" folder onto the terminal window. Then make sure there's a space, then type "r" (without the quotes). Then make sure there's another space. Then drop the file you want repaired onto the terminal window (it'll give the path and name of the file). Then make sure there's another space, and type "Users/yourname/Desktop" or wherever you want the fixed file placed. It may be easier to just drop the folder where you want it placed onto the terminal window again so there's no chance at typos.

Then hit "return" and the repair scan will start. if the file has a recovery record, it will say that it was found almost immediately. Then it goes about repairing the file. Depending on the size of the file, it may take a couple minutes.

Note that the file will have the prefix "fixed" appended to the beginning of the filename. You'll need to delete that once the repair process has completed before you attempt to join the files again.

That should do the trick!

Wow...thank you so much! Everything worked perfectly. I was up to the point where I dropped in the file needing to be prepared, but couldn't get beyond that. However, I wasn't putting a space after the 'r', so that detail you provided also really helped. Thank you so much again for taking the time to respond with such easy to follow instructions!!!
 
Comment

chrono1081

macrumors 604
Jan 26, 2008
7,777
2,236
Isla Nublar
A RAR file corrupt??? Never...:p

I hate RAR and refuse to use it if I can help it. Its the quickest way to lose data through compression.
 
Comment

woofbow

macrumors newbie
Sep 16, 2010
18
0
Wow...thank you so much! Everything worked perfectly. I was up to the point where I dropped in the file needing to be prepared, but couldn't get beyond that. However, I wasn't putting a space after the 'r', so that detail you provided also really helped. Thank you so much again for taking the time to respond with such easy to follow instructions!!!

My sincere pleasure, sir. If it weren't for Mr. brkirch's above post from THREE years ago, I would have been lost as well. I searched everywhere I could on Google, but there just isn't a GUI app for Mac OS X that does this.

I'm not a regular Terminal user either, although I used to do more of it a few years ago when I was setting up Apache websites. I think it's more of a friend than enemy, though. It just takes a lot of trial and error, sometimes, and closely reading either the on-screen instructions or going to the MAN pages.

Cheers!
 
Comment

DaTr0ll

macrumors newbie
Dec 7, 2010
1
0
Problem with fix

Gskiser,

What I have is a bad rar within a rar portion and that is what is causing the expansion to fail. Any thoughts on how to fix this particular problem or am I just out of luck? :eek:
 
Comment

cjedj

macrumors newbie
Nov 2, 2009
26
0
woofbow and brkirch - at the risk of turning this into the board's thread which goes the longest between posts - thank you both. Your instructions just saved me from tearing my hair out over a failed CRC. Great work!
 
Comment

orangestudio

macrumors newbie
Jul 15, 2010
2
0
Terminal not working...

I dropped the program file "UnRarX" into Terminal and it turns into unrarx.app and it says it's a directory, after 'Bash'. How can I work around that? Help!
 
Comment

Capt Crunch

macrumors 6502
Aug 26, 2001
486
14
Washington, D.C.
If you have a corrupted .rar file, you need the associated par files. Usually those are included in the download.

All you need to do is make sure the .rar and .par files are in the same directory. Get MacParDelux and open any of the .par files with it. It will automatically repair any corrupted .rars and also concatenate the .rar files as well.

No command line needed.
 
Comment

AdrianK

macrumors 68020
Feb 19, 2011
2,230
2
I dropped the program file "UnRarX" into Terminal and it turns into unrarx.app and it says it's a directory, after 'Bash'. How can I work around that? Help!
Because unrarx.app is a folder, not a command line application.

Re-read the post, you need the command line version of the official RAR application.
 
Comment

cjedj

macrumors newbie
Nov 2, 2009
26
0
If you have a corrupted .rar file, you need the associated par files. Usually those are included in the download.

All you need to do is make sure the .rar and .par files are in the same directory. Get MacParDelux and open any of the .par files with it. It will automatically repair any corrupted .rars and also concatenate the .rar files as well.

No command line needed.

Nine times out of ten, yes. The tenth time, you need to go the command line way explained above.
 
Comment

Lyubomir1001

macrumors member
Aug 19, 2010
58
0
I did the "r" command but when I got to repairing, it said data recovery not found. Here is the problem:


Lyubomir-Gizdarskis-iMac:~ lyubomir9$ /Users/lyubomir9/Desktop/rar r /Users/lyubomir9/Desktop/untitled\ folder\ 3/untitled\ folder\ 4/codbo4861.dmg.part1.rar Users/VeselinGizdarski/Desktop

RAR 4.10 beta 2 Copyright (c) 1993-2011 Alexander Roshal 20 Oct 2011
Shareware version Type RAR -? for help

Building fixed.codbo4861.dmg.part1.rar
Scanning...
Data recovery record not found
Reconstructing /Users/lyubomir9/Desktop/untitled folder 3/untitled folder 4/codbo4861.dmg.part1.rar
Building rebuilt.codbo4861.dmg.part1.rar
Found codbo4861.dmg
Done
Lyubomir-Gizdarskis-iMac:~ lyubomir9$ /Users/lyubomir9/Desktop/untitled\ folder/codbo4861.dmg


I didn't even get the file on my desktop.. All I had was ".rebuilt" added to the .rar file. What do I do?

it still says the file is corrupted
 
Comment

briankeith513

macrumors 6502a
Feb 6, 2011
940
136
Atlanta, GA
I did the "r" command but when I got to repairing, it said data recovery not found. Here is the problem:


Lyubomir-Gizdarskis-iMac:~ lyubomir9$ /Users/lyubomir9/Desktop/rar r /Users/lyubomir9/Desktop/untitled\ folder\ 3/untitled\ folder\ 4/codbo4861.dmg.part1.rar Users/VeselinGizdarski/Desktop

RAR 4.10 beta 2 Copyright (c) 1993-2011 Alexander Roshal 20 Oct 2011
Shareware version Type RAR -? for help

Building fixed.codbo4861.dmg.part1.rar
Scanning...
Data recovery record not found
Reconstructing /Users/lyubomir9/Desktop/untitled folder 3/untitled folder 4/codbo4861.dmg.part1.rar
Building rebuilt.codbo4861.dmg.part1.rar
Found codbo4861.dmg
Done
Lyubomir-Gizdarskis-iMac:~ lyubomir9$ /Users/lyubomir9/Desktop/untitled\ folder/codbo4861.dmg


I didn't even get the file on my desktop.. All I had was ".rebuilt" added to the .rar file. What do I do?

it still says the file is corrupted

I have this exact same issue, and it looks exactly like it is in this post. My file is only like 60mb.
 
Comment

boycom

macrumors newbie
Jan 14, 2012
4
0
Almost there, just can't locate file

Hey guys, I did what woofbow said, and it came up as 100% fixed, but the only problem is i can't see the file where i've told it to save it

what's more interesting is that even when i try to do it again and save it in a different place, it keeps asking me 'do you want to overwrite the existing file with this name' meaning that even if i've changed the location, it must still be saving in the same place (don't know where that is)

I've tried using spotlight to locate it and nothing's come up
tried restarting computer, still nothing
I even tried showing the hidden files, and still nothing

It's so close, yet annoyingly won't show
Can anyone help please?


Thanks a million!

Noah
 
Comment

boycom

macrumors newbie
Jan 14, 2012
4
0
empty trash

Hey guys,

For reasons I don't quite understand, emptying the trash seems to solve this
The file is now extracting, and all who have contributed to this thread are gods in my eyes!

Thank you very much

Noah
 
Comment
Status
Not open for further replies.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.