How to reset firmware?

Discussion in 'MacBook Pro' started by neliss, Feb 18, 2011.

  1. neliss macrumors newbie

    Joined:
    Feb 18, 2011
    #1
    I have a problem with my 2009 macbook pro (mbp5,5).
    I ran a firmware update but it failed, and ever since i can't boot my MBP.
    When i turn it on it beeps S-O-S in morse (3x3 beeps) which indicates a firmware update is in progress as described on the apple support site.

    The apple support site mentions there is a firmware restoration CD available, but there is no version listed for my macbook model. I have tried several, but they did not work.
    I also tried some key combo's like the PRAM reset, but it seems the macbook didn't respond to any (also the capslock led doesn't work).

    I went to an apple store hoping they could fix my problem, but they didn't knew the problem and told me they could only replace my logic board with a new one. However i have no applecare warranty left, so this would cost me a lot of money.

    Has anyone experienced the same problem and found a solution?
    Or does anyone have any tips of things that could work?
    Please be so kind to help me, you could save me an expensive repair!
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    I don't see one for that model either. So far as I've been able to tell, they don't release these CDs for every model. As it currently stands, you have a near-dead logic board. If you can't get your hands on the right CD for your model, then it will stay this way. You can try complaining to Apple about the lack of availability of a firmware restore CD.
     

Share This Page