How to resolve locked up jailbroken iPhone stuck in "recovery mode" (see pictures)

Discussion in 'Jailbreaks and iOS Hacks' started by Granitel, Oct 22, 2011.

  1. Granitel, Oct 22, 2011
    Last edited: Oct 26, 2011

    Granitel macrumors member

    Jul 27, 2011
    A few months ago I picked up a jailbroken iPhone 3G with OS 4.2.1 (8C148) off of Craigslist for my kid who has been using it successfully on T-Mobile for voice/text & wifi ever since.
    - Why I decided NOT to change the iPhone IMEI (I simply switched from AT&T to T-Mobile)

    • However, today it locked up & I've done a hard reboot scores of times
    • From a blank screen, the hard reboot gets us the apple logo
    • Then it goes to the 'connect to iTunes' USB->iTunes logo
    • And, lastly, plugged into the Windows PC with iTunes, iTunes apparently tells us the iPhone is locked in 'recovery mode'

    The only text information we get is as shown below:
    What is the next step?

    It won't do a soft reset (i.e., holding down the sleep/wake button & waiting for the slider to appear); and when I do a hard reset (i.e., holding both the sleep/wake & power buttons for ten seconds), it goes into "recovery mode" as shown in the photo sequence below.

    Q: What happens if I say "yes" to the iTunes restore request?

    I'm afraid to restore directly from iTunes because it's jailbroken and we don't want iTunes to restore the original OS ... so my first question is:
    Q: If I elect to restore from iTunes, will the jailbreak disappear?

    The error has no words so it's difficult for me to find the solution in a google search (all I come up with is iPhone restore which 'might' actually blow away the jailbreak, data, and use of T-Mobile).

    May I ask the key question?
    Q: What do you suggest for this jailbroken iPhone which is stuck in 'recovery mode'?


    Attached Files:

  2. Granitel, Oct 24, 2011
    Last edited: Oct 26, 2011

    Granitel thread starter macrumors member

    Jul 27, 2011
    Still waiting ...

    Unfortunately, to move forward, I was forced to additionally ask elsewhere:
    - What are my options? (Jailbroken iPhone 3G iOS 4.2.1 stuck in iTunes recovery mode)

    I'm not sure what I'm doing though ...

    At the moment, I'm exploring the suggested Tiny Umbrella (TU) solutions, and if that doesn't work, I'll update back to the un-jailbroken iOS 4.2.1 on iTunes and then I'll try Sn0wbreeze to jailbreak, and then to install Ultrasn0w to unlock (none of which have I done so I'm breaking new ground for me).

    Some on that very helpful forum are also advising me to skip the SHSH blobs for 3.1.3 on the iPhone 3G & to simply just download 3.1.3 for the 3G on iClarified's ipsw site and shift+restore in iTunes.

    The problem, of course, is that I don't really understand these 'suggestions' so I have to research them as they come in ... but the GREAT advantage of suggestions is that it limits the research from infinity to something manageable!

    Whatever I find out, when I'm successful, I'll try to inform the folks here so they too can benefit from the technical knowhow (my threads are always well detailed with plenty of screenshots and cross links expressly so that others can more easily solve the problems by following in my footsteps).
  3. chargit macrumors 6502a


    Jan 17, 2010
    Evansville, In
    sarcasm wont get you anywhere......

    anytime you do a restore you will lose your jailbreak no questions asked... but since your on a 3g its really no big deal. dont use snowbreeze if they told you to do that I would not return to that forum. go to and follow the instructions on jailbreaking with the firmware you are using. it will have snowbreeze as one of the solutions but dont use it. also tinyumbrella will help you kick the device out of recovery in most situations. its a very usefull tool. depending on what your firmware and baseband were prior to your issue will determine what you need to do next. try to kick out of recovery with tinyumbrella first then report what your firmware and baseband are. if that wont work go ahead and restore then report what you have. you may need to install the iPad baseband so you can unlock it again to use on T-mobile. you are looking for 4.26.08, 5.11.07, 5.12.01, 5.13.04, and 6.15.00
  4. Granitel, Oct 25, 2011
    Last edited: Oct 26, 2011

    Granitel thread starter macrumors member

    Jul 27, 2011
    What is the next step after getting out of recovery mode by downgrading the OS?

    So, I followed your advice as shown below to downgrade the jailbroken iPhone from iOS 4.2.1 to iOS 3.1.3 in 'restore mode' (nothing was done in DFU mode yet).

    Is my next step to somehow 'activate' (even though I'm on T-Mobile) or is it to jump right to a jailbreak (using redsn0w 0.9.4 or Sn0wbreeze 3.1.3 -V1.3) and then to unlock (using blacksn0w or ultrasn0w)?


    Attached Files:

  5. mushtaqc, Oct 26, 2011
    Last edited: Oct 26, 2011

    mushtaqc macrumors newbie

    Oct 26, 2011
    Try this...I had same issue and it solved

    first download the files i.e. 4.2.1
    Mirror :

    Downnload Ireb from the net (Google it you will get it)

    How to Restore :

    Step 1: Go to DFU mode use iReb to enter DFU mode.
    Start iTunes and press and hold Left “Shift” button on the keyboard and then click on “Restore” (Not “Update” or “Check for Update”)
    button in iTunes and then release this button. This will make iTunes prompt you to select the location for your custom firmware 4.2.1 file.
    Select the required custom .ipsw file that you have downloaded.
    Step 2: Now sit back and enjoy as iTunes does the rest for you. After the installation is done, your iOS device will be jailbroken on iOS 4.2.1

    Now go to Cydia and install UltraSn0w to unlock your phone

    After it work good and if you get No Service then follow below steps.

    How To Reflash 06.15.00 baseband
    Step 1) – The first thing you must do is download RedSn0w 0.9.9b6 which is compatible with both Windows and Mac OS X from the iJailbreak Downloads Section.

    Step 2) – When RedSn0w has downloaded you will need to launch RedSn0w.

    Step 3) – Once RedSn0w is up and running you will need to click the Extras Button followed by the Select IPSW Button. Upon clicking the Select IPSW Button you will need to select your iPhone 3GS’ iOS firmware file (the firmware it is currently running… most likely iOS 5). If you do not have your iPhone 3GS’ firmware file please download it from the iJailbreak Downloads Section.

    Step 4) – After you have selected the iPhone 3GS iOS firmware file you will need to go back to the main menu and click the Jailbreak Button.

    Step 5) – You will now need to put your iPhone 3GS into DFU mode. Read the instructions and click the Next Button to begin the DFU mode process.

    Step 6) – Once your iPhone 3GS in DFU mode, you can select options to customize the Jailbreak. You must select the Reflash baseband 15.06.00 and uncheck Install Cydia.
    Step 7) – After you have selected the Reflash 06.15.00 baseband option, click the Next Button and RedSn0w will begin re-jailbreaking/re-flashing your iPhone 3GS’ baseband.

    When the process is ready to discover the iPhone 3GS should work properly, and what kind of 3G connectivity problems / service issues should be strengthened.
  6. mushtaqc macrumors newbie

    Oct 26, 2011
    Replace iOS 5 with your firmware

    did you jailbreak your phone in order to unlock it...No service can be of following reason:

    Phone need Jailbreak and then unlock
    Instable baseband
  7. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    What are you talking about? The guy has a 3G phone and the latest firmware for 3G is 4.2.1.


    You have restore your phone to 3.1.3 (factory setting). So, there are 2 ways for you go get pass this screen.
    1. Use an AT&T sim card, put it into your phone, hook it up with Itunes and it will bring your phone to home screen. Inactive/use AT&T sim card works. It does not need to be active.
    2. Hactivate it with Redsn0w.

    If order for your T-Mobile to work again, you need to unlock it with Ultrasn0w. Check the baseband on your phone first.
  8. JunkyDog macrumors 6502

    Sep 17, 2011
    your posts indicate that he has a 3GS, but he dont, so think again, and do not missled the poor guy. He owns a 3G, you wont get the software you suggested to fit in the 3G iPhone, i wont recommend it..

    Would download the orginal firm and use either snowbeeze 2.2.1 or redsnow 0.9.5b6 to jailbreak and unlock it with ultrasnow from cydia..

    This i hope will clarify some doubts on mushtaq's post about 3GS software that wont even fit in a 3G iPhone..
  9. Granitel, Oct 26, 2011
    Last edited: Oct 26, 2011

    Granitel thread starter macrumors member

    Jul 27, 2011
    Thanks. All this advice is great, but each suggestion entails hours of looking up the answers to find out the exact sequence of steps for my situation.

    To clarify, Tiny Umbrella, on WinXP, reports the iPhone 3G I had bought initially jailbroken on iOS 4.2.1 which locked in restore mode, is now:
    • Device Model = MB702LL/A - iPhone3G
    • Installed Firmware Version = 3.1.3
    • Installed Baseband Version = 06.15.00-5.9_M3S2

    This makes sense!

    I DO have my old AT&T SIM card (because I switched off of AT&T expressly because they penalize users of smart phones who do not want a data plan)!

    Here is what I 'think' you guys are suggesting (is this right?):

    1. This morning, I downgraded iOS 4.2.1 to iOS 3.1.3 using iTunes, iClarify, & Tiny Umbrella (in order to get out of iTunes restore mode)
    2. But then, the iPhone 3G had no sea-of-icons home screen, and could only make emergency calls on T-Mobile
    3. My next step was to activate (either with an active or inactive AT&T SIM card or using Hacktivate (with Redsn0w & SAM)
      • Note: I never needed Redsn0w because a 3-month old inactive AT&T SIM card worked great!
      • That finally got me the sea-of-icons home screen! (THANKS!)
    4. I think the next step is to get the WiFi working at home
    5. Then, I think, I need to install Cydia (can I now upload Cydia at this point?)
    6. With Cydia, I can upload Ultrasn0w
    7. Then, I can Jailbreak (using Ultrasn0w)
    8. Lastly, I need to unlock (again using Ultrasn0w)
    Is this the correct plan of action for an iPhone 3G, iOS3.1.3, Baseband 06.15.00-5.9?


    Attached Files:

  10. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    Which 3.1.3 firmware on your phone, there are lot of jailbreaking tools available to jailbreak your phone.

    1. Spirit. This is very simple, all you need to do is download it, hook up your phone and hit 1 button to jailbreak.
    2. Redsn0w. You know how to use it.
    3. This is a simple tool where you don't even need to hook your phone up to your computer. Make sure your phone hook up to wifi, open Safari and type in and enter, it will ask you to slide to jailbreak.

    Once you're done with one of the method above, Cydia icon will be added to your screen.

    1. Open Cydia, let it load and update.
    2. click on manage, then sources
    3. click on, then ultrasn0w 1.2.4 and install it.
    4. Go to Setting, general, network, turn 3G off.
    5. Pop in your T-Mobile sim and it will search and pick up signal within few seconds.
  11. Granitel, Oct 26, 2011
    Last edited: Oct 26, 2011

    Granitel thread starter macrumors member

    Jul 27, 2011
    Success at last! (Thank you for your kind help!)

    I'm hoping the 3.1.3 iOS will be faster & more compatible (e.g., with Cycorder) than the 4.2.1 was; however, I'm not really sure 'how' I downgraded to iOS 3.1.3 without going into DFU mode (must have been the TSS button in Tiny Umbrella); but with your advice, things moved (finally) right along! :)

    1. With the iPhone 'activated' using a 3-month-old inactive AT&T card & with the T-Mobile SIM card in the still-locked iPhone ...
    2. I set up the WiFi encryption for my home network (I don't have the T-Mobile data plan ... which is the whole reason for switching off of AT&T)
    3. And then simply went to, as you said, in Safari & moved the slider
    - As you said, I eventually saw the message "Cydia has been added to the home screen" (so that solves the question of how to get Cydia on board)
    4. I started Cydia ...
    - It asked "Who Are You?" (I said "Hacker" although that was being generous)
    - Cydia started downloading packages & reloading data.
    - Cydia requested one of 3 essential upgrades (Essential, complete, ignore).
    - I let it do a complete upgrade until it asked to "Close Cydia & Restart".
    5. As instructed, I first clicked on "Manage Account" but I soon realized you meant the "Manage" icon at the bottom of the Cydia screen (book icon).
    - Then I hit the "Sources" button in the center of the screen.
    - Then I hit "" & then "ultrasn0w" (which only then revealed itself to be version 1.2.4)
    - I hit the "install" and "confirm" buttons & it installed & reloaded data.
    - I had to hit the home button to "Reaload Springboard"
    - As I was reading what to do next, a zillion backed-up text messages came in (it is, after all, my kid's iPhone)
    6. I went to the home screen & pressed Settings, general, network, and changed "Enable 3G" from "ON" to "OFF".
    7. I had the T-Mobile SIM card already in so I didn't have to pop it in at this point ... but ... everything was working perfectly!

    Thank you very much for walking me through this (difficult for me) fix which started with a T-Mobile jailbroken/unlocked iOS 4.2.1 iPhone 3G (baseband 06.15.00) which was stuck in iTunes restore mode - and now ended with a working T-Mobile jailbroken/unlocked iOS 3.3.1 iPhone 3G (baseband stayed the same)!

    To help others, here are some pictures of this set of steps you just walked me through.

    Attached Files:

    • 01.jpg
      File size:
      121.7 KB
    • 05.jpg
      File size:
      118 KB
    • 07.jpg
      File size:
      588.3 KB
    • 20.jpg
      File size:
      125.9 KB
    • 29.jpg
      File size:
      146.1 KB
  12. DaIndian macrumors newbie

    Apr 5, 2012
    need to restore my Jailbroken Iphone 3

    Friends, I need some help please. I have a jailbroken Iphone 3. And It was not working well, and so foolishly I decided to erase all content and restore. I tried this and my iphone got stuck in a cycle between a black screen and the apple logo screen. Now i have done the hard reset while connected to itunes. I have been unable to reset the phone. i no longer want to have the phone jailbroken. Please help!
  13. sdmanandhar macrumors newbie

    Nov 19, 2012
    Successful at last

    Hi all,
    I had a similar problem as the OP and following the thread, I have successfully restored my iPhone 3G. Although some of the posts say not to use sn0wbreeze, I used v2.9.5, primarily because I had already downloaded it. Now I have one up and running iPhone!!! Its running firmware v 4.2.1, jailbroken, and unlocked using cydia/ultrasn0w.

    Thanks everyone. This has been a heck of a fortnight for me!!!
  14. onahiatus macrumors newbie

    Feb 21, 2013

    After countless forums and searches I finally stumbled upon your post and saw that you solved the problem. I'm in the same situation as you now, I accidentally out of instinct updated my jailbroken iPhone causing it to be in stuck in recovery mode bootloop now. However, I just want to know, did you lose your data? I have tons of photos and unsynced data (I know, my bad) on my phone I can't bear to just 'restore' it.

    Many thanks in advance for the help.

  15. alifenorm macrumors newbie

    Aug 20, 2013
    first of all big kudos to Granitel, his posts are terrific and for someone moving the first steps in this world are very useful.
    I have a 3g locked in recovery status, tried some solutions but to no effect now.
    Got the same questions as onahiatus: were you able to recover any data before recovering phone use? or you lost them all?
  16. TriJetHero macrumors 601


    Oct 13, 2010
    How to resolve locked up jailbroken iPhone stuck in "recovery mode" (see pict...

    Maybe try in a different thread or make 1 yourself, as this is an 6 month old thread and asking someone who has only 1 posting i would not expect an answer...
  17. alifenorm macrumors newbie

    Aug 20, 2013
    well he has been active again (last june in fact) and this seemed the most pertinent thread to draw is attention for a yes or no reply.
    seem like he lost the data while it should be possible recover them by direct access to the data in the phone.
    like here
    anyway I am just getting my feet wet before trying to do it. and if you want to give some hint I gladly post the whole story here, or another thread.
    thanks for the advice anyway!
  18. dinuka1997 macrumors newbie

    Dec 20, 2013
    i stucks in recovery mood! anyone can help.?


    Myjail broken and unlocked iphone 3gs stucks in recovery mood when i try to update ios 4.1 to 6.1 by custom ipsw which made by snowbreez.
    My iphone is running on ios 4.1 (00.06.15)(new bootrom )
    but i try to update it with old bootrom ipsw.
    I try so many things to get out of recovery mood! but it doesnt fix.
    Im new to apple and can any one help me quickly step by step! :confused:

    3GS-4.1ios-(00.06.15 basband)-new bootrom- 16gb :apple:

    after fixing i want help to upgrade and jail break and unlock it safely
    Anyone can help? :confused:
  19. TriJetHero macrumors 601


    Oct 13, 2010
    Do you have valid manually saved SHSH's for 6.1?
    You can check with ifaith

    What are the first 5 digits of the serial nr?

    You can try to restore to 4.1.
    Put the phone in DFU and hit SHIFT-restore in itunes, now select the STOCK 4.1 IPSW.

Share This Page