How to restore from 5.0.1 to 5.0.1? I have my SHSH Blobs

toxicfume

macrumors newbie
Original poster
Mar 2, 2012
16
0
Hi all, so I've had my iPhone4 jailbroken since sometime and am on 5.0.1 (never upgraded to 5.1) but the phone is giving me some problems now (Safari fails to load and there is a weird touch detection issue towards the top of the screen).. so my question is, how do I go about restoring?

Thanks :)
 

NanoNyrd

macrumors regular
Dec 1, 2011
218
0
I think you can find detailed tutorials on the net. If you use Windows, you can follow this guide: http://www.redmondpie.com/downgrade-5.1-to-5.0.1-5.0-4.3.3-4.3.5-on-iphone-ipad-ipod-touch-how-to-tutorial/
(Note that although it says downgrade from 5.1, it should not really matter).

Alternatively, use redsn0w on any platform. First stich your SHSH blobs to the IPSW file (with redsn0w), then put your phone in Pwned DFU mode (with redsn0w), then restore with iTunes. If you get an error from iTunes leaving your phone in restore mode, use redsn0w to kick it out of restore mode.
(This is purely theoretical, I have not done it since Apple stopped signing 5.0.1)
 

toxicfume

macrumors newbie
Original poster
Mar 2, 2012
16
0
I think you can find detailed tutorials on the net. If you use Windows, you can follow this guide: http://www.redmondpie.com/downgrade-5.1-to-5.0.1-5.0-4.3.3-4.3.5-on-iphone-ipad-ipod-touch-how-to-tutorial/
(Note that although it says downgrade from 5.1, it should not really matter).

Alternatively, use redsn0w on any platform. First stich your SHSH blobs to the IPSW file (with redsn0w), then put your phone in Pwned DFU mode (with redsn0w), then restore with iTunes. If you get an error from iTunes leaving your phone in restore mode, use redsn0w to kick it out of restore mode.
(This is purely theoretical, I have not done it since Apple stopped signing 5.0.1)
Thanks for the response. So how do i "fetch" my SHSH blob so that I can "stitch" it to my NO_BB IPSW?

Do I have to "stitch" the SHSH blob to the 5.0.1 firmware file first? Or do I use redsn0w to preserve baseband first?
 
Last edited:

NanoNyrd

macrumors regular
Dec 1, 2011
218
0
Thanks for the response. So how do i "fetch" my SHSH blob so that I can "stitch" it to my NO_BB IPSW?

Do I have to "stitch" the SHSH blob to the 5.0.1 firmware file first? Or do I use redsn0w to preserve baseband first?
Start redsn0w, choose Extras, choose SHSH blobs, choose Fetch. Stiching is on the same screen, Pwned DFU on the previous screen.

Now, if you have to preserve the baseband, I would guess you should do that before stitching, but I honestly do not know. If you preserve baseband I am pretty sure you are going to get an error from iTunes at the end of the restore, and will need to use redsn0w to recover (Recovery fix on the Extra screen).

Good luck, please report back how it went.
 

dhlizard

macrumors G4
Mar 16, 2009
10,213
118
The Jailbreak Community
All restores to any iOS5 firmware require not only the hash file but the APTicket also.
Then you must stitch both to your IPSW in order to restore

At the completion, when you get error -1, use Redsn0w to kick it out of recovery
 

toxicfume

macrumors newbie
Original poster
Mar 2, 2012
16
0
Thanks for the replies, guy. Well, I ended up never restoring because that problem I had somehow got fixed. The touch area around the status bar at the top of the screen does not act erratically anymore and so far everything has been looking smooth. If for any reason it ever comes up again, or if I have any other problem, I'll be sure to read this thread. Appreciate all the responses. :)
 

petersun21

macrumors newbie
Mar 24, 2012
7
0
hope someone can help

I bought a verizon iphone 4s with bad esn. Jailbroke it and installed SAM. Bought a CCCSim card and tried to unlock it. Was not successful. Stupid enough, tried reset all settings. The phone stuck in the initial setup (activation problem). I believe it is not starting CDMA network, instead to use GSM to activate. I do not want to upgrade to 5.1 yet. I cannot rejailbreak it. I cannot restore it to 5.0.1 yet. I believe there should be a solution to modify some files on the phone to have it pass the initial setup. Any help is appreciated.