how to revive my iPod

Discussion in 'iPod' started by fjs08, Sep 2, 2006.

  1. fjs08 macrumors 65816

    Jun 25, 2003

    I have a 3+ yr old iPod 15GB model. Last used it the end of July. Worked perfectly. It's been sitting for a month now. I turned it on, the Apple logo came on and that's that!!! Nothing more. It's stuck there. I can here a whirring noise inside, but nothing more than that. Plugged it into the Firewire port of my Titanium Powerbook, nothing. Left it for 10 minutes. Unplugged it from the Firewire port and then directly into the AC recharger. Still nothing. My daughter had a problem with hers and someone told her to "restart" it by holding in the center button and the Menu button at the same time. That didn't work either. Actually, I've tried a bunch of combinations of buttons and nothing works. Is it dead?? Oh, I can't shut it off either? It is basically stuck on the Apple logo??



  2. iSaint macrumors 603


    May 26, 2004
    South Mississippi y'all, near the water!
  3. fjs08 thread starter macrumors 65816

    Jun 25, 2003

Share This Page