How to Right Click: Remote desktop into a windows PC

Discussion in 'MacBook Pro' started by masse, Jan 3, 2008.

  1. masse macrumors 6502a

    masse

    Joined:
    May 4, 2007
    Location:
    MA/GA
    #1
    I'm doing some research that requires me to remote in to a windows pc. I have no problems if I have my mouse...but I don't always have it.

    I was wondering if there's a known easy way to right click under windows 2000...I did a search and found nothing so sorry if this is a stupid question.
     
  2. TheStu macrumors 65816

    Joined:
    Aug 20, 2006
    Location:
    Carlisle, PA
    #2
    It has always been for me that the virtual machine responds like you think it would to how you do things in OS X... to put another way.

    Command+C rather than Ctrl+C, Ctrl+click to right click... that sort of thing.

    If your version of Remote Desktop Connection doesn't do that, get the new 2.0 version. It may still be in beta, but it has worked great for me in the past.
     
  3. masse thread starter macrumors 6502a

    masse

    Joined:
    May 4, 2007
    Location:
    MA/GA
    #3
    I'm pretty sure that was the first thing I tried. Could always remote in again and test it, but have a dentist appointment now so don't have time.
     
  4. MacEddie macrumors newbie

    Joined:
    Dec 15, 2008
    #4
    Actually it's Ctrl + Shift + Click.
     
  5. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #5
    You should be able to do two-finger click to invoke the contextual menu.

    That's how its been on every remote/virtualized platform i've used which includes:
    Citrix
    Remote Desktop
    VNC
    Console Session through ESX
    VMWare Fusion
    Parallels

    etc etc.
     
  6. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #6
    hhmm i was pretty sure that it was just Ctrl + Click.... have to check it when i get home
     
  7. dddane macrumors newbie

    Joined:
    Dec 16, 2008
    #7

    ding ding ding, winner. (thanks, btw, it's amazing how little info there is out there ... came across other forums asking the same thing yet nobody responded with that answer!)

    i came across this because i couldn't figure it out. for MS RDP on a mac Ctl+click definitely does not do it. It's ctrl+shift+click.

    and just in case anyone is compiling a list, on VMware Fusion, it's a simple ctrl+click to do it.

    ..the two finger click would only work on a laptop with a touchpad, no? or are these goofy side buttons on my new imac somehow able to be turned into two finger clickers? that would be somewhat ideal, by default they both seem to do the expose application thing (though i find them actually difficult to press the way the mouse is designed on the new imac..)
     
  8. rob ganly macrumors newbie

    Joined:
    Dec 10, 2010
    #8
    yep, i can confirm that it is ctrl, shift and click on MS RDC 2.0.1 (on snow leopard)

    :)

    rob ganly
     
  9. dtsteinb macrumors newbie

    Joined:
    Aug 4, 2014
    #9
    Can't Right Click

    Nothing is working for me. Is there something for the trackpad I need to either turn on or off in system preferences?:mad:
     
  10. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #10
    Erm. Thread that's been inactive for 4+ years?

    Suggest you create a new topic.
     
  11. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #11
    Mother of thread resurrection...

    Go to System Preferences → Trackpad.

    Under the Point and Click tab, check 'Enable secondary click' and immediately underneath it, select the option to click on the lower right corner of the trackpad, or tap with two fingers, depending on your preference.
     
  12. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #12
    You're telling me, I was actually around here then!!

    Anyway sure that'll enable it no worries. Surprised Apple don't enable it by default really...
     

Share This Page