How to run iOS 4.0

Discussion in 'iPhone' started by funrush, Apr 17, 2010.

  1. funrush macrumors regular

    Nov 22, 2008
    This a list of what you need to successfully run iOS 4.0.

    You need:

    - iPhone 3G/3Gs
    - Your UDID registered by a developer.
    - 4.0 .IPSW file (make sure you download the right one for your device)
    - iOS 4.0 developer tools installed! (xcode 3.2.3 ect.)

    If you do not have the dev-tools installed, you CAN NOT backup your iPhone. (This was confirmed by a Apple employee) Trust me you don't want to not back-up your iPhone for a few months.

    I'm writing this list because I made the mistake of trying to help Apple find bugs without paying the 99 dollars for the developer program. So if you're installing 4.0 'illegally' make sure you stick to these 4 rules.

    Happy beta testing :)
  2. goobot macrumors 603


    Jun 26, 2009
    long island NY
    never back up my phone. its better to just start over after a restore so the os is fresh.
  3. funrush thread starter macrumors regular

    Nov 22, 2008
    What about messages from your girlfriend and friends? And all your apps and Exchange settings ect.

Share This Page