How to select San Francisco in the fonts list?

Discussion in 'OS X El Capitan (10.11)' started by C64, Oct 3, 2015.

  1. C64 macrumors 65816

    C64

    Joined:
    Sep 3, 2008
    #1
    I'm trying to use San Francisco as the font for mail messages. The "Message list font" is set to "System Font", but I can't find that anywhere in the "All Fonts" list. Also no mention of "San Francisco". Any ideas?
     

    Attached Files:

  2. KALLT, Oct 3, 2015
    Last edited: Oct 3, 2015

    KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    San Francisco is restricted, you can’t use it like that. However, you can swap it with a Terminal command:
    Code:
    defaults write -app Mail NSFont ".AppleSystemUIFont"
    
    To change the font size:
    Code:
    defaults write -app Mail NSFontSize -int 12
    // Edit

    Hmm this does seem to affect the settings panel, but it won’t work in actual messages.
     
  3. C64 thread starter macrumors 65816

    C64

    Joined:
    Sep 3, 2008
    #3
    Hmm.. that does seem to change "Message font" in the preferences to "System Font Regular 12", but plain text is now displayed in Times New Roman.
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    I’ve tried a few other combinations with .SFNSText-Regular, -apple-system, -apple-system-body but they all fail in the message text.
     

Share This Page