How to Send and Receive SMS Messages on iPad and Mac via Text Message Forwarding

Discussion in 'Guides, How Tos and Reviews' started by MacRumors, Aug 13, 2018.

  1. MacRumors macrumors bot


    Apr 12, 2001

    Ever since iOS 7, Apple has provided a Text Message Forwarding service that can push SMS messages received through your iPhone's cellular network to your other Apple devices.

    Using the same network, the forwarding service also allows you to send messages from your iPad or Mac to other phone numbers, even if they don't support Apple's iMessages platform (dumbphones and Android devices, for example).


    For whatever reason, the Text Message Forwarding feature may not be enabled on your iPhone, so if you tend to miss standard text messages coming through to your phone when you're engaged with something on your Mac or iPad, it's definitely worth enabling.

    Once activated, those messages will show up on all your devices in the Messages app as green chat bubbles, allowing you to distinguish them from regular blue iMessages. Keep reading to learn how to activate the feature in iOS 11.

    How to Activate Text Message Forwarding in iOS 11
    1. Launch the Settings app on your iPhone.
    2. Tap Messages.
    3. Tap Send & Receive.
    4. Tap Use your Apple ID for iMessage.

      Tap Sign in to use your Apple ID for iMessage, or tap Select Other Apple ID and then enter the login credentials for the account you want to use.
    5. Wait for a moment while iMessage activates. Click OK in any dialog boxes that confirm your Apple ID is now being used for iMessage on your other devices.
    6. Tap back to Settings -> Messages, and tap the new Text Message Forwarding option in the menu.

      Use the toggle buttons next to the devices in the list to include or exclude them from the Text Message Forwarding service. Note that only devices logged into the same iCloud account and connected to the same Wi-Fi network will appear in the list.
    7. A security code may appear on the devices that you enable - make sure to type the code into your iPhone to activate them for the service.
    If you followed the steps above but the Text Message Forwarding option doesn't appear in your iPhone's settings app, check that your device is connected to Wi-Fi and the internet connection is good.

    Another solution is to turn off and then restart iMessages via Settings -> Messages -> iMessage. You can also try signing out of iMessage and signing in again: Select Settings -> Messages -> Send & Receive, tap your Apple ID at the top, and then tap Sign Out.

    Article Link: How to Send and Receive SMS Messages on iPad and Mac via Text Message Forwarding
  2. diego, Aug 13, 2018
    Last edited by a moderator: Aug 13, 2018

    diego macrumors regular


    Dec 21, 2003
    Canada & Mexico
    I've used sms forwarding ever since it was introduced, but you'd be surprised how many people are not even aware of the feature, plus it's a bit convoluted to activate for someone without a lot of tech skills.
  3. DeepIn2U macrumors 603


    May 30, 2002
    Toronto, Ontario, Canada

    This feature doesn’t work for for me and I’m doubtful this is supported on all authorized carriers of iPhones. This is regardless of the settings or toggling on/off.

    Many don’t understand what SMS is vs iMessage when describing these features.

    iPhone 8
    MacBook Pro (2018)
    Apple Watch S3

    ^ all these devices I own and are up to date. Signed into the same iCloud account on then all.

    Only my Apple Watch Nike+ S3 will show me SMS messages sent by the network provider to my iPhone; and that is because it’s connected via the Apple Watch iOS app and Bluetooth. SMS (short message service) is a text messaging service component of most telephone, internet, and mobile-device systems - and by this very definition is not a direct connected to a laptop with no SIM card. This means I cannot initiate a text message to send outbound.

    Unfortunately for Canadians - KoodoMobile, Rogers wireless, Telus mobility and Wind mobile none of these carriers will forward Txt messages to iCloud iMessage devices.
  4. MessieKake macrumors newbie


    Sep 16, 2016
    This has worked great for me from my iPad or Mac when starting a new conversation or replying to non iMessage enabled numbers.

    What drives me crazy till this day is not having the option to send an iMessage as a SMS permanently available for people that do have iPhones and other iMessage enabled device.

    Here's a detailed example:

    My mom has an iPhone and an iPad. She leaves her iPad at home connected to her wifi, but on her iPhone she doesn't have a data service, so no iMessage when she leaves home.

    So when she's out and sends me an SMS, in order to reply with an SMS I have about a second to press and hold my sent reply (which appears automatically blue) and select "send as text message"; because after a sec or less the message is automatically sent as an iMessage to her iPad and the option for the SMS is no longer available.

    If successful any other message is sent with a green bubble (SMS), but if the first message is sent as an iMessage to the iPad then the option to "send as a text message" is no longer available. Leaving me no way to send her an SMS.

    The iMessage service checks for any device with an internet connection and if an iMessage is delivered successfully it rules out the SMS option. I've tested this and in fact when I turn her iPad's wifi off, my mom's chat in my iPhone automatically becomes green as there are no devices online. It's a nice feature but far from perfect.

    This has been an issue for me for years and I know it isn't a major concern cause almost everybody has data on their phones today, but nevertheless an inconvenience for those minorities that don't. Most will just say to get her data, or just turn off my data to send her an SMS, but you can't deny that there's a problem with the way the service works in this precise context.
  5. diego macrumors regular


    Dec 21, 2003
    Canada & Mexico
    Works perfectly well for me with Koodo.
  6. DeepIn2U macrumors 603


    May 30, 2002
    Toronto, Ontario, Canada
    So if I send you a text message it’ll show up on your Mac?

    Again Text not iMessage starting a text due to no data coverage for me/you on an iOS device?
  7. thewhitehart macrumors 6502a


    Jul 9, 2005
    The town without George Bailey
    I have an unusual issue. I have Messages in iCloud turned on. I forward SMSs from my iPhone to two devices, an iPad and Mac. When I send an SMS from my iPhone, iPad, or Mac to a contact, the message is threaded by the contact's name as it appears in my contacts on all devices. When the contact replies, the reply is placed in the same thread on the iPhone. However, on the iPad and Mac, a new thread appears under the contact's phone number. This creates a problem with Messages in iCloud wherein I delete the thread on the iPhone under the contact's name, but on the iPad and Mac, the threads under the contact's phone number remains.

    The region for iMessage is set to the same country as that of the contact. All of the numbers in my contacts are in international format.

    Does anyone know how to fix this problem?
  8. RUQRU macrumors regular


    Apr 14, 2011
    Mac Addict!
    Since upgrading to the iPhone Xs MAX I can SEND SMS from my iMac but even though they are delivered I get an error message on Messages on the Mac saying "Your message could not be sent."

    I get a reply back on my iPhone but not on the Mac. So the message was sent meaning the Mac and iPhone are set up properly. I verified this with a screen sharing session with an Apple Tech Support (level 1) agent.

    We went through all kinds of trouble shooting. Logging in and out of my Apple ID, etc. He said he would send it to a higher level support person.

    NOTE: I CAN send and receive iMessages from my Mac. The problem is with SMS only.

Share This Page

7 August 13, 2018