How to setup Mac-Mini as a wireless router?

Discussion in 'Mac mini' started by Midgetinabikini, Dec 1, 2007.

  1. Midgetinabikini macrumors regular

    Aug 1, 2006
    My mac-mini (2.0 C2D), 10.5.1,
    He's connected to my cable modem with cat7 cable. i want to use the mini as a wireless router for my macbook and iphone.
    i setup a wireless networked and shared the ethernet connection, both the iphone and mbp getting ip address but i cant surf, or connect to ichat etc.

    I will appreciate any help.

  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Hmm... sounds like you're doing the right thing--sharing from the wired connection to the wireless one, and if they're getting IP addresses it sounds like it's working.

    The only thing I can think of off hand that would make you unable to actually do anything with the connection would be the Mini's firewall. Try turning the firewall off first (it's in the Security pref pane now). If that doesn't help, not sure what else to try.

    I haven't tried sharing with Leopard yet, but exactly what you're trying to do definitely worked under 10.4.
  3. kermit4161 macrumors regular

    Dec 18, 2006
    Try going into the Systems Prefs>Sharing pane. Click on the Internet Sharing box. Then select Airport (it doesn't show on mine, but should on yours since you set it up to act as a wireless share). That should allow your other devices to reach the Internet.

    I *think* the Firewall settings are just blocking incoming access... not outgoing (could very well be wrong).
  4. Midgetinabikini thread starter macrumors regular

    Aug 1, 2006
    After few days of testing and still nothing. The Mini's Airport is working and i can see and connect to the network i created, getting valid IP address too.

    But after few seconds, i cant surf or receive any data.

    Even more, i cant setup any FTP or HTTP access to the Mac-Mini, all ports are open, are sharing setting are correct. the only thing i can do, is to share the Mac-Mini in my internal network.

    never had those problems with Tiger...I'm sorry for upgrading :-(
  5. Sherman Homan macrumors 6502

    Oct 27, 2006
    Sounds like a DNS problem. Type in a raw IP address:
    See if that takes you Apple's home page. If it does, then you are missing a DNS entry somewhere.
  6. Midgetinabikini thread starter macrumors regular

    Aug 1, 2006
    no, nothing.
  7. chapito macrumors newbie

    Jan 31, 2008
    mini - sharing internet connection

    I just set my mini up for the same
    System Pref -> Sharing-> Internet sharing.

    in internet sharing allow Ethernet to share to Airport
    (in leopard select: airport options)

    select: network name
    select: channel (auto is good if there isnt alot of other networks around)
    enable: encription
    enter: password (be sure to use "letters" go with at least 5 characters)
    select: WEP 40 bit

    Your mini should now "transmit" a wireless network out to your other computers.

    Now on the laptop side: select the "new network" it will ask for WEP password
    enter: password
    select: remember in key chain.

    You should be good to go.
    The only problem I've faced is the fact that when the mini is asleep or off there is obviously no wireless network available. So you'll need to adjust the mini energy settings appropriately.

    (I could use some suggestions about leaving the mini on all of the time.:confused: Im mostly worried about security over WAN.)

    Hope this helps and its not just a re-hash of what you've done.:D
    Good Luck

Share This Page