How to setup PM G5 as a server?

Discussion in 'PowerPC Macs' started by CYB3RBYTE, Feb 23, 2015.

  1. CYB3RBYTE macrumors regular

    CYB3RBYTE

    Joined:
    Sep 2, 2014
    Location:
    Midwest
    #1
    Hello all!

    I have a 2.0 DP 2004 PowerMac G5, which I would like to use as a file server. I live at two houses currently (curse you parental divorce), so being able to access this server from either house would be a god send for my photography work. I have read up on how to do this but all the articles I find are always vague about certain aspects of the setup. Can anyone help me out? Thanks!
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    What aspect are you unclear on? Seems pretty strait forward to me, you enable file sharing in System Preferences > Sharing, forward the afp port (548) of that machine's IP address on your router, and once at the other house connect to your internet IP in Finder (Go > Connect to Server) and enter your login credentials.
     
  3. poiihy, Feb 23, 2015
    Last edited: Feb 23, 2015

    poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #3
    Yup that is all there is too it.
    1. Turn on file sharing
    2. Set up port forwarding
    3. Leave the computer running and enjoy the server

    If you don't know how to port forward, provide us the make and model of your router and I/we will give you instructions; or you can look it up yourself.

    Usually to do it is this:
    1. Access your routers settings, via either the config application if it has one (like Cisco Connect), or the web config in the web browser. For the web config you type in the IP address of the router, usually 192.168.1.1 or something like that.
    2. Go to the port forward settings
    3. Add a forward for the afp port 548 to your G5's IP address (you can find your IP address in the Network tab in System Preferences). Lets say the IP of your G5 is 192.168.1.123. It would be something like this: "Internal Port: 548, External port: 548, Protocol: Both, IP Address: 192.168.1.123, Enabled: ✓" I don't know what protocol afp uses so just set the protocol to Both.
    4. Save it
     
  4. CYB3RBYTE thread starter macrumors regular

    CYB3RBYTE

    Joined:
    Sep 2, 2014
    Location:
    Midwest
    #4
    I use a Apple Airport Extreme 5th Generation for my wireless router. Port forwarding in Airport Utility was a little confusing for me. That's the main problem I'm having with the setup...
     
  5. poiihy, Feb 23, 2015
    Last edited: Feb 23, 2015

    poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #5
    I found this pdf
    http://www.rainmachine.com/support/...ing-Apple-AirPortExtreme-Router-for-HTTPS.pdf
    It talks about port forwarding something else but you can follow the same thing for your system.

    First set up DHCP reservation so the IP of your G5 doesn't randomly change.
    Enter the MAC and IPv4 addresses of the G5.

    Then set up port settings.
    The public UDP, TCP, private UDP, TCP will all be the same port, afp port (548). And IP address of your G5.
    Edit: it looks like afp only uses TCP so you can leave the public/private UDP ports blank.

    look at this
    https://discussions.apple.com/thread/3006955?tstart=0

    -------------------------------------------------

    Here is a much more useful method; try this:
    http://www.tech-otaku.com/networking/establishing-ssh-tunnel-remotely-access-mac-afp-vnc/
    With this method you use an SSH tunnel instead which is more secure.
     
  6. CYB3RBYTE thread starter macrumors regular

    CYB3RBYTE

    Joined:
    Sep 2, 2014
    Location:
    Midwest
    #6
    Okay, I set everything up last night according to the RainMaker article, but it still isn't seeing it. I will have to check out the other article you posted when I get home.
     
  7. CYB3RBYTE thread starter macrumors regular

    CYB3RBYTE

    Joined:
    Sep 2, 2014
    Location:
    Midwest
    #7
    Just an update - Sorry for bringing a thread back from the dead here. :p

    I have tried again and again with this method for using the G5 or even my iMac as a server. But for some unknown reason, (probably not being hooked into Ethernet and using Wifi) I can't seem to connect to it.

    NOW HERE IS THE REALLY WEIRD PART...

    Since I have an Airport Extreme Gen. 7 Router, I figured I could just hook up my 500GB WD Passport for Mac to it and enable Sharing Over WAN to access it that way and more directly... NOPE. When I am not at my house and using a different Wifi point, the Airport Extreme comes up in my Finder bar under the shared tab, but it fails to connect to the router.

    Now, I have internet through Time Warner Cable in my area, with good speeds and reliability. However I wonder if TWC blocks connections like VPNs and such? Not going out but perhaps those connections coming in??

    Please help me. This is so frustrating. Honestly I have been using Dropbox and everytime I do it just reminds me that I couldn't figure this out. :mad:
     
  8. tevion5 macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #8
    Really? I have a large enough airport network here, and I love the fact that I can manage ports from even my iPhone. Very convinient when playing with servers from Web to FTP to Minecraft, to AFP etc.
     
  9. CYB3RBYTE thread starter macrumors regular

    CYB3RBYTE

    Joined:
    Sep 2, 2014
    Location:
    Midwest
    #9
    Most of the time, yes, I LOVE MY ROUTER!!

    Just the fact that it works out of the box and has worked for 2 plus years is great. I remember my old Linksys router would randomly "Nope" every couple days (It was a wireless g router, but seriously c'mon Cisco).

    That being said I'm still having problems with the remote access. :p
     
  10. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #10
    That really sucks.

    My own personal network is using a DOCSIS 3.0 Cisco cable modem that is connected to a 2004 vintage D-Link DI-604 wired router. That router was a refurb and it's been on 24/7 since 2005.

    Compared to modern routers it's firmware is ancient, but it allows port forwarding and lots of other stuff that modern routers do. I have a wireless router as well, a Linksys WRT-54GL but it's used only as a wireless access point for my wireless devices. If I had to rely on it for port forwarding I'd probably have smashed it by now as it was confusing enough to figure out how to get it into a non-router mode. Allowing wireless devices by MAC address on the thing was even more of a nightmare to figure out.

    The NetGear router at work was also easy and between my home network and the work network I have the drives on my MP at work mounted on the desktop of my Quicksilver at home and the drives on my Quicksilver at home mounted on the desktop of the MP at work.

    Further, my router at home is set to allow VNC so I can see the desktop of my Quicksilver (all six displays) from anywhere.

    It's criminal that an Apple device is that hard to figure out.
     
  11. CYB3RBYTE thread starter macrumors regular

    CYB3RBYTE

    Joined:
    Sep 2, 2014
    Location:
    Midwest
    #11
    You got that right. Like I said, I am the computer jock of the household (well technically both my households as they both have Airport Extremes, heh), and the Airport routers are a breeze to setup, and fairly fast. If anything is screwing with me, I'm betting you it's my bastard ISP, which is Time Warner Cable. They don't allow for VPN connections, which is why I'm guess BTMM and Airport Extreme Disk Sharing over WAN is not happening for me.

    *Evil Scientist Voice*

    CURSE YOU TIME WARNER CABLE!!!!:mad:
     
  12. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #12

    When using "Share Disks Over WAN" you must use the "Connect to Server" menu in Finder. Keep in mind that the AirPort must not be behind another router or a modem that handles DHCP. You could also look into "Back to my Mac".
     

Share This Page