Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

How to share external HDD over Mac network?

ascender

macrumors 68040
Original poster
Dec 8, 2005
3,624
1,534
Sorry, I know this question has been asked before, but I've done a search and tried some of the solutions, but am getting nowhere. Also some of the threads seem to go off on a tangent.

Anyway, I have the following setup:

- All machines running OS X

- iMac with an External HDD connected via FW800

- External HDD is called "MyBook"

I would like to be able to access this External HDD from other machines on my network, for file copying and maybe streaming audio/video.

How do I go about setting this up?

Thanks,


Mike.
 

BiikeMike

macrumors 65816
Sep 17, 2005
1,019
1
It should be fairly easy. Go to the computer that the drive is connected to, highlight the drive, and go to get info (apple+I)

Expand the details, and put all the access to read and write. Hit apply to enclosed items.

Then go to whatever mac you want to connect, be on the desktop, and go to the "go" menu.

select "network" and find the name of the computer the drive is connected to and hit "connect". you should then be able to find your external drive, it mount on your desktop and be in business
 
Comment

MacBlackBook22

macrumors 6502
Jul 1, 2007
407
36
Canada
I am interested in this too. I have a my book hard drive connected to my one of my macbooks. I would like to connect to it with my other macbook I just tried using the instructions but it didn't work. the external my book hard drive does not show up under network only the computer
 
Comment

ascender

macrumors 68040
Original poster
Dec 8, 2005
3,624
1,534
When I connect to the computer with the HDD on it remotely, the drive isn't listed as a valid share. I've checked and the permissions are r/w already, so its not that.

Actually, on my Powerbook, I can't actually browse the network, I have to go via "Connect to Server" for some reason.
 
Comment

BiikeMike

macrumors 65816
Sep 17, 2005
1,019
1
Go to Control Panels:Sharing and make sure that "Personal File Sharing" is checked.....
 
Comment

BiikeMike

macrumors 65816
Sep 17, 2005
1,019
1
We'll have to wait for someone who knows more than I to chime in, That is what I have done on my computers and it works fine...
 
Comment

ascender

macrumors 68040
Original poster
Dec 8, 2005
3,624
1,534
Oh, I'm assuming this is all possible with just TCP/IP? I don't need to enable AppleTalk or anything do I?
 
Comment

benlee

macrumors 65816
Mar 4, 2007
1,243
1
enabling apple talk would probably be a good way to do it, thats how i share files across computers.
 
Comment

jschuur

macrumors newbie
Jun 26, 2007
4
0
FWIW, I got here on a forum search with the exact same issue.

I can share other folders (home and the root boot drive) just fine from my iMac (where the MyBook external drive is hooked up to) to my Macbook, but a mounted drive won't show up.

I know you have to be an administrator to view mounted drives, but both the iMac account I'm using as credentials to log into from the Macbook and even the local account on the Macbook that I'm doing the connecting from are admins.

The file system type is the default FAT32 that it came pre-formatted as, and I understand that doesn't support the full array of permission options (Get Info -> Ownership & Permissions e.g. only has a single, non-editable 'You can read and write' entry). Could that be related?

I'm probably going to try and reformat to HFS+ journaled, but that will require copying everything off the drive beforehand, so I'm taking a trip back to the Apple store first.

Will post my findings here later...
 
Comment

jschuur

macrumors newbie
Jun 26, 2007
4
0
Solution: Don't use FAT32 file system

As I suspected. If you reformat the drive with a Mac file system (use Disk Utility, select the drive, pick 'Erase'), it'll appear among the list of mountable volumes.

I suspect that the Mac file systems offer a greater range of permissions that it uses to tell if someone else should be able to mount it. I used 'Mac OS Extended (Journaled)', which apparently also allows for files > 4 gigs.
 
Comment

dysamoria

macrumors 6502a
Dec 8, 2011
965
528
Solution: Don't use FAT32 file system

As I suspected. If you reformat the drive with a Mac file system (use Disk Utility, select the drive, pick 'Erase'), it'll appear among the list of mountable volumes.

I suspect that the Mac file systems offer a greater range of permissions that it uses to tell if someone else should be able to mount it. I used 'Mac OS Extended (Journaled)', which apparently also allows for files > 4 gigs.

i know it's ten+ years later, but... Was there no other solution to this? i want to share an external (firewire) NTFS (read-only, i know) drive and there seems to be no way to do this.
 
Comment

dysamoria

macrumors 6502a
Dec 8, 2011
965
528
Sorry to resurrect an old thread. I came here facing the same problem as OP, except I'm sharing from a mac to a mac. So it's definitely not the case that both windows and os x make it easy to share to the same OS... only windows does. and, more specifically, windows makes it easy to share files/folders with 90% of the computer-using world. Macs make it easy - sometimes - to share with the other 5-8% of the world that also uses macs, and it's debatable as to how easy it really is because I can't see my external drive when I enable personal file sharing and then log in with an admin account on that machine.

Try exFAT, if possible.

i don't want to convert the drive. It's full of data. If i was willing to reformat it, i probably wouldn't even have this issue.
 
Comment

dysamoria

macrumors 6502a
Dec 8, 2011
965
528
Ahhhhhhhhh ok I had a feeling. Maybe try Paragon NTFS or Tuxera NTFS and enable SMB file sharing instead of AFP?

i do have SMB active. i'm not looking to install 3rd-party NTFS drivers. i'm just wanting to know if NTFS is the reason i cannot share the drive. If so, it makes me suspect sharing would still not work with a 3rd-party NTFS driver.
 
Comment

cruisin

macrumors 6502a
Apr 1, 2014
962
223
Canada
Apparently Apple replaced SMB (samba) in Lion with a custom version that doesn't support NTFS (mainly due to Mac not having a good NTFS driver, only a read-only version). You need to add the original samba back (and you need to install MacPorts and Xcode to make it happen).

Plus you need 3rd-party NTFS drivers, as NTFS is read-only and you will need to write new permissions to the drive to share it (and it is read-only by default under Mac).

So NTFS is the reason, from a certain point of view.

See: https://apple.stackexchange.com/questions/24051/how-do-i-share-ntfs-folder-from-osx-lion-to-window-7
 
  • Like
Reactions: dysamoria and teezy
Comment

dysamoria

macrumors 6502a
Dec 8, 2011
965
528
Apparently Apple replaced SMB (samba) in Lion with a custom version that doesn't support NTFS (mainly due to Mac not having a good NTFS driver, only a read-only version). You need to add the original samba back (and you need to install MacPorts and Xcode to make it happen).

Plus you need 3rd-party NTFS drivers, as NTFS is read-only and you will need to write new permissions to the drive to share it (and it is read-only by default under Mac).

So NTFS is the reason, from a certain point of view.

See: https://apple.stackexchange.com/questions/24051/how-do-i-share-ntfs-folder-from-osx-lion-to-window-7

Interesting. This is not something i'm going to try to solve any more, because it's too much messing about with the system for my taste. I appreciate your reply, as this info is much better than what i had before. Thank you!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.