How to share my ethernet connection via WiFi reliably?

Discussion in 'OS X Mavericks (10.9)' started by mrjayviper, Jun 27, 2014.

  1. mrjayviper macrumors regular

    Joined:
    Jul 17, 2012
    #1
    I have setup my macbook running latest Mavericks to be a WiFi hotspot but it is very very flaky. just I need to turn it off/on multiple times to get it working. and now it's not working at all. Probably needs a restart.

    Any tips/suggestions to get it to work stably?

    thanks :)
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    Just switch on Internet Sharing in the System Preferences pane, wait for about half a minute and when the Wi-fi icon in the menu bar turns gray, it's stable.

    You just have to be patient to wait for the wi-fi icon to turn gray :)
     
  3. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #3
    Dedicated hardware, is my recommendation.
    E.g. Airport Express.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Is your MB always connected via ethernet...or...are there times when you use wifi for its connection?
     
  5. mrjayviper thread starter macrumors regular

    Joined:
    Jul 17, 2012
    #5
    yes it is connected to ethernet using the Thunderbolt port (via the ethernet adapter).

    ----------

    can't. I'm at work.

    ----------

    not for me. :/

    I'm using a mid-2013 MBPr right now. But I've had the problem even on my mid-2010 MBP running mountain lion at the time.

    just not stable
     
  6. Vanilla Face, Jun 27, 2014
    Last edited by a moderator: Jul 2, 2014

    Vanilla Face macrumors 6502

    Joined:
    Aug 11, 2013
    #6
    You went to system preferences, sharing, clicked on internet sharing, from the drop down list labeled "Share your connection from:" you selected 'Ethernet', and then clicked the check box under the "To computers using:" labeled 'WiFi', and then finally checked the internet sharing check box on the left?
     
  7. mrjayviper thread starter macrumors regular

    Joined:
    Jul 17, 2012
    #7
    yes to all as I can connect to it.

    just it's not stable. my devices loses "sight" of the WiFi hotspot. My devices doesn't have the same problem seeing my airport extreme but then again, that's a dedicated device.

    I'm just wanting a WiFi hotspot while at work.

    The work does provide free WiFi but I need to login and it kicks you out after a certain number of minutes requiring me to relogin.

    thanks again :)
     
  8. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #8
    Make sure any traces of wifi networks to which you have been connected are deleted from the MacBook.

    Also, is your bluetooth turned off?

    There could be possible interference from any other wifi signals in the area or even other electronic devices.
     
  9. mrjayviper thread starter macrumors regular

    Joined:
    Jul 17, 2012
    #9
    ummmm I'm using BT for my mouse. I'll try the suggestion though.

    and it's quite possible it's indeed possible interference from the work WiFi network! :/
     

Share This Page