How to start a iMessage

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AznTakumi, Apr 12, 2013.

  1. AznTakumi macrumors regular

    Joined:
    Apr 4, 2011
    #1
    I have been having a problem starting a iMessage with people who I know for sure have a iPhone and iMessage installed. I could stil send iMessages to some people but I can't to others(by others I mean people with iPhones still). I did jailbreak and on a older firmware so I am wondering if this is causing the problem or is something else going on?
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    A few things need to happen. If you have them as a contact, their phone number needs to be listed as "iPhone" and not "Mobile." Secondly, the recipient needs to be logged in to iCloud and if they are set to receive iMessages from contacts only you have to be a contact in their Address Book.

    Lastly, if there's an outage in their area you won't be able to iMessage them. I had that happen the other day with the iMessage outage. One friend out of three I know can get iMessaged weren't in blue when I checked. It was standard SMS. Once Apple cleared the outage they reappeared in blue.
     
  3. darky90 macrumors member

    Joined:
    Oct 30, 2012
    #3
    If the other person doesn't have the iMessage option turned on in their settings, they won't be receiving your imsg. I'm not sure if it matters if the other peoples contact information has to be under iPhone for imsg to work. All my contacts were automatically placed under mobile when I imported my list and it still works.
     
  4. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #4
    Maybe it's a local thing then, IDK. I have a friend in Australia and a friend in the UK. Until I designated them as iPhone in my Contacts I was sending SMS and not iMessage. The same for my sister who lives three states away from me.

    Perhaps it may be to the fact that my iMessage setting is set to Contacts only and not everyone?
     

Share This Page