How to stop Apple Music from downloading music onto my iPhone

Discussion in 'iOS 10' started by s2mike, Aug 23, 2016.

  1. s2mike macrumors 6502

    Joined:
    Sep 14, 2015
    #1
    For some reason, streaming songs from Apple Music seems to result in a couple of those songs being downloaded to your device.

    Today I listened to a few albums on Apple Music and now I see that two of those tracks are now downloaded onto my phone.

    Any idea how to prevent this from happening? I just want to stream the music but I hate having music downloaded onto my device.

    Thanks in advance.
     
  2. Marshall73 macrumors 65816

    Marshall73

    Joined:
    Apr 20, 2015
    #2
    My understanding is that Apple Music works as follows. When playing any songs they are cached on the phone and are removed from the cache after a period of time unless you specifically download them. I don't think there is a way to stop them caching, only a way to clear the cache under the usage settings in the iPhone settings.
     
  3. s2mike thread starter macrumors 6502

    Joined:
    Sep 14, 2015
    #3
    I gotcha. Thanks for the reply.

    I have tons of available space, so it's no biggie...just sets off my OCD.
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    You generally do not have to worry about caching. The phone cleans up old caches automatically as the device runs out of space. It lends the disk space until it is needed elsewhere. Apple Music uses this quite a bit, because it is cheaper and more efficient to store it.
     
  5. s2mike thread starter macrumors 6502

    Joined:
    Sep 14, 2015
    #5
    I guess I just find it weird that I listened to several full albums, front to back, and yet for some reason the device only "downloaded" 2-3 songs. Odd.
     
  6. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #6
    Make sure Automatic Downloads is turned off in the Music settings (see screenshot) With it on it will download music you add to your library for offline listening.

    Settings > Music > Automatic Downloads - Toggle Off
     

    Attached Files:

  7. StonewallBrown macrumors regular

    StonewallBrown

    Joined:
    Mar 25, 2013
    #7
    I have the same kinda issue. I assume it's just a bug. I have auto downloads turned off. Yet everything I add to my library, no matter the device it's added on, it downloads on my iPhone. I don't have that issue on my iPad.
     
  8. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #8
    Which Automatic Downloads is it you have turned off? Because in iOS 10 the Music app has it own new option for it and is not the same older setting found in iTunes & App Store settings. A lot of people aren't noticing the new option in Settings > Music > Automatic Downloads and are looking at the older setting in Settings > iTunes & App Store > Automatic Downloads and wonder why music still downloads.
     
  9. s2mike thread starter macrumors 6502

    Joined:
    Sep 14, 2015
    #9
    Yep, I've got that toggled off and it still downloads a couple random tracks. I think it's a bug.
     
  10. StonewallBrown macrumors regular

    StonewallBrown

    Joined:
    Mar 25, 2013
    #10
    Good to point that out. I had/have both off I've even tried toggling it on and off. It's not a big deal for me. I have the space. The optimize storage feature works, so I have that on as a safety valve. I'm sure it'll be fixed. If I still have the problem when the GM comes out, I'll just wipe it and restore it.
     
  11. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #11
    I've noticed the same thing happening with random music that I haven't listened to in forever. Not a lot, but it does happen. Must be a bug.
     

Share This Page