How to Stop Firefox 4 to launch at startup on Mac OS X 10.6?? PLEASE HELP...

Discussion in 'macOS' started by liuskusuma, Apr 4, 2011.

  1. liuskusuma, Apr 4, 2011
    Last edited: Apr 5, 2011

    liuskusuma macrumors newbie

    Joined:
    Apr 4, 2011
    #1
    Hi,

    Firefox 4 always launch at my startup, how to stop this? I use current gen Macbook Pro 15".
    I've search google and this forum but couldn't find a solution that work.
    Anyway, here's what I've done so far:

    1. I've checked that Firefox is not in my System Preference/Login/Login Items.

    2. I've check that when I right click Firefox on my Dock, the option Open at Login is Un-Ticked.

    3. I've checked the item on my MacintochHD/Library/StartupItem and
    Firefox is not there.

    4. I've also checked that there are no option in the Firefox preference that has an option to turn this on or off (or am I missing one???).

    5. Tried to uninstall using AppZapper/AppCleaner, restart the comp and re-installing Firefox again, it still launch on startup. :(

    What should I do to stop firefox from launching on startup?? Please help :(
     
  2. BioBjoern macrumors newbie

    BioBjoern

    Joined:
    Apr 5, 2011
    Location:
    Denmark
    #2
    But not only Firefox 4...

    Hi, I am having the same problem with Cisco AnyConnect, also on Mac OS X 10.6. Been browsing the web for hours to find a solution...
     
  3. Let's Sekuhara! macrumors 6502

    Let's Sekuhara!

    Joined:
    Jun 30, 2008
    Location:
    日本
    #3
    That's f'd. You got me beat. :confused:

    Firefox 4 has been good to me. Love the sync feature.

    Good luck.
     
  4. liuskusuma thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #4
    Any Luck?
     
  5. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #5
    Is FF 4 your default browser? If so, make it Safari and see if FF 4 or Safari start up next time you reboot or log out and back in again.
     
  6. liuskusuma thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #6
    I've just tried to change my default browser to safari but firefox still opens on startup :(.

    *sigh* This is annoying.
     
  7. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #7
    Launch Services might firing it off. Download a copy of Lingon, and you will be able to see all services managed by launchd. One of them might be triggering FireFox to load on login.
     
  8. liuskusuma thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #8
    Thanks, I've just installed lingon, what should I do or look out for?
     
  9. liuskusuma thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #9
    Sorry I'm not too good with this kind of thing. But nothing is related to firefox that I know of in Lingon.
     
  10. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #10
    I'm out of direct ideas. One thing you can do is create a separate user account, then log in as that user and verify that ff isn't coming up for that user. Log out of the test account and back in to your account and see if ff comes up. If it comes up every time you log in rather than only when you reboot that could provide a clue.
     
  11. liuskusuma thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #11
    Awesome, I found the culprit, It was bitdefender :eek:, Thank you for all the help guys, I really appreciate all the suggestions :D
     
  12. ivnj macrumors 65816

    Joined:
    Dec 8, 2006
    #12
    Weird it has been good to me also.
     
  13. BioBjoern macrumors newbie

    BioBjoern

    Joined:
    Apr 5, 2011
    Location:
    Denmark
    #13
    Still trying

    No, haven't had any luck. By using Lingon, I can deny start up on logon. But as a result, AnyConnect won't connect. I have contacted Cisco systems for support, but am still waiting for an answer. :eek:
     
  14. ohsster macrumors newbie

    Joined:
    May 24, 2011
    Location:
    Kalamazoo, MI
    #14
    STOP launch

    Double Click on desktop icon, stop launch is there!
     
  15. ammemma macrumors newbie

    Joined:
    Sep 19, 2011
    #15
    Printer

    I think I may have a solution, however it might have just been luck;

    I was suffering from the same affliction, however it was with OS X 10.7. By reading other forums I discovered that someone solved this problem by deleting a "file" they'd made for their printer... And my problem only started when I plugged my printer in and then booted up....

    So, I removed the printer cord from the computer, reset, and lo and behold Firefox (version 4) did not start up!!

    Free and clear!
     
  16. pmachado macrumors newbie

    Joined:
    Oct 23, 2011
    #16
    A possible solution

    Guys, I had Firefox and Quick Time launching at startup and that was really annoying. I´ve done something which worked for me:

    1) Go to System Preferences
    2) Accounts (or login)
    3) Login items

    Firefox and Quick Time appeared here , although not checked - I just highlighted them and deleted!

    Now they launch only when I ask!

    Good Luck!
     

Share This Page