How to stop HTML5 autoplay in Safari

Discussion in 'Mac Apps and Mac App Store' started by BobbyCat, Jan 23, 2012.

  1. BobbyCat macrumors regular

    BobbyCat

    Joined:
    Jul 22, 2002
    Location:
    Beyond
    #1
    If somebody can tell me how to prevent Safari from autoplaying all HTML5 videos as soon as a webpage is opened, I'd be really grateful.
    Very irritating indeed.
    At least with ClickToFlash, the user can decide which Flash videos to play and when. Surely there must be a similar feature with HTML5?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    If it is YouTube you have the problems with, unsubscribe from the HTML5 beta at www.youtube.com/html5 .

    Do you maybe have some extension installed, that forces HTML5?
     
  3. Cmd-the-World macrumors regular

    Joined:
    Apr 7, 2010
    #3
    Are you using this version of click to flash: http://hoyois.github.com/safariextensions/clicktoplugin/

    The default behaviour is to auto play all HTML 5 videos.

    To change the settings:

    1) Right click and click on the click to flash preferences
    2) Select the media player tab
    3) Select the behaviour how you want the plugin to react upon identifying HTML 5 videos by changing the Initial behaviour settings.

    Hope this helps.
     
  4. BobbyCat thread starter macrumors regular

    BobbyCat

    Joined:
    Jul 22, 2002
    Location:
    Beyond
    #4
    simsaladimbamba & Cmd-the-World

    Problem solved! I recently updated ClickToFlash and changed the settings inadvertently. I had autoplay enabled and couldn't figure out what triggered that behavior.
    1.000 thanks :)
     
  5. Squishy Tia macrumors regular

    Squishy Tia

    Joined:
    Nov 17, 2010
    #5
    Normally I don't necro threads, but because this thread comes up first in the Google searches for disabling HTML5 in Safari, I thought I'd put in this information too since it is relevant.

    If you have the YouTube 5 Safari extension installed, you need to also uncheck the "autoplay YouTube videos on YouTube.com?" option, as this also controls all HTML5 video in Safari. I found that until I disabled that setting HTML5 video on Bleacherreport.com (CNN's pathetic sports news site...ugh) and others would still autoplay.

    So just a heads up, if you have this extension in addition to ClickToFlash, make sure to uncheck that preference checkbox.
     

Share This Page