iPhone How to stop iCloud call forward between iphone and Macbook

Discussion in 'iOS 8' started by truelies, Oct 21, 2014.

  1. truelies macrumors regular

    Joined:
    Oct 14, 2011
    #1
    I have an iphone and a Macbook, after update to ios 8.1 today I didn't answer my iphone, then this call went to my Macbook. I turned Hangoff on my iphone, but it still works this way. How can I turn this share thing off?
     
  2. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #2

    it's actually all a mess. Handoff only applies to apps.
    For calls the setting is in Settings -> Facetime -> Iphone Mobile calls.
    For sms, the settings is in Settings -> Messages -> Text Messge forwarding
     
  3. MichaelCD macrumors member

    Joined:
    Oct 20, 2014
    #3
    in your iphone go to setting-> facetime and turn off iphone Cellular Calls.
    I'm not sure if that will stop it but give it a try
     
  4. truelies thread starter macrumors regular

    Joined:
    Oct 14, 2011
    #4
    The iphone Cellular Calls was turned off, but it still doing this forward. Anyway to stop this?
     
  5. LosLoco, Oct 21, 2014
    Last edited: Oct 21, 2014

    LosLoco macrumors member

    Joined:
    Nov 28, 2012
    #5
    I don't even understand the "iPhone Cellular Calls"-option under Facetime-settings on my iPhone.

    It's turned off, and when I try to turn it on, I get a message saying "Facetime and iCloud needs to be logged in to the same iCloud-account" (I'm not 100% on the wording, as my iOS is in my native language, Danish).

    The odd thing is, both Facetime and iCloud ARE logged in to the same iCloud-account! But I still can't enable this setting.. I've tried rebooting, logging out and back in, hard reset (or whatever home+sleep-button for 10 secs is called)

    Nothing lets me turn the darned thing on! :(
     
  6. truelies thread starter macrumors regular

    Joined:
    Oct 14, 2011
    #6
    This is really mess,don't need forward at all
     
  7. Bamff macrumors regular

    Joined:
    May 6, 2013
    #7
    Sign out of your Apple ID in FaceTime and it will only rout it to your number-iPhone.
     
  8. truelies thread starter macrumors regular

    Joined:
    Oct 14, 2011
    #8

    But now people can't facetime you through email.
     
  9. haruhiko macrumors 601

    haruhiko

    Joined:
    Sep 29, 2009
    #9
    To stop your MacBook from receive calls from your iPhone you need to go to the FaceTime app's preferences setting on your MacBook to turn off iPhone calls.
     
  10. shotts56 macrumors 6502

    Joined:
    Sep 23, 2008
    Location:
    Scotland
    #10
    That's what worked for me to fix this problem. Although why on earth the option to turn off iphone cellular calls is hidden under settings -> FaceTime, I have no idea.
     

Share This Page