How to stop iPhone correcting UK to I'm

Discussion in 'iPhone' started by joe8232, Oct 1, 2008.

  1. joe8232 macrumors regular

    Joined:
    Jun 21, 2005
    #1
    Does anyone else have the problem where their iPhone keeps correcting uk to i'm - this is particularly annoying when typing web addresses. Is there a way to add words to a list that will not get auto-corrected? Also get it with st (I live in St. Andrews) which it corrects to at. Very annoying.
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    I think that if you refuse a specific auto-correction about 5 times, by pressing the bubble each time before accepting it, it will stop doing it after that.
     
  3. mickbab macrumors 65816

    mickbab

    Joined:
    Sep 13, 2008
    Location:
    Sydney, Australia
    #3
    the iphone has a "smart" dictionary so if you keep typing words and x-ing the recommendations it will learn your words.
     
  4. NekoFever macrumors member

    Joined:
    Apr 29, 2005
    #4
    BTW, if you're typing 'uk' in URLs as part of '.co.uk', hold down on the '.com' button and it'll offer a shortcut to '.co.uk', assuming your keyboard is set to UK English. If you can't solve a problem, find a way around it ;)
     
  5. atiffarooq macrumors 6502

    atiffarooq

    Joined:
    May 27, 2006
    #5
    I didn't know this and I thought I had worked out all the little shortcuts. Thanks!
     
  6. ajnicho macrumors 6502a

    Joined:
    Sep 24, 2008
    #6
    I've typed .co.uk millions of times and clicked the x bubble but it continues to correct it to I'm.

    the .com button is not always present when typing in email addresses in forms etc.
     
  7. joe8232 thread starter macrumors regular

    Joined:
    Jun 21, 2005
    #7
    I agree that the .co.uk is quite handy but I also type .ac.uk quite a bit but sadly apple doesn't let you customize the shortcut options :(
     
  8. hollerz macrumors 6502a

    hollerz

    Joined:
    Sep 13, 2006
    Location:
    Durham, UK
    #8
    This annoys me too, I've been refusing the auto suggestion since the phone came out and it still hasn't stopped doing it!
     
  9. Shad0w59 macrumors member

    Joined:
    Jun 24, 2008
    #9
    Jailbreak plus the appropriate package can turn off auto correct.
     
  10. JAWWC macrumors regular

    Joined:
    Jun 1, 2008
    #10
    I have this problem. I don't want to turn off auto correct completely, I just wish this function people say was true, but it never seems to remember when I press the x.
     

Share This Page