How to stop receiving old gmail emails?

Discussion in 'iPhone' started by 2Sticky, Jun 20, 2009.

  1. 2Sticky macrumors regular

    Joined:
    Mar 4, 2005
    Location:
    UK
    #1
    Hey,

    I have set up my gmail account on my iPhone, however it keeps getting all my old emails, so it is set to just show 25, however I want it to just receive ones from now on, is it possible to delete emails and not have it so there are always the 25 latest emails on the phone?

    Hope that makes sense...
     
  2. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #2
    Check the IMAP box and you should be good to go. Because most POP emails require that you remove or delete emails in all active accounts; eg. iPhone, desktop at home and work.... (hope this helps)
     
  3. 2Sticky thread starter macrumors regular

    Joined:
    Mar 4, 2005
    Location:
    UK
    #3
    IMAP is enabled... :S

    Don't have this problem with Mail on my Mac so I'm a bit confused...
     
  4. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #4
    Is imap enabled on your phone and on your gmail account?



    I use pop as i don't want to sync my emails, i like to keep certain ones in different locations. But when i set up my new phone and when i updated to 3.0 on my old phone about 150 old messages loaded on my phone the first time i checked email. After that only new mail is received.
     
  5. 2Sticky thread starter macrumors regular

    Joined:
    Mar 4, 2005
    Location:
    UK
    #5
    Its all working fine, its just it still always makes it so it has the latest 25 emails on there, so if i delete them all, it just gets the next 25 which are in my gmail account, seeing as there about 5000 emails on there I don't really want to delete them all!
     

Share This Page