How to stop Safari auto reloading?

Discussion in 'macOS' started by kdum8, Sep 13, 2011.

  1. kdum8 macrumors 6502a

    kdum8

    Joined:
    Sep 8, 2006
    Location:
    Tokyo, Japan
    #1
    Very simple, but each time I switch back to another window in safari, it reloads the page. This is especially annoying if I've paused a video in the window. It never used to happen, perhaps one of the updates changed the browser's behaviour?

    Anyone know why this happens and any way to stop it? :confused:

    This is happening on OS 10.6.8 with Safari 5.1
     
  2. vmachiel macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #2
    I have a dutch system so I don't know the english option name but look under preferences and under tabs. The bottom one should be unchecked. Does this solve it? (had similar problem and i think this was the solution, although i'm not sure)
     
  3. kdum8 thread starter macrumors 6502a

    kdum8

    Joined:
    Sep 8, 2006
    Location:
    Tokyo, Japan
    #3
    Hi, thanks for your reply and for making a suggestion. I was beginning to think no one would see this thread!

    I had a look under tabs in preferences as you suggested but can't see anything that would affect it (see image)

    Also looked through all the other options but nothing there...:confused:

    Annoying browser keeps reloading pages though..
     

    Attached Files:

  4. vmachiel macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #4
    Weird, your options are different from mine, although i also have safari 5.1. Maybe the apple support forums can help you?
     
  5. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #5
    are you on Lion?, the above is from Snow Leopard which is slightly different

    Safari in 5.1 changed the way it works, it now has the additional process 'Safari Web Content' if this crashes, your Safari will look normal but will refresh tabs when you next go to them

    Have you tried disabling any extensions to see if it makes a difference

    **I am on the Lion version, which I think works the same as SL, but apologies if it doesn't
     
  6. kdum8 thread starter macrumors 6502a

    kdum8

    Joined:
    Sep 8, 2006
    Location:
    Tokyo, Japan
    #6
    It worked! Thanks. I don't seem to have any extensions installed in safari, but strangely selecting "disable all extensions" seemed to do the trick anyway. Browser back in operation. Thanks again! :D
     

Share This Page