Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

MacRumors

macrumors bot
Original poster
Apr 12, 2001
52,456
14,151



Most Apple Watch owners will recognize the "Now Playing" app - it automatically launches by default whenever you play audio through the Music or Podcasts app on your iPhone. A similar screen shows when you play audio through any third-party iPhone app that also has an Apple Watch extension, like Overcast, for example.

The Now Playing app provides quick access to playback controls on your wrist, as well as track options like Love/Dislike and Delete From Library. You can also turn the Crown on your Apple Watch to adjust volume, which is handy when you're listening on AirPods or other headphones that don't have built-in volume controls.

apple-watch-now-playing-screen-800x533.jpeg

You might not like the way the Now Playing app automatically appears when you play audio on your iPhone. If you just want to see your watch face when you raise your wrist during audio playback, you can turn off the default behavior by following the first set of steps below.

You can still make it easy to access the Now Playing app without it automatically taking over the screen whenever you play audio. One solution is to add the Now Playing app to your Apple Watch's Dock, accessed with a press of the Side button. Another option is to enable the Now Playing watch face complication. Click the links to find out how.

How to Disable Auto-Launch Audio Apps on Apple Watch

  1. Press the Crown on your Apple Watch to invoke the app launcher.
    Launch the Settings app.
    apple-watch-auto-launch-audio-apps-800x464.jpg

    Tap General.
    Tap Wake Screen.
    Toggle off Auto-Launch Audio Apps.
How to Disable Auto-Launch Audio Apps via iPhone

  1. Launch the Watch app on your iPhone.
    Tap General.
    auto-launch-audio-watch-app-800x491.jpg

    Scroll down and tap Wake Screen.
    Toggle off Auto-Launch Audio Apps.
How to Add 'Now Playing' to Your Apple Watch's Dock

  1. Launch the Watch app on your iPhone.
    Tap Dock.
    Tap Favorites in the Dock Ordering section if it isn't already selected.
    apple-watch-now-playing-add-to-dock-800x513.jpg

    Tap Edit in the upper right corner of the screen.
    Scroll down to the Do Not Include section and tap the plus (+) symbol next to Now Playing to add it to the list of docked apps. Alternatively, drag the app into the Favorites list via the three-line button at the far right of the entry. (Note you can also use these buttons to control the arrangement of apps in the Dock.)
    Tap Done in the upper right of the screen.
How to Enable the 'Now Playing' Complication
Before following these steps, make sure you're using a watch face that accepts text-based complications (Modular and Activity Digital are two such examples.)

  1. Hard press the watch face on your Apple Watch.
    Tap Customize.
    apple-watch-now-playing-complication-800x471.jpg

    Swipe left until the large text-based complication space is highlighted.
    Turn the Crown to scroll through the options until you get to the Now Playing complication (also shown as 'Tap to Open' in the text space).
    Press the Crown twice to set the complication and exit Customize mode.

Article Link: How to Stop Your Apple Watch From Launching the 'Now Playing' App When Audio Plays on Your iPhone
 

steve217

macrumors 6502
Nov 11, 2011
289
316
NC
It would be nice to be able to enable 'Now Playing' based upon the paired device. For example, when the phone is streaming to the car, I don't need 'Now Playing' from the watch - I can use the car controls.

When the phone is streaming to my AirPods, then auto-'Now Playing' would be my preference.
 
Comment

Kabeyun

macrumors 68040
Mar 27, 2004
3,050
5,726
Eastern USA
Handy tip, thanks Tim. Was wondering about this. A little irritating default behavior for me, as Now Playing appears with anything with an audio feed (YouTube stuff, web videos, etc.). Never really explored watchOS as thoroughly as I should’ve.
 
Comment

HaywireTX

macrumors newbie
Feb 8, 2017
20
33
Thank you, thank you, thank you! I might actually like my Apple Watch again. Whoever thought this was a good idea is clueless.
 
Comment

sully54

macrumors 6502
Sep 15, 2012
292
567
Canada
This is great! Was wondering about this.

Enjoying these how-to posts. Keep em coming!
 
Comment

Ted13

macrumors 6502a
Dec 29, 2003
620
324
NYC
Thank you, thank you, thank you! I might actually like my Apple Watch again. Whoever thought this was a good idea is clueless.
Well it is my favorite app on the Apple Watch, I am immensely grateful it works the way it does by default. I listen to podcasts via Overcast every morning on the long dog walk with Air Pods, and the ability to instantly adjust volume via the crown, skip back/forward 30 secs, pause or play is things I do constantly - talking to people, load street noise, etc. etc. My phone never comes out of my pocket. Far and away the most useful feature on the Apple Watch
 
Comment

B4U

macrumors 68030
Oct 11, 2012
2,897
2,858
Undisclosed location
Now, how do I stop the “now playing” to auto launch when I use the workout app in the watch?
I don’t even listen to the music on the phone when doing my workout.
 
Comment

Mike Oxard

macrumors 6502a
Oct 22, 2009
804
456
It would be nice to be able to enable 'Now Playing' based upon the paired device. For example, when the phone is streaming to the car, I don't need 'Now Playing' from the watch - I can use the car controls.
This would be great, while driving through winter my coat was nudging the crown, continually adjusting the volume.
 
Comment

npete

macrumors newbie
Mar 30, 2018
3
0
When I try to add the “Now Playing” complication I do not see it. When I try to add it in one of the small boxes I only see the music complication which is for playing music on the watch and doesn’t seem to have an effect on the music I am playing on my phone. Am I doing something wrong? Or is it only available in the middle/short/wide box?
 
Comment

machumors90

macrumors member
Oct 24, 2017
33
12
ABQ
I actually was sitting at the ATL airport and noticed this girl in front across from me that had the "Now Playing" card up on her Apple Watch. I knew how frustrating it was that this kept showing up for me, so I walked over to her and said "I know I'm a total stranger, but if that annoys you, let me show you how to fix it" to which she quickly responded "YES PLEASE I GOOGLED HOW TO STOP IT FROM POPPING UP BUT I COULDN'T GET IT TO STOP".
Literally went *click*click*click* and she gave me a hug. A perfect stranger gave me a hug for fixing this for her.
 
Comment

wilef

macrumors newbie
Aug 23, 2016
24
40
I'd like Now Playing to show up when I'm actually listening to music or an audiobook, but not pop up when browsing an article that happens to have a video playing. Selectively picking which apps auto-start the Now Playing app would work...
 
Comment

yallmeansall

macrumors newbie
Dec 13, 2017
6
1



How to Enable the 'Now Playing' Complication
Before following these steps, make sure you're using a watch face that accepts text-based complications (Modular and Activity Digital are two such examples.)

  1. Hard press the watch face on your Apple Watch.
    Tap Customize.
    apple-watch-now-playing-complication-800x471.jpg

    Swipe left until the large text-based complication space is highlighted.
    Turn the Crown to scroll through the options until you get to the Now Playing complication (also shown as 'Tap to Open' in the text space).
    Press the Crown twice to set the complication and exit Customize mode.

Article Link: How to Stop Your Apple Watch From Launching the 'Now Playing' App When Audio Plays on Your iPhone

Here's my problem: Both on WatchOS 3 and 4, "Now Playing" has never been a complication available to me. All other parts of your good article I am aware of and they work well for me, but I cannot get the super useful "Now Playing" feature to give me a complication as an option.
 
Comment

jrummer

macrumors newbie
Sep 1, 2009
5
0
Here's my problem: Both on WatchOS 3 and 4, "Now Playing" has never been a complication available to me. All other parts of your good article I am aware of and they work well for me, but I cannot get the super useful "Now Playing" feature to give me a complication as an option.


the Now Playing complication is no longer an option in Modular.
its available in chronograph
 
Comment

rom3o

macrumors regular
Dec 22, 2014
191
232
What do I do if the auto launch option is disabled (checked both on the watch and in the iPhone app) but the media controls keep showing up? This is driving my crazy ever since I got the Apple Watch two months ago. Already tried resetting it but the toggle still doesn’t change the behaviour of the media controls...
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.