How to switch off video files preview in Finder column view ?

Discussion in 'macOS' started by Piepz, Apr 25, 2007.

  1. Piepz macrumors member

    Joined:
    Feb 7, 2007
    Location:
    Riga, Latvia
    #1
    Hello,
    I recently just bought an iMac (I'm a switcher) and everything's fine so far, except I hate that Finder wants to preview all my video files in column view when I roll on them and even in "get info".
    Is there a way to switch off this? It seriously slows down my system..

    Thanks in advance.
     
  2. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #2
    Click the little triangle next to the preview to collapse it. It's all or nothing however; this will turn off the previews for all documents.
     
  3. Multimedia macrumors 603

    Multimedia

    Joined:
    Jul 27, 2001
    Location:
    Santa Cruz CA, Silicon Beach
    #3
    Preview Column Does NOT Slow Down Any Macs

    No it doesn't. What makes you think so? There is nothing about the preview column that slows anything down. And I think you are overlooking the tremendous value that column provides. Are you running on 512MB of RAM or what? What iMac did you just buy? :rolleyes:
     
  4. Piepz thread starter macrumors member

    Joined:
    Feb 7, 2007
    Location:
    Riga, Latvia
    #4
    Look at my sig.

    I don't like that it tries to load video, that's all.
     
  5. Multimedia macrumors 603

    Multimedia

    Joined:
    Jul 27, 2001
    Location:
    Santa Cruz CA, Silicon Beach
    #5
    It Does Not Try To Load Video

    It doesn't try to load video. It shows a still of the opening frame with a player in the OFF position. You can play it if you like. But it does NOT take power away from your iMac to show those mini QT players in the next column. Are you double clicking? You should only be single clicking or using the up-down arrows to navagate in column view. If you double click on a QT movie it launches the QT player. But that has nothing to do with what you see in column view which takes no power away from your processors.
     
  6. GodBless macrumors 65816

    GodBless

    Joined:
    Jan 22, 2005
    #6
    An option that might come in handy is turning off the preview column all together. Here is a list on how to do this:
    1. Open a window in column view
    2. While the window (in column view) is open select the "View" Finder menu (on the top bar on the screen) and choose the option "Show View Options"
    3. Un-check the box that is called "Show preview column"

    I hope this helps. :)
     
  7. t1937r0 macrumors 6502a

    Joined:
    Sep 5, 2006
    #7
    Have you ever tried to use the up and down arrows in column mode to select one file out of a large number of .m2v and .ac3 files? You know, like those used in dvdsp projects? Or accidently left clicked (once) on an m2v file when you meant to click on the corresponding ac3 file? On a powerbook G4? With the quicktime mpeg-2 component installed? There is a very long pause while finder tries to display the preview for each m2v file. While this is happening, Activity Monitor claims that finder is using ~10% of the CPU, and is reading large quantities of data from the hard drive. Indeed, for a few seconds (depending on the size of the m2v file) Activity Monitor even says that Finder is (Not Responding). It seems that finder has to read the whole m2v file before it can display the first frame.

    It happens on my Intel Core Duo Mac Mini also.

    And both of these machines have their full complement of ram.

    I suspect it is the mpeg-2 playback component for quicktime.
     
  8. mara macrumors newbie

    Joined:
    May 5, 2003
    Location:
    Helsinki, Finland
    #8
    Yes it does. Everytime I forgot to turn preview off (for navigating through some video files and if QT does not have the codec to play it) I have to force quit the Finder as it is not responding (we are talking about 2-5 minutes not seconds...).

    Oh and btw I'm on MB CD 2.0 with 2 gigs of ram...
     
  9. jaglad macrumors member

    Joined:
    Apr 18, 2007
    Location:
    Royston, UK
    #9
    I have to agree with Multimedia here, OSX doesnt load the video when in column view, it loads the first frame only, I have just been through some videos on my macs and each one does the same, just loads up the first frame and doesnt slow anything down.

    Sounds like you have an issue somewhere, have you tried repairing disk permissions??? If your new to macs and never done this, disk utility can be found in Applications > Utilities > Disk Utility. Open it up and click on your hard drive, then choose Repair Disk Permissions. This should usually be done after installing any OSX updates or if something doesnt seem to be working right.
     
  10. XIII macrumors 68040

    XIII

    Joined:
    Aug 15, 2004
    Location:
    England
    #10
    Same thing happens to a lesser extent when its loading WMVs on my Core Duo iMac with 1.5GB of RAM.
     
  11. t1937r0 macrumors 6502a

    Joined:
    Sep 5, 2006
    #11
    Have you tried .m2v files greater than a couple hunderd MB created with DVD Studio Pro? If those work fine in preview, can you post details about your machine, ie CPU, disk drive type/speed, memory?

    Thanks!
     
  12. Piepz thread starter macrumors member

    Joined:
    Feb 7, 2007
    Location:
    Riga, Latvia
    #12
    Is there a way to turn off preview _only_ for video files, because I like preview for pictures..?
     
  13. Laslo Panaflex macrumors 65816

    Laslo Panaflex

    Joined:
    May 1, 2003
    Location:
    Tokyo
    #13
    .m2v files created with compressor have never worked well in the preview of the finder, since as far as I can remember it's always taken 30secs to a minute to generate the preview. It's a horrible bug that I wish apple would fix, I hate it when I accidently click on a single .m2v file when in column view, I usually force quit the finder.
     
  14. Multimedia macrumors 603

    Multimedia

    Joined:
    Jul 27, 2001
    Location:
    Santa Cruz CA, Silicon Beach
    #14
    My Apologies. You're right. I was wrong. Exception For Those Type Files

    I forgot about this exception. You are totally correct. My bad. I apologize. I know what you mean. It's a real pain in the rear when that happens. I guess turning off preview in the view options is the best way to avoid this problem.
     
  15. jaglad macrumors member

    Joined:
    Apr 18, 2007
    Location:
    Royston, UK
    #15
    To be honest I have never tried a .m2v file and as every one else talks about this problem then I will experience the same. But for just .mov files etc then I dont have any problems.
     
  16. mainstreetmark macrumors 68020

    mainstreetmark

    Joined:
    May 7, 2003
    Location:
    Saint Augustine, FL
    #16
    Surely you must realize it must load the video file to even get to the first frame, right? You can even see the spinning prickly wheel thing, indicating it's working on something.

    The dude has a legitimate issue. If the movie it tries to preview, it's a significant pain, much worse in Panther. While it's loading said file (even if it's small, and in non-autoplay mode), Finder won't do anything else during this time, like it should.

    What he's probably asking is if there's a hidden plist pref you could set that would turn QUICKTIME preview off, or, more generically, don't try to load the preview if the file in question is significantly sized.
     

Share This Page