How to switch on two factor authentication?

Discussion in 'OS X El Capitan (10.11)' started by mujtaba.mir, Jan 5, 2016.

  1. mujtaba.mir macrumors regular

    mujtaba.mir

    Joined:
    Oct 16, 2014
    #1
    Ok, so I have got two step authentication on for like forever and I have been very patient waiting for the two factor authentication to get turned on for my Apple ID, sadly no luck there.

    Any one has a clue on how to force it through?

    Running 10.11.2 on 2015 rMBP
    and iOS 9.2.1 on iPhone 6
     
  2. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
  3. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #3

    Make sure all your devices are compatible. I wanted it for a while and it wouldn't let me until I removed my 3rd gen. Apple TV, then I was able to opt-in and sign back in to the Apple TV.
     
  4. mujtaba.mir thread starter macrumors regular

    mujtaba.mir

    Joined:
    Oct 16, 2014
    #4
    I still have the recovery key option.
    --- Post Merged, Jan 5, 2016 ---
    I have got all the compatible devices. Not sure what the missing piece in the puzzle is. :|
     
  5. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #5
    Apple says the system requirements are:
    If you have other devices signed into your Apple ID account, you will not be able to see the option for 2-factor. Even with the proper requirements, you still may not see the option, and if that's the case, you apparently need to keep waiting for Apple to offer you 2FA.
     
  6. mujtaba.mir thread starter macrumors regular

    mujtaba.mir

    Joined:
    Oct 16, 2014
    #6
    I meet these requirements. Guess will have to wait more. :eek:
    Just out of curiosity, do they send you an email saying you are now eligible for 2FA or you have to turn off two step authentication on your account and then see if 2FA is there or not?
     
  7. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
    #7
    I don't recall waiting for anything. I just enabled it and it was on.
     
  8. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #8
    I think you have to turn it off then go to Settings > iCloud > (name) > Password & Security and tap on Enable Two-Factor... (on the iPhone, I'm not sure the steps on the Mac).
     

Share This Page