How to synch sent e-mails in Mail using Gmail

Discussion in 'Mac OS X Lion (10.7)' started by hamsterburger, Feb 21, 2012.

  1. hamsterburger macrumors member

    Joined:
    Mar 28, 2007
    #1
    Hi I’m using Mail as my e-mail client with a Gmail address on a MacBook pro running OS X 10.7 Lion.

    When I send emails from my address on another computer it does not show up in the sent folder in Mail on my MacBook Pro, however all emails to my inn boxes show up both places. How can I make my Sent folder behave just like my inn box, i.e. make sure that my sent folder is identical whether I access it in Mail or using google.com on another computer?

    Also, some time ago for some reason all my sent emails older than a year were downloaded to the sent folder on my mac, so I no longer have them available on line. This is particularly problematic when I need to check older sent emails and am not on my MacBook. How can I upload these downloaded emails to my online Gmail account?

    All these mails are fairly small size. There are no big attachments so it should not be a size issue.

    Any help on this issue would be much appreciated.

    Thanks :)
     
  2. Waterbabies, Feb 21, 2012
    Last edited: Feb 21, 2012

    Waterbabies macrumors newbie

    Joined:
    Feb 21, 2012
    #2
    What I do is use file sharing, and just import the sent items mailboxes into the Mail on the other computer. eg, I have an ibook and a mac mini. File sharing is switched on on both. If I want to have a copy of the messages I have sent from the mac mini, on the ibook, I just do an import into the ibook mail (and vice versa. ( I usually do this every week or so on both computers) Then I move the sent mail messages from the import into the correct mailbox at the top. Seems to work OK for me, and although it isn't a true sync, as you have to remember to do it, it does mean that you have at least a fairly up to date record of what you've sent.

    There's probably a simpler way, but I'm not a whizz kid - I just get by!

    EDITING!

    Sorry! That's wrong! That's what I tried initially, but it doesn't work with Lion, because the library is hidden. What I do with the ones on the Mac Mini, (Lion) is copy the mailboxes V2 folder onto an external hard drive, and then import them onto then ibook from that. I have 10.5.8 in the ibook, so it works fine that way. I just put the mailbox folder into file sharing on that, so I can do it the first way.
     
  3. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
  4. hamsterburger thread starter macrumors member

    Joined:
    Mar 28, 2007
    #4
    Hi. Thanks for replying

    The account info in Mail says Google IMAP.

    @waterbabies: Sorry if I did not make my self clear. I only have one computer. What I am asking abut is how to make sure my sent messages in Mail on that computer will be the same as the sent messages on my Google account when I access it via browser on any computer.

    Any Ideas?
     
  5. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #5
    I'm not on my Mac, so I can't test this. With Exchange you can set which folder is you send items folder. I assume it might also be the case with IMAP. I'm guessing your Mac is using one folder for sent items and GMail (from the browser) is using another.

    Try this (or something close to this):
    1. Click and highlight the folder for your account that GMail using for set items. You may need to expand all folders and find it in the folder tree.
    2. Click the "Mailbox" menu
    3. Choose "Use This Mailbox For"
    4. Choose "Sent"
     
  6. hamsterburger, Feb 23, 2012
    Last edited: Feb 24, 2012

    hamsterburger thread starter macrumors member

    Joined:
    Mar 28, 2007
    #6
  7. hamsterburger thread starter macrumors member

    Joined:
    Mar 28, 2007
    #8
    Ok...

    Thanks, none of the options on the last link were different from the settings I already had.

    I have tried checking and unchecking the "store sent messages on the server" tab in advanced options on my mac.

    The result is that every single sendt e-mail has now been deleted from my gmail online and downloaded to my computer. Damn!

    How can I get these up on my gmail server again? Please help
     
  8. djjonnyd macrumors newbie

    Joined:
    Oct 12, 2012
    #9
    I'm having the same problem!!!

    I want to know how to import all my "sent" email from my Gmail account (I can see them online!) to the Mail app on my MacBook Pro.
    Ex. I need the emails from before July 2010 (when I got this comp) to be in my "Sent" folder.
    Any knowledge on this?!?
    thanks :)
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #10
    If you set up the Mail app account as IMAP with GMail then follow the instructions in post #5 above, it will do what you want.
     
  10. djjonnyd macrumors newbie

    Joined:
    Oct 12, 2012
    #11
    been there, done that...

    Already completed before I even found this thread! All is does is sync current sent emails from here on out. It doesn't import old emails from the server.
    Am I doing something wrong?
    I would call apple, but they usually say "this is not supported because it's a Google issue"...
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #12
    Look in the Mailbox Behaviors section of Mail account prefs and make sure you have it checked on to save sent mail on the server.

    Also on gmail.com look in the settings and there is an area where you can check which IMAP folders you want to show in the Mail client. Make sure you have the sent folder checked in there also.

    As an aside... in the same gmail.com screen uncheck the "All Mail" share in IMAP folder as that creates double downloads (and space usage) for every message in Mail app.
     
  12. hamsterburger thread starter macrumors member

    Joined:
    Mar 28, 2007
    #13
    Hi again. Thought that I would try sorting this out once more. I have added a screen shot of mail.

    My regular sent messages (called "Sendt" in Norwegian) only contains the mails sent from this computer in that app, but the gmail folder in the bottom (called "Sendt e-post) has all sent emails from. How can i get mail to use the upper "Sendt" folder instead?

    Thanks
     

    Attached Files:

  13. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #14
    Try selecting the mail folder you want to use for sent then use the below menu option to choose that mail box for sent messages.

    [​IMG]
     
  14. hamsterburger thread starter macrumors member

    Joined:
    Mar 28, 2007
    #15
    Hi again. Thanks for replying.

    The choice to use the standard sent folder is grayed out.

    Can anyone who uses gmail and the OSX mail client post a screen shot of how it looks like to you? Are you able to use the standard sent folder like I assume one can with other mail clients than gmail?
     
  15. tony.b, Apr 24, 2013
    Last edited: Apr 24, 2013

    tony.b macrumors newbie

    Joined:
    Apr 24, 2013
    #16
    Hi,

    Gmail automatically stores all your Sent emails on server.
    in your Mac mail client:
    1. Turn-off "Store sent messages on the server"
    macmail.png

    2. Select (gmail's) "Sent" folder
    macmail2.png

    3. from menu choose -> Mailbox -> Use this mailbox for -> Sent
    (read the important notice below before making this step!)
    macmail4.png

    Important notice:
    macmail3.png
    step 3 will delete your Local Sent folder and Create a new one which is a duplicate of Gmail's Sent folder, and which will be Synced with your Mail Client sent emails and emails sent using Gmail/web/iphone..etc.

    in case you have important emails in your local sent folder which were not copied/synced to gmail, you better take another step and simply drag&drop a copy to gmail's sent folder before doing step 4.

    Hope that helps,

    Tony
     

Share This Page