How to turn mouse acceleration OFF?

Discussion in 'MacBook Pro' started by bloodlucky, Jan 19, 2014.

  1. bloodlucky macrumors newbie

    Joined:
    Jan 19, 2014
    #1
    Okay, there's a bit of a journey behind this problem and a sequence of bad decisions and messups that put me in the position I am in right now. Although the biggest purpose of my macbook pro (2011) is for schoolwork, I occasionally play Valve games through Steam such as TF2, Counter Strike, Half Life 2 and Garry's Mod. I was watching a youtube video about TF2 about a month ago and the commentator recommended that if you're having trouble aiming, you could turn off "mouse acceleration" in your computer, and he briefly explained what it was and why it affects your aiming performance. Well as soon as the video ended, I immediately googled how to turn it off, assuming my computer had mouse acceleration which was the reason for my relatively poor aim. As it turns out, mouse acceleration in my computer was ALREADY off, and I just really sucked at aiming. Of course, at the time I didn't know that, and went to this site in my ambition to turn off mouse acceleration which I didn't know was already disabled: http://osxdaily.com/2010/08/25/mouse-acceleration/

    If you scroll down the website, and look under the part that reads "How to disable or adjust mouse acceleration" you'll see a command that is given that the article claims will disable your mouse acceleration when entered into Terminal. I entered it, assuming I had nothing to lose, but boy I sure did. After entering the command into Terminal I logged out and back in, and immediately noticed a change in my mouse. It felt like I had less control over it but I was convinced that it was simply the "magic kicking in" until I went on TF2 and realized how badly I screwed up.

    Not only is it aggrevating to know that I've only worsened the situation, but it also feels incredibly uncomfortable just moving the mouse around when doing schoolwork. So I took my computer to the Apple store and the apple guy showed me to the mouse sensitivity section and told me to simply lower the bar, which should fix my problem. But he clearly didn't understand that mouse acceleration and sensitivity are very different, and mouse acceleration is relative to the distance of where the cursor travels according to the speed, and sensitivity only changes the speed of the actual mouse.

    So now I'm using my computer and no matter what I do I get this incredibly itchy feeling whenever I'm using the mouse to do anything, and I've looked through countless results in turning it off but all softwares that claim to kill mouse acceleration are not available for Lion (which I'm running on.) I can't imagine how it could be so hard, if it was turned on so easily then why is it seemingly impossible to disable? Does anyone know how to disable this?
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    Did you follow the instructions on the same page: "This is entered into the Terminal once and can be reversed or adjusted by changing the -1 at the end" and try different values in place of the -1??

    Failing that look in your Time Machine backup for an older version of the file (i.e. before you changed it with this command), and restore it.
     
  3. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #4
    I tried the same things as you but on newer OSX it didn't work to my satisfaction.

    The best thing I have found is this.
    http://forums.macrumors.com/showthread.php?t=812687

    http://ktwit.net/code/killmouseaccel

    It is some script that was once posted by some guy who put together a few terminal commands. It works best imo.
    It leaves you with a completely linear acceleration curve with no mouse acc. at all. It does require a decent mouse though. 800 dpi or some crap magic mouse will leave you with something so slow it is a pain. You also should NOT increase the mouse speed slider (sensitivity) beyond half way in the prefs as it gets really inaccurate very fast. Set it to one lower than the middle setting or right in the middle and adjust the mouse dpi if you can.
    Works great with around 1800-2500 dpi IMO. But <1200 is slow like crazy.

    Smoothmouse I think doesn't work on Mavericks properly and many like Steermouse are shareware. All you need is some terminal commands.

    After OSX updates you need to reapply those changes sometimes.
     
  4. bloodlucky thread starter macrumors newbie

    Joined:
    Jan 19, 2014
    #5
    thanks guys. not familiar with time machine but opening it now

    ----------


    After I clicked your link killmouseaccel appears as a blank file. SmoothMouse 1.0.9 appears as a zip file. I wonder if its my end thats screwing up and not allowing compatibility with any of the recommended software..
     
  5. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #6
    you have to save it and then run it.
    It shouldn't be blank.
    Try this one.

    I tried Smoothmouse too once but that never really worked for me on the OSX Version I was on. Maybe they updated it now.
     
  6. bloodlucky thread starter macrumors newbie

    Joined:
    Jan 19, 2014
    #7
    Not working either. I can't imagine its unchangeable after accidentally enabling it, and Time Machine doesn't work because I don't own an AirPort Utility Hotspot
     
  7. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #8
    That's completely unrelated. Were you even using time machine to do backups in the first place?
     
  8. bloodlucky thread starter macrumors newbie

    Joined:
    Jan 19, 2014
    #9
    Not sure... I never knew what time machine was before this. (I'm 15 for ******'s sake)
     
  9. bloodlucky thread starter macrumors newbie

    Joined:
    Jan 19, 2014
    #10
    Awesome news!

    Okay, I found the easiest way to disable mouse acceleration, any 3 year old can do it and I can't believe nobody found this earlier. I went on this youtube video http://www.youtube.com/watch?v=nyBNIysnz2c and the title basically speaks for itself. Download SteerMouse, install it and it'll ask you to restart your computer. Then open System Preferences which SteerMouse can be accessed through. After you open the program, set your tracking speed to 0 and bam, you're home free ;)

    I feel like crying, the war is over

    I should write a book
     
  10. termhn, Nov 30, 2014
    Last edited: Nov 30, 2014

    termhn macrumors newbie

    Joined:
    Nov 30, 2014
    #11
    The post by dusk007 works a charm, thanks!

    Also, here's how to get it to run on startup:

    1. Download and unroll the tarball here: http://forums3.armagetronad.net/down...le.php?id=9698
    2. You should now have a file in downloads called killmouseaccel with no extension. I decided to rename it to killma (no extension still) for convenience and you should to to make the rest of the guide work.
    3. Right click and copy the newly renamed killma file
    4. In the top menu in finder click go and then go to folder and type in "/usr/local/bin"
    5. Paste (Command-V) killma into this folder
    6. You should now be able to open terminal (click spotlight or Command-Spacebar then type terminal) and then run:

    killma mouse

    to eliminate your acceleration.
    7. To make this automatically apply on startup, inside terminal do the following. It will ask for your password, when you type it it won't actually type any letters but you are actually typing. Just type in your password and hit enter:

    sudo mkdir /System/Library/StartupItems/killma && cd $_
    sudo nano killma.sh

    7a. You're now in a little text editor. Type the following:

    #! /bin/bash
    killma mouse

    7b. Press Control-X and then Y when asked if you want to save the buffer

    7c. Now run:

    sudo chmod +x killma.sh

    8. Done! It should kill your mouse accel at startup now.
     

Share This Page