How to turn of internal display with Lion?

Discussion in 'MacBook Pro' started by DYER, Jul 20, 2011.

  1. DYER macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #1
    Ok guys I have been using a Apple cinema display with my Late 08 macbook pro ever since I got it. However I have with Leopard and Snow Leopard always had the internal display switched off yet kept the laptop open due to it overheating easily when running apps such as Photoshop.
    My question to you: How do I make this happen with Lion?
    Every time I open or close my Mac the display shuts down or activates!!!
    I just want the internal display to stay off but there are no options for this in the display settings.

    Any help would be extremely appreciated!

    Sorry if this has been answered, I searched the forums to no avail.

    Chris
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    I'm pretty sure this would still work properly.

    http://support.apple.com/kb/ht3131
     
  3. DYER thread starter macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #3
    Sadly it doesn't instead of powering down when you close the lid it just switches off the internal display. The second you re-open the laptop it switches the display back on.
    This is what I need to try and get around :(
     
  4. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #4
    You are probably doing something wrong. I've used clamshell mode plenty of times.

    Do you wake the computer up using an external device before re-opening the lid? If not, the behavior you're seeing is normal.
     
  5. mac00l macrumors 6502

    Joined:
    May 3, 2011
    #5
    Not with Lion.

    It seems so far that your only option is to wait for an update. You can search in the OSX Lion forum, and there are plenty of people with your issues.
     
  6. DYER thread starter macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #6
    Sadly not.

    Seems I am not the only one either.

    https://discussions.apple.com/message/15662934#15662934
     
  7. DYER thread starter macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #7
    It would appear as thought this is just going to be one of those things someone will have to make a fix for or Apple will need to change.
    I am now satisfied there are NO settings in Lion to allow the internal display to be both open and switched off.

    So if anyone would like to make a fix… :D:D:D
     
  8. DYER thread starter macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #8
    Interim solution.

    Ok one workaround is to use SwitchResx.
    Download the app and run it and it gives you the option to 'deactivate' a display.
    Simple deactivate it in the settings menu and you can use your computer with only one display.

    One caveat.
    It does not turn the display off.
    All your system resources are devoted to the external display - i.e. the mac does not 'see' the laptops display however it simply makes the screen 'black' but it is still switches on. Turn off the backlight and it is as good as off.
    However I do wonder whether you could damage the display by having a load of black pixels constantly stuck on it?
     
  9. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #9
    very interesting. It was somewhat slightly annoying to have to close lid then power up externally to get it work every other time (though I got used to it) but this is definitely a bug.

    I agree with the sentiments in the apple forum post. http://www.apple.com/feedback/ give em feedback and let em know it's not working correctly.
     
  10. DYER thread starter macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #10
    OK The best fix anyone has come up with as of yet - and I really like this one, is to use a magnet on the right side of your mbp to make it think it is closed when it is not!

    Works a charm.
     
  11. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #11
    Very mcgyver like :D
     

Share This Page