How to turn off airport automatically when physically connected with cable

Discussion in 'macOS' started by TortoiseAvenger, Mar 11, 2008.

  1. TortoiseAvenger macrumors newbie

    Joined:
    Feb 21, 2008
    #1
    Hello. My mac laptops always bring up that annoying wireless network selection window upon opening, even when I'm connected through a physical cable. Is there any way to automatically turn the airport off when physically connected? This seems like something that should be easy...

    Tortoise
     
  2. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #2
    In system preferences--network--you can select the order of service connections. Put cable higher on the list than airport, and it will automatically select that first.
     
  3. TortoiseAvenger thread starter macrumors newbie

    Joined:
    Feb 21, 2008
    #3
    Hum..... thanks, but ethernet is already higher.
     
  4. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #4
    Why not just turn off the automatic request to join an unsecured network? :confused:
     
  5. TortoiseAvenger thread starter macrumors newbie

    Joined:
    Feb 21, 2008
    #5
    The window that pops up includes all available networks, secured or not. I don't care too much about the airport being off, I just don't want it to look for networks when it's physically connected.
     
  6. ichiroboston macrumors newbie

    Joined:
    Sep 28, 2004
    #6
    I am currently trying to figure out a way to make this happen.
    I support a company with many macintosh laptops and cannot trust users to remember to turn off their airport when at their desk plugged into ethernet.

    Here is my reason for the need:

    1. If your airport is left on and it automatically connects to an authorized base station it will use an IP on your network, even if airport is listed below Ethernet on the priority list. So your computer will use 2 IP's from your DHCP pool.

    2. Kind of a security hole, I filled this with apple but nothing much happened.
    For example:
    You are connected to your LAN via Ethernet AND your Airport is also on and connected to an "outside" wireless network (for example, "linksys";) )
    Your computer is actually connected to both networks at the same time. BUT since "Ethernet" is the priority in the network list all outgoing and incoming packets comes through the Ethernet port.... BUT!!! Since your Airport is also connected with a valid IP address (supplied by "linksys") your computer will accept any incoming packets and requests!!!

    You can test this (you will need 2 computers):

    Open up System Preferences and turn on file sharing.
    Keep your System Preferences open.

    Plug in your Ethernet cable, turn on Airport and select your network (the same network as your ethernet connection).

    Open your Network in your System Prefrences and select Airport, click advanced and find your IP# that your Airport connection has (which is different than the IP# of your Ethernet connection)

    Remember, your Ethernet is prioritized higher than Airport connection.

    Go to your other computer and try to connect (file sharing) using the IP# which you got from the airport system preferences of the main computer... it connects!

    Im sorry if this post is kind of confusing, I think it's difficult to explain this in words..

    We are trying to write a simple control panel which if it detects an ethernet link, it will automatically shut off Airport.

    This has become a huge problem in enterprise since each computer ends up using 2 IP's and not to mention the security issues.

    If anyone has any suggestions please pass them over.
    Thanks!
    Ichiro
     
  7. Tubercles macrumors newbie

    Joined:
    May 14, 2009
    #7
    How to turn off airport automatically when physically connected with cable

    Hi ichiroboston,
    Have you had any luck with your solution yet? We have the exact same problem as you described. I am also looking at writing a script to turn of airport when ethernet is plugged in.
    Can you let me know if you have had any success. This is a real pain in the butt.
    Cheers
     
  8. ichiroboston macrumors newbie

    Joined:
    Sep 28, 2004
    #8
    Nope, I could not find or create a good solution.

    I added this to Apple's bug report but they closed it without any solution.

    Sorry,
    Ichiro
     

Share This Page