Resolved How to turn off automatic numbering/bulleting in Pages '09

Discussion in 'Mac Apps and Mac App Store' started by sun surfer, Sep 10, 2011.

  1. sun surfer, Sep 10, 2011
    Last edited: Sep 11, 2011

    sun surfer macrumors regular

    Joined:
    Jun 6, 2010
    #1
    Help! I have a very long list (over a thousand numbered items) that I need to copy from a document and paste into Pages to edit. However, the list is broken up many times over with different titles/headers throughout the list which are in the document that I'm copying and pasting, which is the way I need it pasted into Pages.

    I first tried to just paste it. It automatically bullet numbers EVERYTHING, so everything is re-numbered to include all the titles/headers throughout the list. When I used the inspector to choose "no bullets" after selecting all, it takes ALL the numbers off.

    Before I paste it, the inspector says "no bullets", so even though it already is set to "no bullets" it still automatically puts bullets in the list when I paste. To go through and manually correct everything once pasted would take forever. There must be a way to fix this!
     
  2. radicalcentrist macrumors member

    Joined:
    Dec 10, 2008
    Location:
    Portland, OR
    #2
    First off, a question. As you go through the original document, do the headers show up as a different style?

    Secondly, if you click onto a line that should be headlined in the pages doc, does it show up as a different style as the other lines?

    If so, you can right-click on the style in pages and "select all instances," then just change the bulletin for those specific ones.

    If they're not already a different style (between the numbered lists and the headlines), you're probably SOL.
     
  3. sahnert macrumors 6502

    Joined:
    Oct 20, 2003
    Location:
    Seattle
    #3
    Pages Menu > Preferences > Auto-Correction > uncheck "Automatically Detect Lists"
     
  4. sun surfer thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #4
    radicalcentrist, what do you mean by "style"? They are the same font as the list, but they are a different size and they are bolded. If that is sufficiently different, I don't know where to "right click style" at.

    I thought this would work. I unchecked it yet it still automatically numbers/bullets the list!
     
  5. radicalcentrist macrumors member

    Joined:
    Dec 10, 2008
    Location:
    Portland, OR
    #5
    One of the beauties of Pages is that you can create "styles" incredibly easily (which format multiple pieces of text in the same manner).

    Paste your list into Pages. Then click into a line that is supposed to be a headline. Then, click on the small blue circle with the paragraph character in top lefthand corner of the editing bar. A drawer will slide out with a variety of "styles." If you click on one, it will apply that style to the line you're on.

    Once you have the styles drawer visible, see if it changes when you cursor up or down from the headline to a properly numbered line. If it does, you're in luck. Put your cursor on the line of a headline and then hover over the style until you see the grey down arrow. Click on it, then click on "select all uses of...." Once all of your headlines are highlighted, go into the Inspector (Command-I) and change those to not be in list form.

    Like I said, this all only works if the styles are different between the headlines and the lists.
     
  6. sun surfer thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #6
    I really wish that would work but it doesn't seem to. :( I did it, and I thought it worked, but it only selects that one line, even though all headers are the same style. I tried another random header and same thing, it only selected the one line. Argh!
     
  7. radicalcentrist macrumors member

    Joined:
    Dec 10, 2008
    Location:
    Portland, OR
    #7
    Another idea....Find and Replace can do pretty advanced style replacing. Try to identify anything specific formatting that the headlines have that the properly enumerated lists don't. Try replacing that with a uniform style (set one header as you'd like it, click the red downward facing arrow and create a new style from selection. Then try F&R for the formatting differentiation, replacing it with your new style.
     
  8. sun surfer thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #8
    OMG I was skeptical after the other similar thing didn't work, but that worked radicalcentrist! Thanks so much; it saved me so much time and I would've NEVER figured that out myself! :D
     
  9. radicalcentrist macrumors member

    Joined:
    Dec 10, 2008
    Location:
    Portland, OR
    #9
    Terrific! Glad I could help. I spend a lot of time formatting pasted material, so I definitely feel your pain. Feel free to private message me if you have any other questions!
     

Share This Page